Subject: [Isis-wg] Simplified Extension of LSP Space for IS-IS Draft

From: "Les Ginsberg \(ginsberg\)" <[email-masked]>
Date: Sat, 1 Apr 2006 22:21:14 -0800

Folks -

The draft describing the alternative to RFC 3786 is now available.

http://www.ietf.org/internet-drafts/draft-ginsberg-isis-extlsp-00.txt

   Les

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 06 Apr 2006 11:00:37 +0200

les,

i have read through your draft and do think that there may
be a simpler fix to all of the fragment scalability problems.

basic idea is to introduce a kind of connector-TLV
where you can link arbitrary information to a diffent sysid
in an additive fashion. unlike the IS ALias TLV it does not
work at the SPF level but rather at the TLV parser level
inside a router which extracts information and adds it
to the internal representation of the LSDB.

---

for example lets assume that a node has two sysids

1921.6800.1001  (main sysid)
1720.1600.1001  (leaf sysid)

in the main LSP we announce all SPF relevant information.

<lsp sysid=1921.6800.1001>
   <area>
   <nlpid>
   <te-id>
   <ip-interface>
   <hostname>
   <extd IS reach>
      <neighbor sysid = xxxx.xxxx.xxxx metric 3000 no-subltv>
   </extd IS reach>
</lsp 1921.6800.1001>

in the leaf LSP we announce all non-SPF relevant information

<lsp sysid=1720.1600.1001>
   <connector sysid=1921.6800.1001>
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   <extd IS reach>
      <neighbor sysid=xxxx.xxxx.xxxx metric 0>
        <unreserved bandwidth>
   </extd IS reach>

   /* occurence of a connector TLV links all TLV / subTLV
      information found in that fragment in an additive fashion.
      so we may repeat the extd-IS reach attribute with different subTLV content.
    */

   <extd IS reach>
      <neighbor sysid=xxxx.xxxx.xxxx metric 0>
        <interface-address>
        <neighbor-address>
        <unreserved bandwidth>
   </extd IS reach>

</lsp 1720.1600.1001>

a receiving router should add all information found in a fragment
containing the connector TLV in an additive fashion upon installation in the
local representation of the LSDB. for subTLV information the higher-level
TLV information serves as key. (in our example sysid is the key for any subTLVs
linked)

what needs to be taken care is security/purging related stuff if some external node
wants to link information.

what do you think ?

/hannes