Subject: [Isis-wg] WG review of draft-ietf-ccamp-automesh-01.txt before CCAMP LC

From: David Ward <[email-masked]>
Date: Wed, 16 Aug 2006 19:47:23 -0500

All -

    Please give final review and last comments on
draft-ietf-ccamp-automesh-01.txt  as the CCAMP WG would like to LC the
document.

http://www.ietf.org/internet-drafts/draft-ietf-ccamp-automesh-01.txt

-DWard

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Stephen Nadas \(RL/TNT\)" <[email-masked]>
Date: Fri, 18 Aug 2006 08:03:22 -0500

My comments are as follows: 

Abstract 
--------
1st sentence: 
s/set up/setup/
s/Path/Paths/

Introduction 
------------
3rd para: 
consider: s/well identified/pre-identified/ I suspect this is closer to
what is meant 

4th para: 
s/set up/setup/

section 2.
----------
	last para, last sent. consider s/one or more/zero or more/

section 3.2. 
------------
	consider: 
	- A Tail-end address (used as the TE LSP tail-end address by
other LSRs
				            ^^^ 		     
          belonging to the same mesh-group when they setup LSPs to this
LSR).
 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ 

section 4.1 
-----------
	1st para under figure 1 and 
section 4.2
----------- 
	1st para 

        consider putting penultimate sentence of the para 1st and as a
separate
        paragraph. (ie "The TE-MESH-GROUP TLV is used to advertise the
desire of 
        an LSR to join/leave a given TE mesh-group.")  this would
separate some 
        of the TLV coding details from the reason for sending it 

section 5.
----------
	what is behavior when TE-MESG-GROUP TLV appears more than once? 
	Undefined? 1st TLV wins? Last TLV wins? 
 
section 5.1.
------------ 
	2nd para, 1st sent. s/TLV changes/TLVs change/	 

section 5.1 (2nd para) & 5,2 (1st para)  
---------------------------------------
consider
   
   When an LSR wants to join another mesh group, the information for
   that new mesh group will be added to the TE-MESH-GROUP TLV;
   conversely, when the LSR leaves a mesh-group the information for that
   mesh-group will be removed from the TE-MESH-GROUP TLV.

instead of 

   In the case of a join, a new entry will be added to the
   TE-MESH-GROUP TLV; conversely, if the LSR leaves a mesh-group the
   corresponding entry will be removed from the TE-MESH-GROUP TLV. 

Steve 

Stephen Nadas                           Ericsson IPI       
[email-masked]              920 Main Campus Dr. 
Voice:  +1-919-472-9935 Fax: x/9999     Suite 500 
Mobile: +1-919-522-0991 ECN: 802 29935  Raleigh, NC 27606

-----Original Message-----
From: David Ward [mailto:[email-masked]] 
Sent: Wednesday, August 16, 2006 8:47 PM
To: [email-masked]; David Ward; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: [Isis-wg] WG review of draft-ietf-ccamp-automesh-01.txt
beforeCCAMP LC

All -

-DWard

---

From: Ross Callon <[email-masked]>
Date: Fri, 18 Aug 2006 21:04:11 -0400

>http://www.ietf.org/internet-drafts/draft-ietf-ccamp-automesh-01.txt

Just to be clear on process: This document has already been last called
in the CCAMP working group and been submitted to the IESG for
publication. However, since this document makes changes / extensions
to IS-IS (and to OSPF), it needs to be last called also in the IS-IS (and
OSPF) working group(s).

We would appreciate comments if any within the next two weeks,
particularly on any implications that this could have on the overall
operation of IS-IS.

Thanks, Ross

---

From: JP Vasseur <[email-masked]>
Date: Thu, 31 Aug 2006 07:03:28 -0400

Hi Stephen,

Thanks for your comments that will be incorporated in a new revision  
- Few comments below,

> My comments are as follows:

Has been replaced by "An LSR may belong to more than one TE mesh-group 
(s)".

> section 3.2.

The current text in the document is actually correct.

> section 5.

"The TE-MESH-GROUP TLV is OPTIONAL and must at most appear once in a  
OSPF Router Information LSA or ISIS Router Capability TLV." Note that  
must is actually a MUST.

Thanks.

JP.