Subject: [Isis-wg] ISIS Authentication Problem

From: Pranjal Chakravarty <[email-masked]>
Date: Thu, 29 Jan 2009 07:11:06 +0530 (IST)

Hello I have a problem with ISIS area/domain authentication.
Suppose we have two Routers(maybe cisco)
We configure area authentication password in both routers
 
R1>area authentication sprint
R2>area authentication sprint
 
Now there is no problem both routres remain adjacent and both routers accept others LSP and ISIS routes are present in both routers.
 
Now we change area authentication password in one of the routers.
 
R1>area authentication tata
 
Now in R1 Immediatly Other routers(R2's) LSP will be deleted from its database and ISIS Routes that it learnt from R2 will be deleted.
 
But in router R2, LSP of R1 is not becoming lifetime zero and R2 is not deleting ISIS routes which it learnt from R1 even though area password s are diffrent now .
 
,The database gets cleared and ISIS routes are deleted only after we give clear isis * command.in R2 Router.
 
Is it a problem ... 

      Unlimited freedom, unlimited storage. Get it now, on http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Tony Li" <[email-masked]>
Date: Wed, 28 Jan 2009 22:42:03 -0800

Hi Pranjal,
 
Well, it's not a protocol issue.  ;-)  Whether or not you consider it a bug
is more of an operational question.
 
>From the perspective of R2, nothing has gone wrong.  R2 is going to start
hearing new LSPs from R1, but those LSPs are going to contain the wrong
authentication information.  R2 then correctly _ignores_ the new, 'bad'
data.  
 
Note that it would be a bug if R2 was to perform any substantive action on
receipt of an incorrectly authenticated LSP.  Doing so would create a huge
DoS vector.
 
If your concern is password transitioning, an implementation is free to
accept multiple passwords on receipt.
 
Regards,
Tony

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Pranjal Chakravarty
Sent: Wednesday, January 28, 2009 5:41 PM
To: [email-masked]
Subject: [Isis-wg] ISIS Authentication Problem

 
Now there is no problem both routres remain adjacent and both routers accept
others LSP and ISIS routes are present in both routers.

 
Now in R1 Immediatly Other routers(R2's) LSP will be deleted from its
database and ISIS Routes that it learnt from R2 will be deleted.
 
But in router R2, LSP of R1 is not becoming lifetime zero and R2 is not
deleting ISIS routes which it learnt from R1 even though area password s are
diffrent now .
 
,The database gets cleared and ISIS routes are deleted only after we give
clear isis * command.in R2 Router.
 
Is it a problem ... 

  _____  

Explore your hobbies and interests. Click
<http://in.rd.yahoo.com/tagline_groups_6/*http://in.promos.yahoo.com/groups/
> here to begin.