Subject: Re: [Isms] Proposed SSH Transport Address Changes (and a quick nit)

From: <[email-masked]>
Date: Tue, 5 Aug 2008 12:33:48 +0300

Wes Hardaker wrote:
> 
> DH> I am of the impression this would require yet another 
> DH> mapping table to support a feature that is not needed by 
> DH> everybody. 
> 
> Actually, I think it drops the need for one.

This reply comes a bit late... but I think I agree with Wes here:
allowing "user@host" as SSH transport address could drop the need 
for one mapping table on notification originators (it's not that
important for command generators).

An administrator configuring TARGET-MIB will of course include the
securityName used for VACM, but that's *our* name for the *recipient*
(e.g. "joe", an administrator).  To actually open the SSH connection,
SSH will need to send *their* name for *us* (e.g. "router134").

Configuring an extra table mapping "joe,192.0.2.1" to "router134" will
of course work, but allowing "[email-masked]" as transport
address could be simpler to deploy.

(SSH will still need a mapping from "192.0.2.1" to the host public
key, and from "[email-masked]" to the password/private key,
but IMHO those really belong in SSH module, not on SNMP side.)

Best regards,
Pasi
_______________________________________________
Isms mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isms

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Wed, 06 Aug 2008 10:17:50 -0400

> important for command generators).

+1