Subject: [Isms] proposed quick changes to secshell section 3: drop 3.1.4 and 3.1.5

From: Wes Hardaker <[email-masked]>
Date: Tue, 21 Oct 2008 10:37:16 -0700

As Dave S. pointed out, the content of section 3.1.5 (Protection against
replay, delay and redirection) is redundant with text in at least 3.1.1.

I'm arguing that so is 3.1.4 (which is "privacy protocol support") which
basically currently says (roughly) "SSHTM supports encryption because
SSH does".  This is already stated as well in 3.1.1.

Thus I think they should both go away.
-- 
Wes Hardaker
Sparta, Inc.
_______________________________________________
Isms mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isms

---

From: "David Harrington" <[email-masked]>
Date: Tue, 21 Oct 2008 14:59:39 -0400

Hi,

I think my original intention was to have 3.1 describe just the
threats, and section 3.1.* describe the SSH mitigation of the threats.

If you want to eliminate the redundancy, I suggest taking the first
paragraph of 3.1.1 and put it into 3.1, and then move the remaining
sentences from 3.1.1 into the respective 3.1.* sections, thus
eliminating 3.1.1, and having each threat discussed in only one
sub-section.

dbh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Wes Hardaker
> Sent: Tuesday, October 21, 2008 1:37 PM
> To: [email-masked]
> Subject: [Isms] proposed quick changes to secshell section 3: 
> drop 3.1.4 and3.1.5
> 
>

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 21 Oct 2008 15:43:54 -0700

>>>>> On Tue, 21 Oct 2008 14:59:39 -0400, "David Harrington" <[email-masked]> said:

DH> If you want to eliminate the redundancy, I suggest taking the first
DH> paragraph of 3.1.1 and put it into 3.1, and then move the remaining
DH> sentences from 3.1.1 into the respective 3.1.* sections, thus
DH> eliminating 3.1.1, and having each threat discussed in only one
DH> sub-section.

So you're suggesting taking each bullet in 3.1.1 and breaking them into
their own sub sections (eg, 3.1.1.1)...  Doable, of course, but I don't
see the benefit of having extra sections instead of a numbered list.  I
think it's fine as is (after dropping the redundant 3.1.4/3.1.5 which
were basically covering 2/7th of the threats and the threats section
already discusses the SSH solutions to the threads).
-- 
Wes Hardaker
Sparta, Inc.
_______________________________________________
Isms mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isms

---

From: "David Harrington" <[email-masked]>
Date: Tue, 21 Oct 2008 21:01:20 -0400

Hi,

you misunderstood.
section 3.1.1 is to a large degree redundant with sections 3.1.*
I don't think 3.1.1 is needed; it can be folded into the following
sections.
The number of the following sections provides the (numbered) list of
threats.

dbh

> From: Wes Hardaker [mailto:[email-masked]] 
> Sent: Tuesday, October 21, 2008 6:44 PM
> To: David Harrington
> Cc: 'Wes Hardaker'; [email-masked]
> Subject: Re: proposed quick changes to secshell section 3: 
> drop 3.1.4 and3.1.5
>