Subject: Re: [Isms] COMMENT: draft-ietf-isms-radius-vacm

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 25 Aug 2010 10:53:53 -0700

Hi -

> From: "Adrian Farrel" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Wednesday, August 25, 2010 2:34 AM
> Subject: COMMENT: draft-ietf-isms-radius-vacm 
>
> Comment:
> 
> Thanks for this I-D. I have no objection to its publication as an RFC.
> 
> Section 4.1
> 
> I found the following sentence somewhat tricky.
> 
>    An implementation-specific identifier is needed for each AAA-
>    authorized "session", corresponding to a communication channel, such
>    as a transport session, for which a principal has been AAA-
>    authenticated and which is authorized to offer SNMP service.
> 
> The problem is around "implementation-specific" which implies that 
> there is a single identifier for all communication channels from any
> Company-X Product-Y device. Not what you mean!
> 
> If you have time to tweak this a little, that would be good.

I'm not able to parse the sentence in a way that yields the reading
you found problematic.  However, would something like this address
your concern?

   A unique identifier is needed for each AAA-authorized "session",
   corresponding to a communication channel, such as a transport
   session, for which a principal has been AAA-authenticated and
   which is authorized to offer SNMP service.  How these identifiers
   are assigned is implementation-specific.

N.B. - there are ongoing discussions in the WG about whether "AAA-authorized"
and "AAA-authenticated" might be open to misinterpretation, which might result
in other tweaks to this text.

> ---
> 
> Section 4.2
> 
> Not sure that the two uses of "MAY" in this section really need to be
> upper case, but it is not very important.

I agree that these might be border cases.  If the objection isn't a strong
one, I'll leave them as-is, since this is what the WG agreed to.  FWIW,
I *think* the usage is defensible in the context of specifying conformance
to an applicability statement, but I wouldn't put up much of a fight if
folks think it's important to change this to lower case.

> ---
> 
> Section 5.1
> 
> Would be nice to give a reference for the TCs mentioned.

Consider it done!

Randy

---

From: "David Harrington" <[email-masked]>
Date: Wed, 25 Aug 2010 20:45:29 -0400

Hi Randy,

I think we usually use implementation-dependent rather than
implementation-specific.
That's how I interpreted Adrian's comment.

my $.02
dbh 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Randy Presuhn
> Sent: Wednesday, August 25, 2010 1:54 PM
> To: Adrian Farrel; [email-masked]
> Cc: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: COMMENT: draft-ietf-isms-radius-vacm 
> 
> Hi -
> 
> > Cc: <[email-masked]>; 
> > <[email-masked]>

> I'm not able to parse the sentence in a way that yields the 
> reading you found problematic.  However, would something like 
> this address your concern?
> 
> and "AAA-authenticated" might be open to misinterpretation, 
> which might result in other tweaks to this text.
> 
> > ---
> > 
> > Section 4.2
> > 
> I agree that these might be border cases.  If the objection 
> isn't a strong one, I'll leave them as-is, since this is what 
> the WG agreed to.  FWIW, I *think* the usage is defensible in 
> the context of specifying conformance to an applicability 
> statement, but I wouldn't put up much of a fight if folks 
> think it's important to change this to lower case.
> 
> 
> > ---
> > 
> > Section 5.1
> >

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 25 Aug 2010 18:36:04 -0700

Hi -

Ok, I'll do a global replacement of implementation-specific with
implementation-dependent, as well as the change in phrasing.

Randy

----- Original Message ----- 
> From: "David Harrington" <[email-masked]>
> To: "'Randy Presuhn'" <[email-masked]>; "'Adrian Farrel'" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
> Sent: Wednesday, August 25, 2010 5:45 PM
> Subject: RE: COMMENT: draft-ietf-isms-radius-vacm 
>