Subject: [geonet/its] EtherType for geonet/ITS 0x8947 reflected at IANA (was: What do we need to make ITS WG go forward? - EtherType for ITS)

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 May 2014 13:24:02 +0200

Hello geonetters,

I would like to inform you that, following our discussions about 
EtherType for geonet, and per my request, and per designated reviewer 
for this entry - IANA has added an entry in the table of EtherTypes for 
0x8947 for GeoNetworking, as to reflect the IEEE allocation of same 
EtherType.

      http://www.iana.org/assignments/ieee-802-numbers

This is a good allocation which should help software designers in 
writing interoperable implementations of geonetworking code over link 
layers of type Ethernet, and in some cases, links dedicated to ITS 
vehicular communications.

Yours,

Alex

On 23/10/2013 17:41, Romascanu, Dan (Dan) wrote:
> Hi Alexandru,
>
> The authority for allocation is with the IEEE, and the list to be
> referenced and used in specifications is the one at IEEE.
>
> The IANA list is informational and includes as specified on the page
> 'contributed unverified information from various sources'. It would
> be good I think to have the new ethertype mentioned on the IANA page
> as well, because some IETF-ers may go first to that list. I suggest
> that you just send an email to IANA asking for the change (additional
> row in the table) be made according to the IEEE allocation. We can
> talk about this with the IANA folks in Vancouver if this is not
> solved until then.
>
> I am not sure who needs to be asked about the linux kernel patches, I
> can guess that a query to the [email-masked] may result on
> useful information from people involved with that layer.
>
> I hope this helps.
>
> Regards,
>
> Dan
>
>
>
>> -----Original Message----- From: Alexandru Petrescu
>> [mailto:[email-masked]] Sent: Wednesday, October 23,
>> 2013 6:28 PM To: Romascanu, Dan (Dan); [email-masked] Subject: Re:
>> [its] What do we need to make ITS WG go forward? - EtherType for
>> ITS
>>
>> Hi Dan,
>>
>> Let me bring back this topic.
>>
>> Since our last discussion the EtherType for ETSI GeoNetworking
>> 0x8947 has been set at IEEE:
>> http://standards.ieee.org/develop/regauth/ethertype/eth.txt
>>
>> However, it is absent at the IANA website:
>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xml
>>
>>
>>
Where should we ask at IANA about this type?
>>
>> Also, this ethertype 0x8947 seems absent from the linux kernel
>> sources.
>>
>> Where should we ask a patch?
>>
>> Alex
>>
>>
>> Le 30/01/2013 11:00, Romascanu, Dan (Dan) a écrit :
>>> Hi,
>>>
>>> If the PDF letter is dated 1/29 (yesterday) than we may see the
>>> IEEE RA list updated soon.
>>>
>>> There is no need for IANA to make an allocation (if we are
>>> discussing EtherTypes). The responsibility for EtherTypes
>>> assignment is with the IEEE RA and the file at IANA is only
>>> informational. See the note at
>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xml.
>>>
>>>
>>>
>>
>>>
Regards,
>>>
>>> Dan
>>>
>>>
>>>
>>>
>>>> -----Original Message----- From: [email-masked]
>>>> [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
>>>> Sent: Wednesday, January 30, 2013 11:54 AM To: [email-masked]
>>>> Subject: Re: [its] What do we need to make ITS WG go forward?
>>>> - EtherType for ITS
>>>>
>>>> In private I got hold of a pdf letter from IEEE to ETSI dated
>>>> January 29th, 2013, which says that the EtherType is #8947.
>>>> (not sure hexa or decimal).
>>>>
>>>> See that letter attached to this email.
>>>>
>>>> One would say that things unfold as we speak.
>>>>
>>>> I still think that IANA should also allocate it as well. (maybe
>>>> I'll get another pdf in private telling me it's already
>>>> done...)
>>>>
>>>> Alex
>>>>
>>>> Le 30/01/2013 10:39, Alexandru Petrescu a écrit :
>>>>> Le 30/01/2013 10:11, Thierry Ernst a écrit :
>>>>>>
>>>>>> Alex,
>>>>>>
>>>>>> IEEE have assigned Ethernet Type Field number #8947 for ITS
>>>>>> use (ETSI TC ITS's GeoNetworking). Check the following
>>>>>> document available on the ETSI server:
>>>>>>
>>>>>> ITS(13)000020
>>>>>> <http://docbox.etsi.org/ITS/ITS/05-CONTRIBUTIONS/2013/ITS%2813%2900
>>>>>>
>>>>>>
00
>>>>>>
>>>>>>
>>>>>>
>> 20_Ethernet_Type_Field_number_for_GeoNetworking.pdf>
>>>>>>
>>>>>>
>>>>>> Ethernet Type Field number for GeoNetworking
>>>>>> http://docbox.etsi.org/ITS/ITS/05-CONTRIBUTIONS/2013/ITS(13)000020_
>>>>>>
>>>>>>
Et
>>>>>>
>>>>>>
>>>>>>
>> hernet_Type_Field_number_for_GeoNetworking.pdf
>>>>>>
>>>>>>
>>>>>
>>>>> Thierry,
>>>>>
>>>>> I
>>>>>>
>>>>> may be wrong, but here are my thoughts.
>>>>>
>>>>> I am trying to access these URLs you provide above but they
>>>>> are password protected.  What is the username and password?
>>>>>
>>>>> The URL indicates ETSI, not IEEE.
>>>>>
>>>>> The IEEE URL for EtherTypes is the following, I believe:
>>>>> http://standards.ieee.org/develop/regauth/ethertype/eth.txt
>>>>>
>>>>> That eth.txt file does not contain 0707 nor 8947.  But it
>>>>> does contain, for example 86DD which is 'IPv6'.
>>>>>
>>>>> The 0x0707 EtherType is present in an implementation which
>>>>> is supposed compliant with ETSI ITS (plugtests).  Wireshark
>>>>> dump available upon request.
>>>>>
>>>>> Besides, if this is to be about IPv6, I think it should be
>>>>> reserved at IANA as well, in addition to reserving it at
>>>>> IEEE. The IANA URL for IEEE 802 Numbers is at:
>>>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xm
>>>>>
>>>>>
l
>>>>>
>>>>>
>>>>>
>>>>>
>> (the #8947 that you mention above does not seem to figure in this
>>>>> IANA URL).
>>>>>
>>>>> This is why I believe this number should be reserved both as
>>>>> an EtherType at IEEE and at IANA.
>>>>>
>>>>> Yours,
>>>>>
>>>>> Alex
>>>>>
>>>>>>
>>>>>> Regards, Thierry.
>>>>>>
>>>>>>
>>>>>> On 28/01/13 14:28, Alexandru Petrescu wrote:
>>>>>>> Le 28/01/2013 14:16, Joe Klein a écrit :
>>>>>>>> I really dislike the fact that ISO is charging for the
>>>>>>>> ISO 21217 - Architecture & ISO 21210 - IPv6
>>>>>>>> Networking.
>>>>>>>>
>>>>>>>> Does this make it any better? Safer?  Should ISO now
>>>>>>>> have cybersecurity and safety liability if the
>>>>>>>> specification leads to deaths and damage to property?
>>>>>>>
>>>>>>> Does it make any better interoperable as well?
>>>>>>>
>>>>>>> EtherType 0x0707 described in ITS documents, implemented,
>>>>>>> but not specified by IEEE nor reserved at IANA - does not
>>>>>>> make it interoperable.
>>>>>>>
>>>>>>> One wouldn't think that this 0x0707 ethertype be reserved
>>>>>>> by somebody who is not IANA nor IEEE?
>>>>>>>
>>>>>>> (see a good example of interoperability: IPv6 0x86dd
>>>>>>> ethertype is reserved at IEEE and at IANA
>>>>>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.
>>>>>>>
>>>>>>>
xm
>>>>>>>
>>>>>>>
>>>>>>>
>> l)
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>
>>>>>>>
>>>> Alex
>>>>>>>
>>>>>>> Or should these standards remain in
>>>>>>>> the public domain, for researches to review and
>>>>>>>> validate?
>>>>>>>>
>>>>>>>> Just my 2 cents.
>>>>>>>>
>>>>>>>> Joe
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, Jan 28, 2013 at 6:31 AM, Thierry Ernst
>>>>>>>> <[email-masked]> wrote:
>>>>>>>>>
>>>>>>>>> Dear all,
>>>>>>>>>
>>>>>>>>> At this stage, I don't think a new working group is
>>>>>>>>> needed. First, it would need a charter, and support
>>>>>>>>> from the industry. But more importantly, IETF WGs are
>>>>>>>>> not usually sector-driven, so it means the different
>>>>>>>>> issues pertaining to ITS should be brought to VARIOUS
>>>>>>>>> existing WGs, and a WG should only be created if
>>>>>>>>> there is an important issue for which there is no
>>>>>>>>> existing WG that could work on it.
>>>>>>>>>
>>>>>>>>> This said, as mentioned earlier, ITS is not only
>>>>>>>>> about vehicular communications, though the issues
>>>>>>>>> listed by Alexandru below mostly consider vehicular
>>>>>>>>> communications.
>>>>>>>>>
>>>>>>>>> What ITS really needs is the definition of a common
>>>>>>>>> communication architecture and the definition of what
>>>>>>>>> features should be comprised for an IPv6 networking
>>>>>>>>> stack deployed for ITS use cases. This cannot be done
>>>>>>>>> at IETF, and actually already exists at ISO: - ISO
>>>>>>>>> 21217 - Architecture - ISO 21210 - IPv6 Networking
>>>>>>>>>
>>>>>>>>> As an input to the discussion, please consider
>>>>>>>>> reading documents D2.1 and D2.2 available on the
>>>>>>>>> ITSSv6 project web page:
>>>>>>>>> http://www.itssv6.eu/documentation/ D2.2 provides an
>>>>>>>>> analysis of the currently published version of ISO
>>>>>>>>> 21210, but new work items have been launched since
>>>>>>>>> then to address remaining issues.
>>>>>>>>>
>>>>>>>>> Regards, Thierry.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On 28/01/13 11:08, Alexandru Petrescu wrote:
>>>>>>>>>>
>>>>>>>>>> Le 28/01/2013 05:02, Stan Ratliff (sratliff) a
>>>>>>>>>> écrit :
>>>>>>>>>>>
>>>>>>>>>>> All,
>>>>>>>>>>>
>>>>>>>>>>> This is just one opinion, but I'd like to
>>>>>>>>>>> understand why ITS would need its own IETF group.
>>>>>>>>>>> The work here is the same (IMO) as what is taking
>>>>>>>>>>> place in MANET. I would vote that this work be
>>>>>>>>>>> taken up in MANET.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Stan,
>>>>>>>>>>
>>>>>>>>>> Thank you for the offer.  I considered this offer
>>>>>>>>>> since some time.
>>>>>>>>>>
>>>>>>>>>> I try to understand whether some of these items on
>>>>>>>>>> which I have interest could be brought in in MANET
>>>>>>>>>> WG: - V2V using prefix exchange - VIN-based IP
>>>>>>>>>> addressing scheme - ND Prefix Delegation -
>>>>>>>>>> PMIP-based network mobility - IPv6 single-address
>>>>>>>>>> connecion 'sharing' with a cellular operator and a
>>>>>>>>>> vehicular moving network  (type '64share' of
>>>>>>>>>> v6ops). - Default Route with DHCPv6.
>>>>>>>>>>
>>>>>>>>>> Please let me know.
>>>>>>>>>>
>>>>>>>>>> Yours,
>>>>>>>>>>
>>>>>>>>>> Alex
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Regards, Stan
>>>>>>>>>>>
>>>>>>>>>>> On Jan 26, 2013, at 9:34 AM, Abdussalam Baryun
>>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi Nabil,
>>>>>>>>>>>>
>>>>>>>>>>>> I think we already done some steps but not sure
>>>>>>>>>>>> how far now. We will need to propose the WG and
>>>>>>>>>>>> provide the WG charter, as use cases and work
>>>>>>>>>>>> to be done in this group. This charter needs to
>>>>>>>>>>>> be approved by the IESG. I have not attended
>>>>>>>>>>>> the last meeting so not sure about the status
>>>>>>>>>>>> now,
>>>>>>>>>>>>
>>>>>>>>>>>> AB
>>>>>>>>>>>>
>>>>>>>>>>>> On 1/26/13, Nabil Benamar
>>>>>>>>>>>> <[email-masked]> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>> Hi All,
>>>>>>>>>>>>>
>>>>>>>>>>>>> I'm still interested in this list and want to
>>>>>>>>>>>>> join voices previously heard to make it a
>>>>>>>>>>>>> working group. So what should we exactly do,
>>>>>>>>>>>>> to achieve this goal ?
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> 2013/1/26 Abdussalam Baryun
>>>>>>>>>>>>> <[email-masked]>
>>>>>>>>>>>>>
>>>>>>>>>>>>>> Hi All,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> I was interested in this group but not sure
>>>>>>>>>>>>>> where are we so far. Is there progress, or
>>>>>>>>>>>>>> is there issues/efforts that need to be
>>>>>>>>>>>>>> completed and volunteered.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> AB
>>>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>
>>>>>>>>>>>>>>
its mailing list [email-masked]
>>>>>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> -- * * *تحياتي ، **Cordialement, Regards* * *
>>>>>>>>>>>>> * * *نبيل بنعمرو Nabil Benamar* Professor of
>>>>>>>>>>>>> computer sciences Simulation and Modelisation
>>>>>>>>>>>>> Laboratory Human Sciences Faculty of Meknes
>>>>>>>>>>>>> Moulay Ismail* *University* Meknes, Morocco
>>>>>>>>>>>>> *GSM: * *+ 212 6 70832236
>>>>>>>>>>>>> http://nabilbenamar.com/
>>>>>>>>>>>>>
>>>>>>>>>>>>> *
>>>>>>>>>>>>>
>>>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>>>>
>>>>>>>>>>>>>
--
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>> ------------------
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>> *
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>
>>>>>>>>>>>>
its mailing list [email-masked]
>>>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> its mailing list [email-masked]
>>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> _______________________________________________
>>>>>>>>>> its mailing list [email-masked]
>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> _______________________________________________ its
>>>>>>>>> mailing list [email-masked]
>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>
>>>>>>>> _______________________________________________ its
>>>>>>>> mailing list [email-masked]
>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________ its
>>>>>>> mailing list [email-masked]
>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________ its
>>>>>> mailing list [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________ its mailing
>>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>
>>
>

---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 May 2014 08:25:48 -0700

This sounds like the cart before the horse. 

Why does geonet have to run at the link-layer?

Now if you have to run any geonet protocol over a layer-3 network, you are required to stretch a subnet and use layer-2 overlays. 

Can someone justify this request?

Dino

> On May 1, 2014, at 4:24 AM, Alexandru Petrescu <[email-masked]> wrote:
> 
> Hello geonetters,
> 
> I would like to inform you that, following our discussions about EtherType for geonet, and per my request, and per designated reviewer for this entry - IANA has added an entry in the table of EtherTypes for 0x8947 for GeoNetworking, as to reflect the IEEE allocation of same EtherType.
> 
> This is a good allocation which should help software designers in writing interoperable implementations of geonetworking code over link layers of type Ethernet, and in some cases, links dedicated to ITS vehicular communications.
> 
> Yours,
> 
> Alex
>

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Thu, 1 May 2014 16:05:31 +0000

Dino,

>-----Original Message-----
>From: its [mailto:[email-masked]] On Behalf Of Dino Farinacci
>Sent: donderdag 1 mei 2014 17:26
>To: Alexandru Petrescu
>Cc: Romascanu, Dan (Dan); [email-masked]
>Subject: Re: [geonet/its] EtherType for geonet/ITS 0x8947 reflected at IANA
>(was: What do we need to make ITS WG go forward? - EtherType for ITS)
>
>Now if you have to run any geonet protocol over a layer-3 network, you are
>required to stretch a subnet and use layer-2 overlays.
>

This is the EtherType that was requested by ETSI Technical Committee ITS for their *non-IP-based* GeoNetworking protocol, which runs over IEEE 802.11 OCB mode (or "G5" in their parlance). It has nothing to do (yet) with any existing or proposed IETF protocol/activity.

This action merely means that IANA's table now holds an entry that was  added to IEEE's own table early last year.

Best regards,
Ronald in 't Velt

>> I would like to inform you that, following our discussions about EtherType
>for geonet, and per my request, and per designated reviewer for this entry -
>IANA has added an entry in the table of EtherTypes for 0x8947 for
>GeoNetworking, as to reflect the IEEE allocation of same EtherType.
>>
>> This is a good allocation which should help software designers in writing
>interoperable implementations of geonetworking code over link layers of
>type Ethernet, and in some cases, links dedicated to ITS vehicular
>communications.
>>
>> Yours,
>>
>> Alex
>>
>>>> [its] What do we need to make ITS WG go forward? - EtherType for ITS
>>>>
>>>> Hi Dan,
>>>>
>>>>>>>> IEEE have assigned Ethernet Type Field number #8947 for ITS use
>>>>>>>> (ETSI TC ITS's GeoNetworking). Check the following document
>>>>>>>> available on the ETSI server:
>>>>>>>>
>>>>>>>> ITS(13)000020
>>>>>>>> <http://docbox.etsi.org/ITS/ITS/05-
>CONTRIBUTIONS/2013/ITS%2813%2
>>>>>>>> 900
>> 00
>>>>>>>> http://docbox.etsi.org/ITS/ITS/05-
>CONTRIBUTIONS/2013/ITS(13)0000
>>>>>>>> 20_
>> Et
>>>>>>> I am trying to access these URLs you provide above but they are
>>>>>>> password protected.  What is the username and password?
>>>>>>>
>>>>>>> That eth.txt file does not contain 0707 nor 8947.  But it does
>>>>>>> contain, for example 86DD which is 'IPv6'.
>>>>>>>
>>>>>>> The 0x0707 EtherType is present in an implementation which is
>>>>>>> supposed compliant with ETSI ITS (plugtests).  Wireshark dump
>>>>>>> available upon request.
>>>>>>>
>>>>>>> reserved at IANA as well, in addition to reserving it at IEEE.
>>>>>>> The IANA URL for IEEE 802 Numbers is at:
>>>>>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-
>numbers
>>>>>>> .xm
>> l
>>>>>>> This is why I believe this number should be reserved both as an
>>>>>>> EtherType at IEEE and at IANA.
>>>>>>>
>>>>>>> Yours,
>>>>>>>
>>>>>>> Alex
>>>>>>>
>>>>>>>>
>>>>>>>> Regards, Thierry.
>>>>>>>>
>>>>>>>>
>>>>>>>>>> I really dislike the fact that ISO is charging for the ISO
>>>>>>>>>> 21217 - Architecture & ISO 21210 - IPv6 Networking.
>>>>>>>>>>
>>>>>>>>>> Does this make it any better? Safer?  Should ISO now have
>>>>>>>>>> cybersecurity and safety liability if the specification leads
>>>>>>>>>> to deaths and damage to property?
>>>>>>>>>
>>>>>>>>> EtherType 0x0707 described in ITS documents, implemented, but
>>>>>>>>> not specified by IEEE nor reserved at IANA - does not make it
>>>>>>>>> interoperable.
>>>>>>>>>
>>>>>>>>> One wouldn't think that this 0x0707 ethertype be reserved by
>>>>>>>>> somebody who is not IANA nor IEEE?
>>>>>>>>>
>>>>>>>>> (see a good example of interoperability: IPv6 0x86dd ethertype
>>>>>>>>> is reserved at IEEE and at IANA
>>>>>>>>>> the public domain, for researches to review and validate?
>>>>>>>>>>
>>>>>>>>>> Just my 2 cents.
>>>>>>>>>>
>>>>>>>>>> Joe
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>> At this stage, I don't think a new working group is needed.
>>>>>>>>>>> First, it would need a charter, and support from the
>>>>>>>>>>> industry. But more importantly, IETF WGs are not usually
>>>>>>>>>>> sector-driven, so it means the different issues pertaining to
>>>>>>>>>>> ITS should be brought to VARIOUS existing WGs, and a WG
>>>>>>>>>>> should only be created if there is an important issue for
>>>>>>>>>>> which there is no existing WG that could work on it.
>>>>>>>>>>>
>>>>>>>>>>> This said, as mentioned earlier, ITS is not only about
>>>>>>>>>>> vehicular communications, though the issues listed by
>>>>>>>>>>> Alexandru below mostly consider vehicular communications.
>>>>>>>>>>>
>>>>>>>>>>> features should be comprised for an IPv6 networking stack
>>>>>>>>>>> deployed for ITS use cases. This cannot be done at IETF, and
>>>>>>>>>>> actually already exists at ISO: - ISO
>>>>>>>>>>> As an input to the discussion, please consider reading
>>>>>>>>>>> documents D2.1 and D2.2 available on the
>>>>>>>>>>> ITSSv6 project web page:
>>>>>>>>>>> http://www.itssv6.eu/documentation/ D2.2 provides an analysis
>>>>>>>>>>> of the currently published version of ISO 21210, but new work
>>>>>>>>>>> items have been launched since then to address remaining
>>>>>>>>>>> issues.
>>>>>>>>>>>
>>>>>>>>>>> Regards, Thierry.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>> Le 28/01/2013 05:02, Stan Ratliff (sratliff) a écrit :
>>>>>>>>>>>>>
>>>>>>>>>>>>> All,
>>>>>>>>>>>>>
>>>>>>>>>>>>> This is just one opinion, but I'd like to understand why
>>>>>>>>>>>>> ITS would need its own IETF group.
>>>>>>>>>>>>> The work here is the same (IMO) as what is taking place in
>>>>>>>>>>>>> MANET. I would vote that this work be taken up in MANET.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Stan,
>>>>>>>>>>>>
>>>>>>>>>>>> Thank you for the offer.  I considered this offer since some
>>>>>>>>>>>> time.
>>>>>>>>>>>>
>>>>>>>>>>>> I try to understand whether some of these items on which I
>>>>>>>>>>>> have interest could be brought in in MANET
>>>>>>>>>>>> WG: - V2V using prefix exchange - VIN-based IP addressing
>>>>>>>>>>>> scheme - ND Prefix Delegation - PMIP-based network mobility
>>>>>>>>>>>> - IPv6 single-address connecion 'sharing' with a cellular
>>>>>>>>>>>> operator and a vehicular moving network  (type '64share' of
>>>>>>>>>>>>>> I think we already done some steps but not sure how far
>>>>>>>>>>>>>> now. We will need to propose the WG and provide the WG
>>>>>>>>>>>>>> charter, as use cases and work to be done in this group.
>>>>>>>>>>>>>> This charter needs to be approved by the IESG. I have not
>>>>>>>>>>>>>> attended the last meeting so not sure about the status
>>>>>>>>>>>>>> now,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> AB
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> I'm still interested in this list and want to join voices
>>>>>>>>>>>>>>> previously heard to make it a working group. So what
>>>>>>>>>>>>>>> should we exactly do, to achieve this goal ?
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> I was interested in this group but not sure where are we
>>>>>>>>>>>>>>>> so far. Is there progress, or is there issues/efforts
>>>>>>>>>>>>>>>> that need to be completed and volunteered.
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> AB
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> * * *نبيل بنعمرو Nabil Benamar* Professor of computer
>>>>>>>>>>>>>>> sciences Simulation and Modelisation Laboratory Human
>>>>>>>>>>>>>>> Sciences Faculty of Meknes Moulay Ismail* *University*
>>>>>>>>>>>>>>> Meknes, Morocco
>>>>>>>>>>>>>>> *GSM: * *+ 212 6 70832236 http://nabilbenamar.com/
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> *
>>>>>>>>>>>>>>>
>mailing
>mailing
>mailing
>mailing list
>>>>>>>> [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>>>>>
>>>>>>>
>mailing list
>>>>>>> [email-masked] https://www.ietf.org/mailman/listinfo/its
>>
>>
>> ---
>> Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce
>que la protection avast! Antivirus est active.
>> http://www.avast.com
>>

Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. TNO aanvaardt geen aansprakelijkheid voor de inhoud van deze e-mail, de wijze waarop u deze gebruikt en voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 1 May 2014 09:42:31 -0700

Okay, thanks for clarification.

Dino

On May 1, 2014, at 9:05 AM, Velt, R. (Ronald) in 't <[email-masked]> wrote:

>> numbers.xm
>> numbers.xml.
>> numbers.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 02 May 2014 17:14:49 +0200

Le 01/05/2014 18:05, Velt, R. (Ronald) in 't a écrit :
> Dino,
>
>> -----Original Message----- From: its [mailto:[email-masked]]
>> On Behalf Of Dino Farinacci Sent: donderdag 1 mei 2014 17:26 To:
>> Alexandru Petrescu Cc: Romascanu, Dan (Dan); [email-masked] Subject:
>> Re: [geonet/its] EtherType for geonet/ITS 0x8947 reflected at IANA
>> Now if you have to run any geonet protocol over a layer-3 network,
>> you are required to stretch a subnet and use layer-2 overlays.
>>
> This is the EtherType that was requested by ETSI Technical Committee
> ITS for their *non-IP-based* GeoNetworking protocol, which runs over
> IEEE 802.11 OCB mode (or "G5" in their parlance). It has nothing to
> do (yet) with any existing or proposed IETF protocol/activity.

Yes, I agree.

This ethertype is for ETSI Geonetworking, which is a different thing 
than 'geonet' as we do at IETF. (yet or never).

We can very well come up with a geonet protocol that is not necessarily 
related to ETSI GEonetworking: it may run on G5 and other links, it may 
run at layer 7 and not layer 3, it may be IP-based, and so on.  Where 
geonet runs is what we have to clarify in the Charter right now.

Alex

>
> This action merely means that IANA's table now holds an entry that
> was  added to IEEE's own table early last year.
>
> Best regards, Ronald in 't Velt
>
>>
>> Dino
>>
>>> EtherType
>> for geonet, and per my request, and per designated reviewer for
>> this entry - IANA has added an entry in the table of EtherTypes for
>>> writing
>> interoperable implementations of geonetworking code over link
>>>> On 23/10/2013 17:41, Romascanu, Dan (Dan) wrote: Hi Alexandru,
>>>>
>>>> The authority for allocation is with the IEEE, and the list to
>>>> be referenced and used in specifications is the one at IEEE.
>>>>
>>>> The IANA list is informational and includes as specified on the
>>>> page 'contributed unverified information from various sources'.
>>>> It would be good I think to have the new ethertype mentioned on
>>>> the IANA page as well, because some IETF-ers may go first to
>>>> that list. I suggest that you just send an email to IANA asking
>>>> for the change (additional row in the table) be made according
>>>> to the IEEE allocation. We can talk about this with the IANA
>>>> folks in Vancouver if this is not solved until then.
>>>>
>>>> I am not sure who needs to be asked about the linux kernel
>>>> patches, I can guess that a query to the [email-masked]
>>>> may result on useful information from people involved with that
>>>> layer.
>>>>
>>>> I hope this helps.
>>>>
>>>> Regards,
>>>>
>>>> Dan
>>>>
>>>>
>>>>
>>>>> [mailto:[email-masked]] Sent: Wednesday,
>>>>> October 23, 2013 6:28 PM To: Romascanu, Dan (Dan);
>>>>> [email-masked] Subject: Re: [its] What do we need to make ITS
>>>>> WG go forward? - EtherType for ITS
>>>>>
>>>>> Hi Dan,
>>>>>
>>>>> Since our last discussion the EtherType for ETSI
>>>>> GeoNetworking 0x8947 has been set at IEEE:
>>>>> Also, this ethertype 0x8947 seems absent from the linux
>>>>> kernel sources.
>>>>>
>>>>>> If the PDF letter is dated 1/29 (yesterday) than we may see
>>>>>> the IEEE RA list updated soon.
>>>>>>
>>>>>> assignment is with the IEEE RA and the file at IANA is
>>>>>> only informational. See the note at
>>>>>>> [mailto:[email-masked]] On Behalf Of Alexandru
>>>>>>> Petrescu Sent: Wednesday, January 30, 2013 11:54 AM To:
>>>>>>> [email-masked] Subject: Re: [its] What do we need to make
>>>>>>> ITS WG go forward? - EtherType for ITS
>>>>>>>
>>>>>>> In private I got hold of a pdf letter from IEEE to ETSI
>>>>>>> dated January 29th, 2013, which says that the EtherType
>>>>>>> is #8947. (not sure hexa or decimal).
>>>>>>>
>>>>>>> I still think that IANA should also allocate it as well.
>>>>>>> (maybe I'll get another pdf in private telling me it's
>>>>>>> already done...)
>>>>>>>
>>>>>>> Alex
>>>>>>>
>>>>>>>>> IEEE have assigned Ethernet Type Field number #8947
>>>>>>>>> for ITS use (ETSI TC ITS's GeoNetworking). Check the
>>>>>>>>> following document available on the ETSI server:
>>>>>>>>>
>>>>>>>>> ITS(13)000020 <http://docbox.etsi.org/ITS/ITS/05-
>>>>>>>> I may be wrong, but here are my thoughts.
>>>>>>>>
>>>>>>>> I am trying to access these URLs you provide above but
>>>>>>>> they are password protected.  What is the username and
>>>>>>>> password?
>>>>>>>>
>>>>>>>> The 0x0707 EtherType is present in an implementation
>>>>>>>> which is supposed compliant with ETSI ITS (plugtests).
>>>>>>>> Wireshark dump available upon request.
>>>>>>>>
>>>>>>>> Besides, if this is to be about IPv6, I think it should
>>>>>>>> be reserved at IANA as well, in addition to reserving
>>>>>>>> it at IEEE. The IANA URL for IEEE 802 Numbers is at:
numbers
>>>>>>>> This is why I believe this number should be reserved
>>>>>>>> both as an EtherType at IEEE and at IANA.
>>>>>>>>
>>>>>>>> Yours,
>>>>>>>>
>>>>>>>> Alex
>>>>>>>>
>>>>>>>>>
>>>>>>>>> Regards, Thierry.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> On 28/01/13 14:28, Alexandru Petrescu wrote: Le
>>>>>>>>>> 28/01/2013 14:16, Joe Klein a écrit :
>>>>>>>>>>> I really dislike the fact that ISO is charging
>>>>>>>>>>> for the ISO 21217 - Architecture & ISO 21210 -
>>>>>>>>>>> IPv6 Networking.
>>>>>>>>>>>
>>>>>>>>>>> Does this make it any better? Safer?  Should ISO
>>>>>>>>>>> now have cybersecurity and safety liability if
>>>>>>>>>>> the specification leads to deaths and damage to
>>>>>>>>>>> property?
>>>>>>>>>>
>>>>>>>>>> EtherType 0x0707 described in ITS documents,
>>>>>>>>>> implemented, but not specified by IEEE nor reserved
>>>>>>>>>> at IANA - does not make it interoperable.
>>>>>>>>>>
>>>>>>>>>> One wouldn't think that this 0x0707 ethertype be
>>>>>>>>>> reserved by somebody who is not IANA nor IEEE?
>>>>>>>>>>
>>>>>>>>>> (see a good example of interoperability: IPv6
>>>>>>>>>> 0x86dd ethertype is reserved at IEEE and at IANA
numbers.
>>>>>>>>>>>> At this stage, I don't think a new working
>>>>>>>>>>>> group is needed. First, it would need a
>>>>>>>>>>>> charter, and support from the industry. But
>>>>>>>>>>>> more importantly, IETF WGs are not usually
>>>>>>>>>>>> sector-driven, so it means the different issues
>>>>>>>>>>>> pertaining to ITS should be brought to VARIOUS
>>>>>>>>>>>> existing WGs, and a WG should only be created
>>>>>>>>>>>> if there is an important issue for which there
>>>>>>>>>>>> is no existing WG that could work on it.
>>>>>>>>>>>>
>>>>>>>>>>>> This said, as mentioned earlier, ITS is not
>>>>>>>>>>>> only about vehicular communications, though the
>>>>>>>>>>>> issues listed by Alexandru below mostly
>>>>>>>>>>>> consider vehicular communications.
>>>>>>>>>>>>
>>>>>>>>>>>> What ITS really needs is the definition of a
>>>>>>>>>>>> common communication architecture and the
>>>>>>>>>>>> definition of what features should be comprised
>>>>>>>>>>>> for an IPv6 networking stack deployed for ITS
>>>>>>>>>>>> use cases. This cannot be done at IETF, and
>>>>>>>>>>>> actually already exists at ISO: - ISO 21217 -
>>>>>>>>>>>> Architecture - ISO 21210 - IPv6 Networking
>>>>>>>>>>>>
>>>>>>>>>>>> reading documents D2.1 and D2.2 available on
>>>>>>>>>>>> the ITSSv6 project web page:
>>>>>>>>>>>> http://www.itssv6.eu/documentation/ D2.2
>>>>>>>>>>>> provides an analysis of the currently published
>>>>>>>>>>>> version of ISO 21210, but new work items have
>>>>>>>>>>>> been launched since then to address remaining
>>>>>>>>>>>> issues.
>>>>>>>>>>>>
>>>>>>>>>>>> Regards, Thierry.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>>> understand why ITS would need its own IETF
>>>>>>>>>>>>>> group. The work here is the same (IMO) as
>>>>>>>>>>>>>> what is taking place in MANET. I would vote
>>>>>>>>>>>>>> that this work be taken up in MANET.
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> Stan,
>>>>>>>>>>>>>
>>>>>>>>>>>>> Thank you for the offer.  I considered this
>>>>>>>>>>>>> offer since some time.
>>>>>>>>>>>>>
>>>>>>>>>>>>> I try to understand whether some of these
>>>>>>>>>>>>> items on which I have interest could be
>>>>>>>>>>>>> brought in in MANET WG: - V2V using prefix
>>>>>>>>>>>>> exchange - VIN-based IP addressing scheme -
>>>>>>>>>>>>> ND Prefix Delegation - PMIP-based network
>>>>>>>>>>>>> mobility - IPv6 single-address connecion
>>>>>>>>>>>>> 'sharing' with a cellular operator and a
>>>>>>>>>>>>>> On Jan 26, 2013, at 9:34 AM, Abdussalam
>>>>>>>>>>>>>> Baryun wrote:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Hi Nabil,
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> I think we already done some steps but
>>>>>>>>>>>>>>> not sure how far now. We will need to
>>>>>>>>>>>>>>> propose the WG and provide the WG
>>>>>>>>>>>>>>> charter, as use cases and work to be done
>>>>>>>>>>>>>>> in this group. This charter needs to be
>>>>>>>>>>>>>>> approved by the IESG. I have not attended
>>>>>>>>>>>>>>> the last meeting so not sure about the
>>>>>>>>>>>>>>> status now,
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> AB
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> I'm still interested in this list and
>>>>>>>>>>>>>>>> want to join voices previously heard to
>>>>>>>>>>>>>>>> make it a working group. So what should
>>>>>>>>>>>>>>>> we exactly do, to achieve this goal ?
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> I was interested in this group but
>>>>>>>>>>>>>>>>> not sure where are we so far. Is
>>>>>>>>>>>>>>>>> there progress, or is there
>>>>>>>>>>>>>>>>> issues/efforts that need to be
>>>>>>>>>>>>>>>> * * *نبيل بنعمرو Nabil Benamar*
>>>>>>>>>>>>>>>> Professor of computer sciences
>>>>>>>>>>>>>>>> Simulation and Modelisation Laboratory
>>>>>>>>>>>>>>>> Human Sciences Faculty of Meknes Moulay
>>>>>>>>>>>>>>>> Ismail* *University* Meknes, Morocco
>>>>>>>>>>>>>>>> ---------------------------------------------------------
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
---
>>>>>>>>>>>> its
>>>>>>>>>>>> list [email-masked]
>>>>>>>>>>> its
>>>>>>>>>>> list [email-masked]
>>>>>>>>>> its
>>>>>>>>>> list [email-masked]
>>>>>>>>> [email-masked]
>>> --- Ce courrier électronique ne contient aucun virus ou logiciel
>>> malveillant parce
>>> _______________________________________________ its mailing list
>> _______________________________________________ its mailing list
> Dit bericht kan informatie bevatten die niet voor u is bestemd.
> Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u
> is toegezonden, wordt u verzocht dat aan de afzender te melden en het
> bericht te verwijderen. TNO aanvaardt geen aansprakelijkheid voor de
> inhoud van deze e-mail, de wijze waarop u deze gebruikt en voor
> schade, van welke aard ook, die verband houdt met risico's verbonden
> aan het elektronisch verzenden van berichten.
>
>
>
> This message may contain information that is not intended for you. If
> you are not the addressee or if this message was sent to you by
> mistake, you are requested to inform the sender and delete the
> message. TNO accepts no liability for the content of this e-mail, for
> the manner in which you use it and for damage of any kind resulting
> from the risks inherent to the electronic transmission of messages.
>