Subject: Re: [ipwave] IPWAVE hackathon

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Feb 2019 07:34:32 -1000

Hi Carlos, Russ and Nabil,
my SKKU team will have IPWAVE Basic Protocols Project this IETF-104
Hackathon.
https://trac.ietf.org/trac/ietf/meeting/wiki/104hackathon

This project is based on simulation and includes IPv6 over 802.11-OCB and
my Vehicular Neighbor Discovery with DAD Optimization as follows:

*IP Wireless Access in Vehicular Environments (IPWAVE) Basic Protocols*

   - Champion(s)
      - Jaehoon Paul Jeong <pauljeong at skku.edu>
   - Project(s)
      - Transmission of IPv6 Packets over IEEE 802.11-OCB (IPv6 over
      802.11-OCB)
      - IPv6 Neighbor Discovery for IP-Based Vehicular Networks
         - Router and Prefix Discovery and IPv6 address autoconfiguration
         - Duplicate Address Detection process
         - Multihop DAD process via V2V communications
      - Simulations of IPWAVE with SUMO, INET, and VEINS
         - Build IPv6/TCP/UDP protocol stack based on VEINS-4.7.1 and
         INET-4.0
         - Build basic IPWAVE running scenario, V2I and V2V based on
         VEINS-4.7.1 and SUMO-0.32.0
         - Transmit IPv6 data packets

   - Specifications:
      - ​https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-34
      - ​
      https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-05
      - ​
      https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-07

In future hackathons, my team will implement these in Linux, so our work
will be able to accommodate Nabil's work later.

I encourage our IPWAVERs to participate in this hackathon on site or
remotely.

Thanks.

Best Regards,
Paul

2019년 2월 21일 (목) 오전 7:19, CARLOS JESUS BERNARDOS CANO <[email-masked]>님이
작성:

> Hi Nabil,
>
> Thanks for letting us know. If Paul's team is participating, maybe you can
> coordinate with him so they replicate what you did as a pre-step for a
> future hackathon where people from both teams could participate. I just
> think some activities on this would help moving IPWAVE activities forward.
>
> Thanks,
>
> Carlos
>
> On Thu, Feb 21, 2019 at 5:58 PM Nabil Benamar <[email-masked]> wrote:
>
>> Thank you Carlos for raising this very crucial point!
>>
>> Indeed I have personally organized a Hackathon in Dakar last year during
>> the African Internet Summit, and it was a success story. We have been able
>> to test different ocb cards, recompiling the Linux Kernel and then see the
>> ocb link communication.....
>>
>> I would love to do it again in upcoming IETF meetings, but unfortunately
>> I'm not participating this time!
>>
>> Best regards
>> Nabil
>>
>>
>>
>> On Thu, Feb 21, 2019, 17:35 CARLOS JESUS BERNARDOS CANO <[email-masked]>
>> wrote:
>>
>>> Hi Nabil, Paul,
>>>
>>> In the last meeting we discussed about the possibility of organizing a
>>> hackathon on IPWAVE topics in Prague. Have you been working on this idea?
>>> Maybe you should also ask Alex.
>>>
>>> If we could have some interop testing on basic IPv6 over OCB, I think
>>> would be really useful.
>>>
>>> Let us know what you think.
>>>
>>> Thanks,
>>>
>>> Carlos
>>>
>>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Fri, 22 Feb 2019 10:31:04 +0100

Hi Paul,

This is very good news. Please, let people know about this on the IPWAVE
mailing list. I think it'd also be good if you can report in 5-10 minutes
during the IPWAVE session in Prague about the outcome of the hackathon.

Thanks,

Carlos

On Thu, Feb 21, 2019 at 6:34 PM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

>       https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-34
>       - ​
>> Thanks for letting us know. If Paul's team is participating, maybe you
>> can coordinate with him so they replicate what you did as a pre-step for a

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 23 Feb 2019 07:24:19 +0900

Carlos,
Sure, I can report IPWAVE Hackathon in IETF-104 IPWAVE session.
10 minutes will be good considering discussion.

IPWAVE WG,
Could you join our hackathon on site or remotely?
IPWAVE Basic Protocols Project
https://trac.ietf.org/trac/ietf/meeting/wiki/104hackathon

If you have intention to join this hackathon, please let me know.

Thanks.

Best Regards,
Paul

2019년 2월 22일 (금) 오후 6:31, CARLOS JESUS BERNARDOS CANO <[email-masked]>님이
작성:

>>>> Indeed I have personally organized a Hackathon in Dakar last year
>>>> during the African Internet Summit, and it was a success story. We have
>>>> been able to test different ocb cards, recompiling the Linux Kernel and
>>>> then see the ocb link communication.....
>>>>
>>>> I would love to do it again in upcoming IETF meetings, but
>>>> unfortunately I'm not participating this time!
>>>>
>>>> Best regards
>>>> Nabil
>>>>
>>>>
>>>>
>>>> On Thu, Feb 21, 2019, 17:35 CARLOS JESUS BERNARDOS CANO <
>>>> [email-masked]> wrote:
>>>>
>>>>> Hi Nabil, Paul,
>>>>>