Subject: Re: [ipwave] About OCB patch for ath10k driver on linux

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 22 May 2020 17:42:46 +0200

Hi,

There is news from Potsdam about an 802.11p (aka OCB mode) patch for an 
ath10k driver, probably for a Mikrotik R11 kind of card.

https://gitlab.com/hpi-potsdam/osm/g5-on-linux/11p-on-linux/-/tree/ath10k

Alex

Le 13/03/2020 à 10:21, Alexandre Petrescu a écrit :
> I dont know whether the patch files and howto for ath10k were received 
> by participants or not.  Some have not; I sent them the files in private.
> 
> The patch files might be missing from my email because I think it might 
> be that the email system 'mailman' filters (cuts) the attachments.
> 
> To avoid that misunderstanding, one should use a repository.
> 
> A repository of appropriate profile could be at 
> https://its.dot.gov/code/ « ITS Code Hub »
> 
> One could try to make an account and upload the files of ath10k to that 
> repository, and then publish here the link.
> 
> Other questions I have about that dot.gov site is whether or not it 
> supports IPv6 access, but that is accessory.  github.com doesnt support 
> IPv6 either.
> 
> Another question one might raise before putting the files there is about 
> that being in a country and not in another country.  At this time I do 
> not mind about that, because the technology of this code is to be used 
> in any country, like the Internet.
> 
> Alex
> 
> Le 11/03/2020 à 15:31, Alexandre Petrescu a écrit :
>> Hi,
>>
>> I am looking for support for making the OCB mode for ath10k drivers 
>> for linux.
>>
>> Currently there is no OCB mode for ath10k drivers.
>>
>> An OCB driver for ath10k driver would open the path towards using 
>> 802.11ac in vehicular networks in OCB mode.
>>
>> We tried to make it work but we have not succeeded fully.
>>
>> One initial error is this:
>>> root@OpenWrt:/# iw dev wlan3 ocb join 5900 10MHz
>>> command failed: Invalid argument (-22)
>> One initial success is this:
>>> Ifconfig wlan3 shows the following output. It shows that the
>>> interface is up.
>>> wlan3 Link encap:Ethernet HWaddr 04:F0:21:54:42:D7
>>> UP BROADCAST MULTICAST MTU:1500 Metric:1
>>> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>>> collisions:0 txqueuelen:1000
>>> RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
>>
>>
>> We developped the premisses of a OCB patch for ath10k, and a howto. 
>> They are attached to this email.
>>
>> We have several additional binary firmwares for the card, that could 
>> be found on the web too. We have an ath9k patch that is minimal.  Also 
>> a few additional explanatory files.  All attached.
>>
>> We have one cheap 802.11ac minipci card Compex WLE900VX from Amazon.  
>> We could send it by post to an interested person, if that's not too 
>> expensive, or maybe pass it during a f2f meeting, or via somebody.  
>> This is common practice.
>>
>> The person who realized this OCB package for ath10k deserves many 
>> thanks - Mariama SARR.  And earlier persons who produced initial works 
>> on ath5k and ath9k.
>>
>> Alex
>>
>> Le 18/12/2019 à 11:38, Alexandre Petrescu a écrit :
>>> Hi, IPWAVErs,
>>>
>>> I would like to know whether someone else works on an OCB patch for
>>> ath10k?
>>>
>>> We work on a patch file for OCB mode for ath10k driver for linux.
>>>
>>> An OCB patch for ath10k would allow to get more bandwidth.  One could
>>>  get more bandwidth than the 16mbit/s of 802.11p by linking two to
>>> five channels even with just an ath9k driver (for which exist OCB
>>> patches). But with ath10k there might be other advantages and even
>>> higher bandwidth.
>>>
>>> An OCB patch for ath10k driver does not exist in the Internet.
>>>
>>> We do not post yet our patch file because it does not work yet, and
>>> we do not want to vehiculate false hopes.  But I will post it end of
>>> March 2020 at latest, at the end of the project.
>>>
>>> The card we use is "PC ngines WL900VX - 802.11ac miniPCI Xpress
>>> Radio" for 35,46Eur on Amazon.  It is Made in China.  It has three
>>> antenna plugs.
>>>
>>> The status of working is: we can add OCB mode and and configure the
>>> card in OCB mode.  Still there is an error "command failed (invalid
>>> argument (-22)" when the iw command is issued.
>>>
>>> Our current patch file is 910 lines long and touches on many files,
>>> such as mac.c in folder 
>>> openwrt-08112019/build_dir/target-arm_cortex-a9+neon_musl-1.1.12_eabi/linux-imx6/linux-4.4/drivers/net/wireless/ath/ath10k,
>>>  and others.
>>>
>>> Alex
>>>
>>> _______________________________________________ its mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/its
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Paul Wouters <[email-masked]>
Date: Fri, 22 May 2020 12:22:59 -0400 (EDT)

> https://gitlab.com/hpi-potsdam/osm/g5-on-linux/11p-on-linux/-/tree/ath10k

Did the license issues regarding the use of OCB outside of TLS RFC's get
resolved?

Paul

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 22 May 2020 20:59:56 +0200

'TLS'?  (transport layer security?)

Alex

Le 22/05/2020 à 18:22, Paul Wouters a écrit :
>> There is news from Potsdam about an 802.11p (aka OCB mode) patch for 
>> an ath10k driver, probably for a Mikrotik R11 kind of card.
>>

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 26 May 2020 16:11:19 +0200

> Did the license issues regarding the use of OCB outside of TLS RFC's get

I suspect TLS implementation is exclusively in the userspace.  That 
might have a distinct license scheme, that I do not know.

The OCB patches to ath10k drivers have license schemes that are 
different.  They would cover generic files deep in the kernel wifi 
structures, and files more specific to a particular manufacturer, like 
Compex, or Atheros, Intel, or similar.  They would be a mixed set of 
licenses both GPL and BSD "no warranty" kinds.

I think Atheros licenses are easier to use by open source developpers.

But I do not know what more precisely in TLS userspace licensing might 
block the use of TLS over 802.11-OCB?

I do know, however, that there are huge obstacles in making PKI for 
vehicular networks like we have PKI for the Internet at large.  There's 
no agreed Certificate Authority for vehicular networks, yet there is 
agreement that the Internet CAs would not be ok for vehicular networks. 
  It is hard to obtain certificates for vehicular networks.

Maybe that difficult situation of CA for vehicular networks relates to a 
potential licensing problem of TLS?

Alex

---

From: Jérôme Härri <[email-masked]>
Date: Tue, 26 May 2020 16:33:58 +0200

Hi Alex, all,

Minor precision: there is a globally agreed EU PKI architecture developed at the C2C and used by ETSI and also now C-ROAD to handle KPI for C-ITS applications in the EU. In theory, nothing refrains an entity to become a certificate provider, but the complexity (and cost) for doing it and reaching the defined security requirements and guaranties make it indeed very hard to get it 'open' to research :-(   

However, you may have a look at the OpenSource C-ITS Stack Vanetza https://www.vanetza.org/ 

Under 'tools' you will see a KPI generator code (standalone), providing correct certificate (tickets) and signatures for ETSI ITS stacks. So far, it is only compliant with the ETSI Security architecture version 1.2, but we (and other people involved) are working to extend it for version 1.3.1  (the current one used by C-ROADs). 

Cheers,

Jérôme

-----Original Message-----
From: its <[email-masked]> On Behalf Of Alexandre Petrescu
Sent: Tuesday, 26 May 2020 16:11
To: Paul Wouters <[email-masked]>
Cc: [email-masked]
Subject: Re: [ipwave] About OCB patch for ath10k driver on linux

Le 22/05/2020 à 18:22, Paul Wouters a écrit :
> Did the license issues regarding the use of OCB outside of TLS RFC's 
> get resolved?

I suspect TLS implementation is exclusively in the userspace.  That might have a distinct license scheme, that I do not know.

The OCB patches to ath10k drivers have license schemes that are different.  They would cover generic files deep in the kernel wifi structures, and files more specific to a particular manufacturer, like Compex, or Atheros, Intel, or similar.  They would be a mixed set of licenses both GPL and BSD "no warranty" kinds.

But I do not know what more precisely in TLS userspace licensing might block the use of TLS over 802.11-OCB?

I do know, however, that there are huge obstacles in making PKI for vehicular networks like we have PKI for the Internet at large.  There's no agreed Certificate Authority for vehicular networks, yet there is agreement that the Internet CAs would not be ok for vehicular networks. 
  It is hard to obtain certificates for vehicular networks.

Maybe that difficult situation of CA for vehicular networks relates to a potential licensing problem of TLS?

Alex

---

From: Paul Wouters <[email-masked]>
Date: Tue, 26 May 2020 12:40:07 -0400

Not it is not the code licence I’m worried about but the IPR claims on OCB.

You might not have a license to use it and only then do we run into limitations of using it in proprietary software as well.

Paul

Sent from my iPhone

> On May 26, 2020, at 10:11, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>>> There is news from Potsdam about an 802.11p (aka OCB mode) patch for an ath10k driver, probably for a Mikrotik R11 kind of card.
>>> 
> I do know, however, that there are huge obstacles in making PKI for vehicular networks like we have PKI for the Internet at large.  There's no agreed Certificate Authority for vehicular networks, yet there is agreement that the Internet CAs would not be ok for vehicular networks.  It is hard to obtain certificates for vehicular networks.
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 27 May 2020 12:20:55 +0200

> Not it is not the code licence I’m worried about but the IPR claims on OCB.

Do you think the OCB mode of 802.11 is IPR'ed?  Where can I search the 
claims?

Alex

---

From: Paul Wouters <[email-masked]>
Date: Wed, 27 May 2020 21:33:34 -0400 (EDT)

> Do you think the OCB mode of 802.11 is IPR'ed?  Where can I search the 

It is the other way around. There is IPR on OCB, and for _some uses_
there are royalty free licenses. For most use cases, AFAIK, there is
no such license.

We have some IPR related claims at IETF here:

 	https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-irtf-cfrg-ocb

And wikipedia lists:

 	https://en.wikipedia.org/wiki/OCB_mode

 	By January 2013, the author has granted a free license for any open
 	source license certified by the Open Source Initiative.[8]

The original site with license seems to have vanished:

 	https://web.cs.ucdavis.edu/~rogaway/ocb/license.htm

So yes, I think OCB in proprietary implementation of 802.11 would
require a non-free license, and would therefor not be suitable for
an IETF standard.

Paul

---

From: John Kenney <[email-masked]>
Date: Wed, 27 May 2020 22:47:25 -0700

I think there is some confusion about the abbreviation OCB. For DSRC it
stands for Outside the Context of a BSS.  The Wikipedia link below is for
something called Offset Codebook Mode.  I don’t know what that is, but it
has nothing to do with DSRC.

-- 
John Kenney
Director and Sr. Principal Researcher
Toyota InfoTech Labs
465 Bernardo Avenue
Mountain View, CA 94043
Tel: 650-694-4160. Mobile: 650-224-6644