Subject: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 21 Feb 2022 15:27:58 +0000

Hi, it looks like a lot of what was in the draft regarding AERO/OMNI has been cut out
so that means I am going to have to re-review it. I will get to this a soon as possible;
hopefully in the next couple of days.

Fred

> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Sunday, February 20, 2022 9:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt
> 
> EXT email: be mindful of links/attachments.
> 
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IP Wireless Access in Vehicular Environments WG of the IETF.
> 
>         Title           : IPv6 Wireless Access in Vehicular Environments (IPWAVE): Problem Statement and Use Cases
>         Author          : Jaehoon (Paul) Jeong
> 	Filename        : draft-ietf-ipwave-vehicular-networking-26.txt
> 	Pages           : 49
> 	Date            : 2022-02-20
> 
> Abstract:
>    This document discusses the problem statement and use cases of
>    IPv6-based vehicular networking for Intelligent Transportation
>    Systems (ITS).  The main scenarios of vehicular communications are
>    vehicle-to-vehicle (V2V), vehicle-to-infrastructure (V2I), and
>    vehicle-to-everything (V2X) communications.  First, this document
>    explains use cases using V2V, V2I, and V2X networking.  Next, for
>    IPv6-based vehicular networks, it makes a gap analysis of current
>    IPv6 protocols (e.g., IPv6 Neighbor Discovery, Mobility Management,
>    and Security & Privacy), and then enumerates requirements for the
>    extensions of those IPv6 protocols for IPv6-based vehicular
>    networking.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-ipwave-vehicular-networking/
> 
> There is also an htmlized version available at:
> https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-26
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-vehicular-networking-26
> 
> 
> Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts
> 
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 21 Feb 2022 19:56:06 +0000

Hi, I started reviewing this and found that it has been completely overhauled since I put my
comments in many months ago. It has in fact been completely rewritten to favor the shared
IPv6 multilink subnet model over multihop networks, to favor RPL/6LowPan over standard
MANET routing protocols, to favor IPv6 ND changes over standard IPv6 ND, and to favor
multilink DAD. None of that is necessary with AERO/OMNI and the NBMA-based virtual link
created by the OMNI Adaptation. So, I stopped midway through marking up the document
with my comments because it has taken a complete left turn and started down a wrong path.

What is mainly at the heart of the divergence is that the document now embraces the
multilink IPv6 subnet model vs the AERO/OMNI NBMA link model that was there the last
time I looked. But, there is no need for such complication when there is a much simpler
alternative at hand. I notice also that in the appendices the AERO/OMNI "6M's of Mobile
Internetworking" was removed - at the very least that needs to be restored.

In its current form, this document has been diverted to go down the wrong path. It
needs to be either re-balanced or re-written.

Thanks - Fred

> From: its [mailto:[email-masked]] On Behalf Of Templin (US), Fred L
> Sent: Monday, February 21, 2022 7:28 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Feb 2022 15:26:47 -0500

Paul and Fred:

I think the update is more aligned with the documents that are advancing one the IETF stream.  That said, I would not be apposed to the inclusion of the 6M's, but not in a way that claims that there is only one approach way to address these things.  What do you think about that was a way forward?

Russ

> On Feb 21, 2022, at 2:56 PM, Templin (US), Fred L <[email-masked]> wrote:
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 22 Feb 2022 12:47:27 +0900

Hi Fred,
As you find, it is true that the text of AERO/OMNI is reduced to address
the INTDIR reviewer (Pascal Thubert) during the IETF Last Call.
However, I tried to balance the contents and importance of both the
approaches.

Let's listen to the IESG's review and address their comments.

I am sorry for not satisfying your expectations fully.

Best Regards,
Paul

On Tue, Feb 22, 2022 at 4:56 AM Templin (US), Fred L <
[email-masked]> wrote:

> > Subject: Re: [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
> >
> > > Subject: [EXTERNAL] [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
> > >
> > >         Title           : IPv6 Wireless Access in Vehicular
> Environments (IPWAVE): Problem Statement and Use Cases

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 22 Feb 2022 12:49:36 +0900

Hi Russ,
I have replied to Fred's email just before.
As the editor, I tried to balance the two approaches even though the text
of AERO/OMNI is reduced.

Fred,
I hope you can understand my position as the editor.

Thanks.

Best Regards,
Paul

On Tue, Feb 22, 2022 at 5:26 AM Russ Housley <[email-masked]> wrote:

> Paul and Fred:
>
> I think the update is more aligned with the documents that are advancing
> one the IETF stream.  That said, I would not be apposed to the inclusion of
> the 6M's, but not in a way that claims that there is only one approach way
> to address these things.  What do you think about that was a way forward?
>
> Russ
>
>