Subject: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 22 Feb 2022 14:34:45 +0000

The way the document is now, it reads as an endorsement for a particular approach.
The document was good last time I read it (which is a while ago) but I guess someone
got you to make drastic changes without my knowing about it. The document cannot
go forward in its current form.

Fred

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Monday, February 21, 2022 7:50 PM
To: Russ Housley <[email-masked]>; Templin (US), Fred L <[email-masked]>
Cc: [email-masked]; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: [EXTERNAL] Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

EXT email: be mindful of links/attachments.

Hi Russ,
I have replied to Fred's email just before.
As the editor, I tried to balance the two approaches even though the text of AERO/OMNI is reduced.

Fred,
I hope you can understand my position as the editor.

Thanks.

Best Regards,
Paul

On Tue, Feb 22, 2022 at 5:26 AM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
Paul and Fred:

I think the update is more aligned with the documents that are advancing one the IETF stream.  That said, I would not be apposed to the inclusion of the 6M's, but not in a way that claims that there is only one approach way to address these things.  What do you think about that was a way forward?

Russ

> On Feb 21, 2022, at 2:56 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi, I started reviewing this and found that it has been completely overhauled since I put my
> comments in many months ago. It has in fact been completely rewritten to favor the shared
> IPv6 multilink subnet model over multihop networks, to favor RPL/6LowPan over standard
> MANET routing protocols, to favor IPv6 ND changes over standard IPv6 ND, and to favor
> multilink DAD. None of that is necessary with AERO/OMNI and the NBMA-based virtual link
> created by the OMNI Adaptation. So, I stopped midway through marking up the document
> with my comments because it has taken a complete left turn and started down a wrong path.
>
> What is mainly at the heart of the divergence is that the document now embraces the
> multilink IPv6 subnet model vs the AERO/OMNI NBMA link model that was there the last
> time I looked. But, there is no need for such complication when there is a much simpler
> alternative at hand. I notice also that in the appendices the AERO/OMNI "6M's of Mobile
> Internetworking" was removed - at the very least that needs to be restored.
>
> In its current form, this document has been diverted to go down the wrong path. It
> needs to be either re-balanced or re-written.
>
> Thanks - Fred
>
>> -----Original Message-----
>> From: its [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Templin (US), Fred L
>> Sent: Monday, February 21, 2022 7:28 AM
>> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>> Subject: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt
>>
>> Hi, it looks like a lot of what was in the draft regarding AERO/OMNI has been cut out
>> so that means I am going to have to re-review it. I will get to this a soon as possible;
>> hopefully in the next couple of days.
>>
>> Fred
>>
>>> -----Original Message-----
>>> From: its [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
>>> Sent: Sunday, February 20, 2022 9:00 PM
>>> To: [email-masked]<mailto:[email-masked]>
>>> Cc: [email-masked]<mailto:[email-masked]>
>>> Subject: [EXTERNAL] [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt
>>>
>>> EXT email: be mindful of links/attachments.
>>>
>>>
>>>
>>>
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>> This draft is a work item of the IP Wireless Access in Vehicular Environments WG of the IETF.
>>>
>>>        Title           : IPv6 Wireless Access in Vehicular Environments (IPWAVE): Problem Statement and Use Cases
>>>        Author          : Jaehoon (Paul) Jeong
>>>     Filename        : draft-ietf-ipwave-vehicular-networking-26.txt
>>>     Pages           : 49
>>>     Date            : 2022-02-20
>>>
>>> Abstract:
>>>   This document discusses the problem statement and use cases of
>>>   IPv6-based vehicular networking for Intelligent Transportation
>>>   Systems (ITS).  The main scenarios of vehicular communications are
>>>   vehicle-to-vehicle (V2V), vehicle-to-infrastructure (V2I), and
>>>   vehicle-to-everything (V2X) communications.  First, this document
>>>   explains use cases using V2V, V2I, and V2X networking.  Next, for
>>>   IPv6-based vehicular networks, it makes a gap analysis of current
>>>   IPv6 protocols (e.g., IPv6 Neighbor Discovery, Mobility Management,
>>>   and Security & Privacy), and then enumerates requirements for the
>>>   extensions of those IPv6 protocols for IPv6-based vehicular
>>>   networking.
>>>
>>>
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-ietf-ipwave-vehicular-networking/
>>>
>>> There is also an htmlized version available at:
>>> https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-26
>>>
>>> A diff from the previous version is available at:
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-vehicular-networking-26
>>>
>>>
>>> Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts
>>>
>>>
>>> _______________________________________________
>>> its mailing list
>>> [email-masked]<mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/its
>>
>> _______________________________________________
>> its mailing list
>> [email-masked]<mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/its
>
> _______________________________________________
> its mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/its

---

From: <[email-masked]>
Date: Tue, 22 Feb 2022 15:45:36 +0000

Dear Fred, Paul, Russ and all,
From my point of view - only loosely following this discussion - I do agree that Paul has achieved a good balance between different protocols included/mentioned. Thanks for that!

Just a small typo: on page 3 it should also read
‘Automatic Extended Route Optimization (AERO)’ instead of ‘Asymmetric Extended Route Optimization (AERO)’
And maybe one could add on p. 14 the sentence
‘Refer to Appendix A for the description how OMNI can support use of multiple radio technologies in V2X’.

Would that help? What do you think?
Thanks
Best regards
Dirk

Von: its <[email-masked]> Im Auftrag von Templin (US), Fred L
Gesendet: Dienstag, 22. Februar 2022 15:35
An: Mr. Jaehoon Paul Jeong <[email-masked]>; Russ Housley <[email-masked]>
Cc: [email-masked]
Betreff: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Fred

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Monday, February 21, 2022 7:50 PM
To: Russ Housley <[email-masked]<mailto:[email-masked]>>; Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Hi Russ,

Fred,

Thanks.

Best Regards,
Paul

Russ

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 22 Feb 2022 15:57:07 +0000

Doesn’t work, Dirk. Several months ago, Paul took my edits and the document looked
good. Then, someone came in later without my knowing about it and said “take out
all of the AERO/OMNI stuff”, and no one told me about it. This is no longer a balanced
document; this is a document that embraces a particular solution alternative while
ignoring another.

You and I had a testy exchange earlier; if your message is a continuation of that
exchange I can tell you that I do not appreciate it.

Fred

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 22, 2022 7:46 AM
To: Templin (US), Fred L <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [EXTERNAL] AW: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Von: its <[email-masked]<mailto:[email-masked]>> Im Auftrag von Templin (US), Fred L
Gesendet: Dienstag, 22. Februar 2022 15:35
An: Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>>; Russ Housley <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Fred

Hi Russ,

Fred,

Thanks.

Best Regards,
Paul

Russ

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 23 Feb 2022 07:20:14 +0900

Hi Dirk,
I will address your comments on the revision.

You are right.
AERO uses Automatic instead of Asymmetric in the latest version.

Thanks.

Best Regards,
Paul

2022년 2월 23일 (수) 오전 12:45, <[email-masked]>님이 작성:

> From my point of view - only loosely following this discussion - I do
> agree that Paul has achieved a good balance between different protocols
> included/mentioned. Thanks for that!
>
>
>
> *Von:* its <[email-masked]> *Im Auftrag von *Templin (US), Fred L
> *Gesendet:* Dienstag, 22. Februar 2022 15:35
> *An:* Mr. Jaehoon Paul Jeong <[email-masked]>; Russ Housley <
> [email-masked]>
> *Cc:* [email-masked]
> *Betreff:* Re: [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
>
>
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Monday, February 21, 2022 7:50 PM
> *To:* Russ Housley <[email-masked]>; Templin (US), Fred L <
> [email-masked]>
> *Cc:* [email-masked]; Mr. Jaehoon Paul Jeong <[email-masked]>
> *Subject:* [EXTERNAL] Re: [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
>
>
>
> On Tue, Feb 22, 2022 at 5:26 AM Russ Housley <[email-masked]> wrote:
>
> Paul and Fred:
>
> I think the update is more aligned with the documents that are advancing
> one the IETF stream.  That said, I would not be apposed to the inclusion of
> the 6M's, but not in a way that claims that there is only one approach way
> to address these things.  What do you think about that was a way forward?
>
> Russ
>
>
> > On Feb 21, 2022, at 2:56 PM, Templin (US), Fred L <
> [email-masked]> wrote:
> >
> >> From: its [mailto:[email-masked]] On Behalf Of Templin (US),
> Fred L
> >> To: [email-masked]; [email-masked]
> >> Subject: Re: [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
> >>
> >>> From: its [mailto:[email-masked]] On Behalf Of
> [email-masked]
> >>> To: [email-masked]
> >>> Cc: [email-masked]
> >>> Subject: [EXTERNAL] [ipwave] I-D Action:
> draft-ietf-ipwave-vehicular-networking-26.txt
> >>>
> >>>        Title           : IPv6 Wireless Access in Vehicular
> Environments (IPWAVE): Problem Statement and Use Cases
> >>> [email-masked]
> >> [email-masked]
> > [email-masked]
> --
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department Head
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Erik Kline <[email-masked]>
Date: Tue, 22 Feb 2022 22:22:28 -0800

The inclusion of the OMNI stuff was highlihgted during the LC, and I agreed
to advance draft 25 to the IESG telechat.

Now I have to re-review draft 27.  I don't know what's changed, but, in
general, please avoid major surgery between IETF LC and IESG telechat.  We
might need to pull draft 27 back for a 2nd LC.

/me goes to have a look and the diff...

On Tue, Feb 22, 2022 at 7:58 AM Templin (US), Fred L <
[email-masked]> wrote:

> *From:* [email-masked] [mailto:[email-masked]]
> *Sent:* Tuesday, February 22, 2022 7:46 AM
> *To:* Templin (US), Fred L <[email-masked]>;
> [email-masked]; [email-masked]
> *Cc:* [email-masked]
> *Subject:* [EXTERNAL] AW: [ipwave] I-D Action:

---

From: Erik Kline <[email-masked]>
Date: Tue, 22 Feb 2022 22:30:04 -0800

I apologize; I see now the diff is small.  I was terribly afraid that the
fast-rev'ing version numbers meant lots of text was in flight (as opposed
to just being held for fixing small things during incorporation of IESG
feedback).

Russ, Carlos,

If you think this document is not ready for the IESG telechat let me know
and I'll pull it back so it can get some more rounds of consideration.  For
now I'm inclined to let it stay.

Thanks, and apologies,
-Erik

On Tue, Feb 22, 2022 at 10:22 PM Erik Kline <[email-masked]> wrote:

> The inclusion of the OMNI stuff was highlihgted during the LC, and I
> agreed to advance draft 25 to the IESG telechat.
>

---

From: <[email-masked]>
Date: Wed, 23 Feb 2022 13:33:16 +0000

Hi Fred,
sorry if I should have used aggressive wording or other ways of not constructively discussed – it wasn’t meant as such!
BTW I can’t remember the heated discussion you mention – perhaps I haven’t realized but be assured that I am also not interested in that.
What I meant was that after a quick review the different protocols considered in the draft seem to me to be more or less here similarly treated – whether AERO and OMNI or (P)MIP6, DMM, etc. – except that RPL is discussed in more detail – but also pointing to disadvantages explicitly.
IMHO the shortening was due to the overall length of the document but I may be wrong.
Sorry for un-deliberately upsetting you!

Best Regards
Dirk

Von: Templin (US), Fred L <[email-masked]>
Gesendet: Dienstag, 22. Februar 2022 16:57
An: von Hugo, Dirk <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: RE: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Fred

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, February 22, 2022 7:46 AM
To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] AW: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-26.txt

Fred

Hi Russ,

Fred,

Thanks.

Best Regards,
Paul

Russ