Subject: Re: [Jmap] Call for adoption: JMAP QUOTA

From: René CORDIER <[email-masked]>
Date: Mon, 30 Sep 2019 08:41:42 +0000

Hi everybody,

I believe I saw some concerns during the call for adoption that will definitely deserve some attention, like multiple levels of quotas, or trying to understand why quotas with IMAP were not widely supported and what can we do to change it with JMAP.

But I don't remember seeing any strong objection to it ! The vote was supposed to finish Friday 20th of September. Is it reasonable to ask to move forward then?

Regards,

Rene.

Le 6 septembre 2019 07:36, de [email-masked]

Just to make it official!

This is a call for adoption for a specification for exposing (and potentially also managing) quotas over JMAP.  As there are already multiple people in favour per the thread at https://mailarchive.ietf.org/arch/msg/jmap/G4C83gJEgjrjxi52J7UKaMc9TpY I am asking now if there are any objections.

If you do have objections, please make them by Friday, 20 September (2 weeks from today).  If there are no objections we will adopt a draft at that point.

As a starting point we will work from https://github.com/linagora/jmap/pull/19.

I believe this work is within our charter, specifically:

Extensions to the existing core and mail JMAP specifications are also

within scope for this working group, for example any additional parts

of SIEVE, IMAP, SMTP submission, as well as transport of JMAP over

WSS (WebSocket over TLS, RFC 6455).

Quota exists as part of IMAP (RFC2087), so is in scope.

This proposed work will also take into account the work on IMAP quota being done in the EXTRA working group on https://datatracker.ietf.org/doc/draft-ietf-extra-quota/

Regards,

Bron.

--

Bron Gondwana, CEO, Fastmail Pty Ltd

[email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 30 Sep 2019 20:38:42 +1000

For sure! Sorry I forgot to move forward on it. If you could upload it with the name draft-ietf-jmap-quota then we can start work on the next revision :)

It will obviously be on the agenda for Singapore as well.

Cheers,

Bron.

>>> Extensions to the existing core and* mail* JMAP specifications are also
>>> of SIEVE, *IMAP*, SMTP submission, as well as transport of JMAP over
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
>