Subject: [Jmap] Call for adoption: JMAP QUOTA

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 06 Sep 2019 10:36:46 +1000

Just to make it official!

This is a call for adoption for a specification for exposing (and potentially also managing) quotas over JMAP. As there are already multiple people in favour per the thread at https://mailarchive.ietf.org/arch/msg/jmap/G4C83gJEgjrjxi52J7UKaMc9TpY I am asking now if there are any objections.

If you do have objections, please make them by Friday, 20 September (2 weeks from today). If there are no objections we will adopt a draft at that point.

As a starting point we will work from https://github.com/linagora/jmap/pull/19.

I believe this work is within our charter, specifically:

> Extensions to the existing core and* mail* JMAP specifications are also
> within scope for this working group, for example any additional parts
> of SIEVE, *IMAP*, SMTP submission, as well as transport of JMAP over
> WSS (WebSocket over TLS, RFC 6455).

Quota exists as part of IMAP (RFC2087), so is in scope.

This proposed work will also take into account the work on IMAP quota being done in the EXTRA working group on https://datatracker.ietf.org/doc/draft-ietf-extra-quota/

Regards,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 6 Sep 2019 10:07:36 +0200

If this is adopted, then I believe action item number one should be to 
consider why the IMAP equivalent was poorly supported, and number two 
to write principles for how to prevent the same problem (s).

Arnt

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 13 Sep 2019 12:28:57 +1000

Yes, definitely. There's going to need to be some thought to get this working correctly, and extensible to new datatypes like the underway JMAP Calendars, and the soon to come JMAP Contacts!

Cheers,

Bron.

On Thu, Sep 12, 2019, at 23:13, John van der Kamp wrote:
> Some services use multiple levels of quota. 1st level may act as a warning, notifying the user he’s close to its quota unless actions are taken. 2nd level would block outgoing messages. 3rd and last level also blocks incoming emails bouncing those to the sender. Only the last level would be required, the rest optional. It looks like this is missing from the spec. Would it be worth considering?

> John

> *From:* Jmap [mailto:[email-masked]] *On Behalf Of *Bron Gondwana
> *Sent:* Friday, 6 September, 2019 02:37
> *To:* [email-masked]
> *Subject:* [Jmap] Call for adoption: JMAP QUOTA

> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
> 
> 
> 
> Amazon Development Center (Netherlands) B.V., Johanna Westerdijkplein 1, 2521 EN The Hague, Registration No. Chamber of Commerce 56869649, VAT: NL 852339859B01
> 
>

---

From: Benoît TELLIER <[email-masked]>
Date: Fri, 13 Sep 2019 02:54:03 +0000

Agree, there is no need to get this specific to emails.

Le 13 septembre 2019 09:28, de [email-masked]

Cheers,

Bron.

John

From: Jmap [mailto:[email-masked]] On Behalf Of Bron Gondwana
Sent: Friday, 6 September, 2019 02:37
To: [email-masked]
Subject: [Jmap] Call for adoption: JMAP QUOTA

Extensions to the existing core and mail JMAP specifications are also

of SIEVE, IMAP, SMTP submission, as well as transport of JMAP over

Regards,

Bron.

--

[email-masked]

Jmap mailing list

[email-masked]

--

[email-masked]