Subject: [Jmap] Proposition: JMAP quotas specifications draft

From: René CORDIER <[email-masked]>
Date: Wed, 4 Sep 2019 07:20:52 +0000

Hello everybody,

With some colleagues at Linagora, we felt the need of having an addition to JMAP regarding Quotas. We want to be able to give mail clients using JMAP a way of getting and displaying quotas of a user's mailbox in a context where it allows us to explain, as much as possible, the business rule behind the quota to the final user.

So we brainstormed and wrote a draft regarding JMAP Quotas specifications. But before submitting officially anything, we would like to discuss it with the rest of the JMAP community. We would be really happy if other people from the JMAP working group could review it, giving feedbacks, so that we could arrive to a consensus all together so that this extension could provide useful not only to us, but also to the rest of the community.

You will be able to find our draft of the specification in the form of a markdown here : https://github.com/linagora/jmap/pull/19

Thank you and please don't hesitate to take some time to discuss it with us !

Best regards,

Rene.

---

From: "Alexey Melnikov" <[email-masked]>
Date: Wed, 04 Sep 2019 14:54:06 +0100

Hi René,

> Thank you and please don't hesitate to take some time to discuss it with us !

This is useful work and I think it would be worth working on in the JMAP WG.

I suggest the text and terminology should be syncrhonized with my draft in the EXTRA WG:
https://datatracker.ietf.org/doc/draft-ietf-extra-quota/?include_text=1

Best Regards,
Alexey

> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 05 Sep 2019 08:15:25 +1000

Definitely agree that it's worthwhile work. We have a Quota spec internally at Fastmail which we'd be happy to go over and see if there's stuff we want to propose to add to your draft.

I'm happy to do a call for adoption in the group straight away for this - knowing that there may be some design rounds as well :)

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: René CORDIER <[email-masked]>
Date: Thu, 5 Sep 2019 03:25:54 +0000

Hi guys,

Thank you a lot for your feedbacks, I highly appreciate it.

Sure don't hesitate to share points you want to discuss, especially if you have an internal Quota spec which means you gave it some serious thoughts on it already as well :)

Best regards,

Rene.

Le 5 septembre 2019 05:15, de [email-masked]

Cheers,

Bron.

Hi René,

Hello everybody,

Best Regards,

Alexey

Best regards,

Rene.

Jmap mailing list

[email-masked]

Jmap mailing list

[email-masked]

--

[email-masked]