Subject: [Jmap] Barry Leiba's Yes on charter-ietf-jmap-02-00: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Tue, 03 Dec 2019 06:07:31 -0800

Barry Leiba has entered the following ballot position for
charter-ietf-jmap-02-00: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-jmap/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Actually, "Yes, but..."

The concrete deliverables at the bottom include JSCalendar but not JSContact;
please add one for the latter.

That would make five concrete deliverables, of which only two (websockets and
MDNs) have milestones listed.  It would be nice to have milestones for the
others.

And there's a milestone for which there's no listed deliverable (the
implementation guidance).  I'm ambivalent here: does it make sense to list it
as a deliverable?  Or maybe it's better just to have it in the milestones, as
there is a "catch-all" deliverable that will cover it.

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 05 Dec 2019 22:34:48 +1100

> charter-ietf-jmap-02-00: Yes

Thanks Barry!

I have attached an updated draft charter. It is also available from the master copy where I track changes on Github:

https://github.com/jmapio/jmap/blob/master/ietf-docs/charter.txt

This explicit change is:

https://github.com/jmapio/jmap/commit/23a26b22c5d56c4531f71806b03894180fa1b0c8

> please add one for the latter.

When I wrote this, we hadn't yet chosen the location for JSContact work to occur, which is why it wasn't included. I have updated that now to include both the JSContact format for contacts and groups of contacts, and a JMAP Contacts document to describe how to access addressbooks which contain records in JSContact format.

> MDNs) have milestones listed. It would be nice to have milestones for the

I can do that. I already had milestone dates agreed at IETF106 for JSContact, but had not yet had them in datatracker because JSContact isn't in scope until this charter is accepted! I will add milestones for all deliverables once the recharter is finished.

> there is a "catch-all" deliverable that will cover it.

We decided at IETF106 to keep that milestone around for now as we think it's a useful document to produce.

I have added additional text to the bottom of the draft charter:

Also within scope for this working group are informational documents for converting between JMAP data representation and other formats which can be used to specify the same underlying data.

JSCalendar also has a document of this type:

https://datatracker.ietf.org/doc/draft-ietf-calext-jscalendar-icalendar/

Though it's being tracked in the CALEXT working group because that's where the JSCalendar format was worked on.

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]