Subject: [Jmap] draft-ietf-jmap-mdn-06

From: Ken Murchison <[email-masked]>
Date: Thu, 5 Mar 2020 19:40:00 -0500

A few questions as I implement this in Cyrus:

- forEmailId is allowed to be null, presumably just for MDN/parse 
responses.  Should we mandate that it be non-null for MDN/send, because 
otherwise, what's the point?

- subject and textBody are both allowed to be null.  Should we recommend 
default text for both?

- The JMAP server may not be able to determine the Final-Recipient of 
the original message was Bcc'd or sent to an alias.  Should the MDN 
object include a 'from' property?

-- 
Ken Murchison
Cyrus Development Team
Fastmail US LLC

---

From: Ken Murchison <[email-masked]>
Date: Fri, 6 Mar 2020 14:35:46 -0500

On 3/5/20 7:40 PM, Ken Murchison wrote:
> responses.  Should we mandate that it be non-null for MDN/send, 
> because otherwise, what's the point?
>
> - subject and textBody are both allowed to be null.  Should we 
> recommend default text for both?
>

Also, do we need a specific error type if the email corresponding to 
fromEmailId does NOT have a Disposition-Notification-To header?  Or do 
we use invalidProperties, forbidden, invalidEmail, noRecipients?

-- 
Ken Murchison
Cyrus Development Team
Fastmail US LLC

---

From: Raphael OUAZANA <[email-masked]>
Date: Wed, 18 Mar 2020 17:42:46 +0000

Hello,

Le 6 mars 2020 20:35, de [email-masked]

> because otherwise, what's the point?

Exactly. I'm adding a word about this.

> recommend default text for both?

I think it asks more questions than it solves an issue. How the server can choose the good language to send the notification?

> object include a 'from' property?

It should match the email of the account, no?

Or maybe we should ask for an identity when sending an MDN, so that the user can choose which email appears in this field?

It seems I missed the notFound error, I'm adding it.

Regards,

Raphaël Ouazana.

---

From: Ken Murchison <[email-masked]>
Date: Wed, 18 Mar 2020 14:09:43 -0400

> It should match the email of the account, no?

If the email was sent to an email alias and eventually delivered to the 
underlying account, the sender of the MDN might want to have the MDN use 
the alias so as not to leak the real address of the account.

> Or maybe we should ask for an identity when sending an MDN, so that 
> the user can choose which email appears in this field?
>

Yes, that is what I was thinking.  If the user doesn't provide a from 
address, then we can default to the email of the account.

-- 

Ken Murchison
Cyrus Development Team
Fastmail US LLC

---

From: Raphael OUAZANA <[email-masked]>
Date: Thu, 19 Mar 2020 10:17:18 +0000

Le 18 mars 2020 19:09, de [email-masked]

On 3/18/20 1:42 PM, Raphael OUAZANA
wrote:

Hello,

If the email was sent to an email alias and eventually delivered
to the underlying account, the sender of the MDN might want to
have the MDN use the alias so as not to leak the real address of
the account.

Or maybe we should ask for an identity when sending an MDN, so
that the user can choose which email appears in this field?

Yes, that is what I was thinking.  If the user doesn't provide a
from address, then we can default to the email of the account.

I will add an identity parameter, like in MessageSubmission. I will make it mandatory because for me it's not clear how we can get an email address from an account.

Regards,

Raphaël.

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 20 Mar 2020 16:43:49 +1100

Thanks for that. 

With that done, I BELIEVE that we -08 resolves every issue outstanding. Do you agree? I'll go ahead and do the shepherd writeup if so.

Cheers,

Bron.

On Thu, Mar 19, 2020, at 21:17, Raphael OUAZANA wrote:

>> If the email was sent to an email alias and eventually delivered to the underlying account, the sender of the MDN might want to have the MDN use the alias so as not to leak the real address of the account.

>> Yes, that is what I was thinking. If the user doesn't provide a from address, then we can default to the email of the account.

> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
> 

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Raphael OUAZANA <[email-masked]>
Date: Fri, 20 Mar 2020 08:24:55 +0000

I agree, I think I've fixed every comments with -08.

Thanks,

Raphaël.

Le 20 mars 2020 06:43, de [email-masked]

Thanks for that.

Cheers,

Bron.

Hello,

Regards,

Raphaël.

Jmap mailing list

[email-masked]

--

[email-masked]