Subject: [Jmap] Fwd: New Version Notification for draft-gondwana-jmap-blob-00.txt

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 02 Nov 2020 14:16:35 +1100

As promised a very rough first draft to show the shape of things.

In particular, it's probably worth looking at whether the 'catenate' logic makes sense to include directly in 'set' or whether it should be a separate item.

Also need to work out how to report which blob is missing for a catenate error!

Finally, I'm not totally happy with the "lookup" logic.  Right now Cyrus has "Blob/get" doing what I'm creating with lookup, but of course that's kinda non-standard usage of 'get' and I'd like to change it.

Bron.

----- Original message -----
From: [email-masked]
To: Bron Gondwana <[email-masked]>
Subject: New Version Notification for draft-gondwana-jmap-blob-00.txt
Date: Monday, November 02, 2020 14:08

A new version of I-D, draft-gondwana-jmap-blob-00.txt
has been successfully submitted by Bron Gondwana and posted to the
IETF repository.

Name: draft-gondwana-jmap-blob
Revision: 00
Title: JMAP Blob management extension
Document date: 2020-11-02
Group: Individual Submission
Pages: 7
URL:            https://www.ietf.org/archive/id/draft-gondwana-jmap-blob-00.txt
Status:         https://datatracker.ietf.org/doc/draft-gondwana-jmap-blob/
Html:           https://www.ietf.org/archive/id/draft-gondwana-jmap-blob-00.html
Htmlized:       https://tools.ietf.org/html/draft-gondwana-jmap-blob-00

Abstract:
   The JMAP base protocol (RFC8620) provides the ability to upload and
   download arbitrary binary data via HTTP PUT and GET on defined
   endpoint.  This binary data is called a "Blob".

   This extension adds additional ways to handle Blobs, by making inline
   method calls within a standard JMAP request.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Ken Murchison <[email-masked]>
Date: Mon, 2 Nov 2020 07:15:43 -0500

FYI, you have this updating RFC 5228, which is obviously an artifact of 
reusing an existing draft as a template.

On 11/1/20 10:16 PM, Bron Gondwana wrote:

> In particular, it's probably worth looking at whether the 'catenate' 
> logic makes sense to include directly in 'set' or whether it should be 
> a separate item.
>
> Finally, I'm not totally happy with the "lookup" logic.  Right now 
> Cyrus has "Blob/get" doing what I'm creating with lookup, but of 
> course that's kinda non-standard usage of 'get' and I'd like to change it.
>
> Bron.
>
> From: [email-masked] <mailto:[email-masked]>
> To: Bron Gondwana <[email-masked] <mailto:[email-masked]>>
> <https://www.ietf.org/archive/id/draft-gondwana-jmap-blob-00.txt>
> <https://datatracker.ietf.org/doc/draft-gondwana-jmap-blob/>
> <https://www.ietf.org/archive/id/draft-gondwana-jmap-blob-00.html>
> <https://tools.ietf.org/html/draft-gondwana-jmap-blob-00>
>
>
> Abstract:
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap

-- 
Kenneth Murchison
Senior Software Developer
Fastmail US LLC

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 04 Nov 2020 20:13:08 +1100

Dammit!  Thanks, will fix when allowed.

On Mon, Nov 2, 2020, at 23:15, Ken Murchison wrote:
> FYI, you have this updating RFC 5228, which is obviously an artifact of reusing an existing draft as a template.

Jmap mailing list
Kenneth Murchison

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 16 Nov 2020 12:48:11 +1100

As promised, v01 is now uploaded with the updating fixed, and also the working group name fixed, and also an example for Blob/set.

Bron.

Jmap mailing list
Kenneth Murchison