Subject: [Jmap] JMAP SieveScript/test

From: Ken Murchison <[email-masked]>
Date: Tue, 23 Mar 2021 16:31:37 -0400

All,

At IETF 110 I presented the format of the SIeveScript/test response that 
is currently documented in 
https://tools.ietf.org/html/draft-ietf-jmap-sieve-04#section-2.5 
<https://tools.ietf.org/html/draft-ietf-jmap-sieve-04#section-2.5> as 
well as a possible alternative format.  It was determined during the 
session that I should ask the list which of the two formats is preferred 
and take proposals any any other possible formats.

The current format is a tuple with three elements, representation as a 
JSON array:

      [
        "vacation",
        {
          ":fcc": "INBOX.Sent",
          ":flags": [ "\\answered" ],
          ":subject": "Auto: test email",
          ":from": "[email-masked]"
        },
        [ “Gone fishing.” ]
      ]

The alternative format is a JSON object with three named elements:

        {
          “type”: "vacation",
          “taggedArgs”: {
                          ":fcc": "INBOX.Sent",
                          ":flags": [ "\\answered" ],
                          ":subject": "Auto: test email",
                          ":from": "[email-masked]"
                        },
          “positionalArgs”: [ “Gone fishing.” ]
        }

Please respond with your preference or any other thoughts.

-- 
Kenneth Murchison
Senior Software Developer
Fastmail US LLC

---

From: "Neil Jenkins" <[email-masked]>
Date: Wed, 24 Mar 2021 11:03:41 +1100

I'd probably go with the second option (named elements) for this.

Neil.

---

From: Ken Murchison <[email-masked]>
Date: Wed, 24 Mar 2021 07:14:00 -0400

Hi Neil,

If we go this route, are you ok with the existing names for the elements?

Is "type" ok?  Should this be "name" or "action"?

Should we expand "Args" to "Arguments"?

I have no strong opinions, and its not like end-users will be spending a 
ton of time looking at wire protocol.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 24 Mar 2021 16:03:47 +0000

> I'd probably go with the second option (named elements) for this.
This is my preference as well.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 24 Mar 2021 16:05:36 +0000

Hi Ken,

> Is "type" ok?  Should this be "name" or "action"?
I think "action" is better, but not a big deal.
> Should we expand "Args" to "Arguments"?
No.
>
> I have no strong opinions, and its not like end-users will be spending 
> a ton of time looking at wire protocol.
>

---

From: "Neil Jenkins" <[email-masked]>
Date: Thu, 25 Mar 2021 11:32:24 +1100

> Is "type" ok?  Should this be "name" or "action"?

I agree with Alexey: I think "action" is better; "type" is such an overloaded word, it's better to avoid when there's a good alternative.

> Should we expand "Args" to "Arguments"?

Not fussed; happy to keep it as Args.

Neil.