Subject: [jose] JSON Web Signature, Encryption comment, signature best practices

From: <[email-masked]>
Date: Wed, 14 Mar 2012 15:33:01 +0000

Hi

You might wish to add an informative reference to XML Signature 1.1 to  the JSON web signature draft (similar to having informative reference to XML Encryption 1.1 in JSON encryption draft).

[XMLDSIG-CORE1]
D. Eastlake, J. Reagle, D. Solo, F. Hirsch, T. Roessler, K. Yiu. XML Signature Syntax and Processing Version 1.1. 3 March 2011. W3C Candidate Recommendation. (Work in progress.) URL: http://www.w3.org/TR/2011/CR-xmldsig-core1-20110303/

The XML Encryption 1.1 reference should be updated

[XMLENC-CORE1]
J. Reagle; D. Eastlake; F. Hirsch; T. Roessler. XML Encryption Syntax and Processing Version 1.1. 13 March 2012. W3C Candidate Recommendation. (Work in progress.) URL: http://www.w3.org/TR/2012/CR-xmlenc-core1-20120313/

In addition, it might be useful to reference the XML Signature Best  Practices document, as similar issues may apply to JSON signing

[XMLDSIG-BESTPRACTICES]
Pratik Datta; Frederick Hirsch. XML Signature Best Practices. 9 August 2011. W3C Working Draft. (Work in progress.) URL:http://www.w3.org/TR/2011/WD-xmldsig-bestpractices-20110809/

regards, Frederick

Frederick Hirsch, Nokia
Chair XML Security WG

---

From: Mike Jones <[email-masked]>
Date: Wed, 14 Mar 2012 16:57:19 +0000

Will do - thanks!

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, March 14, 2012 8:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [jose] JSON Web Signature, Encryption comment, signature best practices

Hi

[XMLDSIG-CORE1]

[XMLENC-CORE1]

[XMLDSIG-BESTPRACTICES]

regards, Frederick

Frederick Hirsch, Nokia
Chair XML Security WG

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose