Subject: [jose] Whiteboard discussion

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Wed, 7 Nov 2012 16:10:28 +0000

If you're interested in participating in the high-level architecture
discussion we just talked about in the room, and you're in Atlanta this
week, please send me a message off-list.

This activity is not intended to be secret in any way, we are just going
to try to put together an email to the list that combines all of the
different ideas that we heard in the room as a coherent world view, so the
group can form an opinion about precisely how many documents we're writing.

-- 
Joe Hildebrand

---

From: Dick Hardt <[email-masked]>
Date: Tue, 13 Nov 2012 08:08:28 -0800

Was there an output from this discussion? 

On Nov 7, 2012, at 8:10 AM, Joe Hildebrand (jhildebr) <[email-masked]> wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Axel Nennker <[email-masked]>
Date: Wed, 14 Nov 2012 17:40:29 +0100

The suspense is killing me too. I am not a fan of off-list discussions.
Axel

2012/11/13 Dick Hardt <[email-masked]>

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Wed, 14 Nov 2012 17:05:58 +0000

Sorry, haven't had a chance to write it up. Hope to tonight.

There is not an extensive off-list discussion going on, just a personal bandwidth issue.

Mobile/terse. DYAC.

On Nov 14, 2012, at 9:40 AM, "Axel Nennker" <[email-masked]<mailto:[email-masked]>> wrote:

2012/11/13 Dick Hardt <[email-masked]<mailto:[email-masked]>>
Was there an output from this discussion?

On Nov 7, 2012, at 8:10 AM, Joe Hildebrand (jhildebr) <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

---

From: John Bradley <[email-masked]>
Date: Wed, 14 Nov 2012 14:17:39 -0300

Yes, Joe was going to post the summery to the list.

Mike and I fell sick with the flue over the weekend so I hope the same fate hasn't befallen Joe.

Richard is also going to write up a alternate proposal and circulate that as well.

Basically we discussed:

1 Extending JWK with formats for symmetric and private keys.

2 Adding a Password Based encryption algorithm to JWA.  

3 Using JWE as the container for protected key info (JWE wrapped JWK).

There was discussion on how to best arrange the new material in the specs and not have the addition slow progress.

It looked like this would meet the needs of the Web Crypto folks and  Matt's need for key transport.

Richard, has what I characterize as an optimization, in mind.   I don't intend to explain it as I don't understand it enough to do it justice.
He is going to write it up.

I have some photos of whiteboards, but those are probably not decipherable by non attendees.

No big secret.  Joe and Jim will get the results and some recommended divvying up of the work out shortly I expect.

John B.