Subject: Re: [jose] #20: Shorter names for JSON serialization

From: "Vladimir Dzhuvinov / NimbusDS" <[email-masked]>
Date: Wed, 08 May 2013 01:39:41 -0700

+1 for "iv" and "tag"

--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked]

-------- Original Message --------
Subject: Re: [jose] #20: Shorter names for JSON serialization
From: Mike Jones <[email-masked]>
Date: Tue, May 07, 2013 10:40 pm
To: Richard Barnes <[email-masked]>, Jim Schaad <[email-masked]>
Cc: "[email-masked]"
<[email-masked]>, jose issue tracker
<[email-masked]>, "[email-masked]" <[email-masked]>

  What about “iv” and “tag”?  For the other names, I’d
actually prefer staying with those that are full words rather than those
that are abbreviations of words, since they’re more descriptive.  But
I agree that “initialization_vector” and “authentication_tag”
were overkill.
  
                                                             -- Mike
  
 From: Richard Barnes [mailto:[email-masked]] 
 Sent: Monday, May 06, 2013 2:51 PM
 To: Jim Schaad
 Cc: jose issue tracker;
[email-masked]; [email-masked]
 Subject: Re: [jose] #20: Shorter names for JSON serialization
  
 Even that's the name for the corresponding field in CMS
AuthEnvelopedData and AuthenticatedData?

 On Monday, May 6, 2013, Jim Schaad wrote:
 I would be againist calling the authentication_tag mac.  I don't object
to
 something like AuthTag.  It is not necessarily a MAC in all cases so
calling
 it one make thing problematical - much like calling a mac a sig.
 
 Jim

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]] On Behalf
Of
 > jose issue tracker
 > Sent: Monday, May 06, 2013 2:29 PM
 > To: [email-masked]; [email-masked]
 > Cc: [email-masked]
 > Subject: [jose] #20: Shorter names for JSON serialization
 >
 > #20: Shorter names for JSON serialization
 >
 >  I noticed as I was doing some programming with the JSON syntax for
 JWE/JWS
 > that the current field names in the JSON format are unnecessarily
 > cumbersome.  Nobody in the real world names a variable
 >  "initialization_vector", it's "iv".   Proposed changes:
 >
 >  || OLD                     || NEW  ||
 >  || signatures              || sigs ||
 >  || signature               || sig  ||
 >  || payload                 || data ||
 >  || recipients              || keys ||
 >  || ciphertext              || data ||
 >  || initialization_vector   || iv   ||
 >  || authentication_tag      || mac  ||
 >
 > --
 >
-------------------------+----------------------------------------------
 > -------------------------+---
 >  Reporter:  [email-masked]   |      Owner:  draft-ietf-jose-json-web-
 >      Type:  defect       |  [email-masked]
 >  Priority:  minor        |     Status:  new
 > Component:  json-web-    |  Milestone:
 >   encryption             |    Version:
 >  Severity:  -            |   Keywords:
 >
-------------------------+----------------------------------------------
 > -------------------------+---
 >
 > Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/20>
 > jose <http://tools.ietf.org/jose/>
 >
 > _______________________________________________
 > jose mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/jose

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Richard Barnes <[email-masked]>
Date: Wed, 8 May 2013 16:43:05 +0100

"iv" and "tag" would be OK.  I still prefer "mac" over "tag", for
consistency with CMS, and just because I think MAC is a more uniformly used
phrase.

What about "data" for "payload" and "ciphertext"?

---

From: Mike Jones <[email-masked]>
Date: Wed, 8 May 2013 18:39:40 +0000

The payload and the ciphertext are actually quite different kinds of fields - in particular, one is plain text and the other is encrypted.  Calling them both "data" would blur this distinction and potentially cause confusion.  I'd rather that we continued using different names when the things being named are different.

                                                            -- Mike

From: Richard Barnes [mailto:[email-masked]]
Sent: Wednesday, May 08, 2013 8:43 AM
To: Vladimir Dzhuvinov / NimbusDS
Cc: [email-masked]; jose issue tracker; [email-masked]
Subject: Re: [jose] #20: Shorter names for JSON serialization

"iv" and "tag" would be OK.  I still prefer "mac" over "tag", for consistency with CMS, and just because I think MAC is a more uniformly used phrase.

On Wed, May 8, 2013 at 9:39 AM, Vladimir Dzhuvinov / NimbusDS <[email-masked]<mailto:[email-masked]>> wrote:
+1 for "iv" and "tag"

--
Vladimir Dzhuvinov : www.NimbusDS.com<http://www.NimbusDS.com> : [email-masked]<mailto:[email-masked]>

-------- Original Message --------
Subject: Re: [jose] #20: Shorter names for JSON serialization
From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Date: Tue, May 07, 2013 10:40 pm
To: Richard Barnes <[email-masked]<mailto:[email-masked]>>, Jim Schaad <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>, jose issue tracker
<[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

  What about "iv" and "tag"?  For the other names, I'd
actually prefer staying with those that are full words rather than those
that are abbreviations of words, since they're more descriptive.  But
I agree that "initialization_vector" and "authentication_tag"
were overkill.

                                                             -- Mike

 From: Richard Barnes [mailto:[email-masked]<mailto:[email-masked]>]
 Sent: Monday, May 06, 2013 2:51 PM
 To: Jim Schaad
 Cc: jose issue tracker;
[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
 Subject: Re: [jose] #20: Shorter names for JSON serialization

 Jim

 > From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
Of
 > To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
 > Cc: [email-masked]<mailto:[email-masked]>
 JWE/JWS
 >  Reporter:  [email-masked]<mailto:[email-masked]>   |      Owner:  draft-ietf-jose-json-web-
 >      Type:  defect       |  [email-masked]<mailto:[email-masked]>
 > [email-masked]<mailto:[email-masked]>

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose
_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose