Subject: [jose] I-D Action: draft-ietf-jose-use-cases-01.txt

From: [email-masked]
Date: Sun, 26 May 2013 12:30:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Javascript Object Signing and Encryption Working Group of the IETF.

	Title           : Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)
	Author(s)       : Richard Barnes
	Filename        : draft-ietf-jose-use-cases-01.txt
	Pages           : 20
	Date            : 2013-05-26

Abstract:
   Many Internet applications have a need for object-based security
   mechanisms in addition to security mechanisms at the network layer or
   transport layer.  In the past, the Cryptographic Message Syntax has
   provided a binary secure object format based on ASN.1.  Over time,
   the use of binary object encodings such as ASN.1 has been overtaken
   by text-based encodings, for example JavaScript Object Notation.
   This document defines a set of use cases and requirements for a
   secure object format encoded using JavaScript Object Notation, drawn
   from a variety of application security mechanisms currently in
   development.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-jose-use-cases

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-jose-use-cases-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-jose-use-cases-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Richard Barnes <[email-masked]>
Date: Sun, 26 May 2013 15:38:02 -0400

This version just adds a use case provided by Jim.  I think this version is
ready for WGLC.
--Richard

On Sun, May 26, 2013 at 3:30 PM, <[email-masked]> wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>

---

From: Mike Jones <[email-masked]>
Date: Mon, 27 May 2013 05:35:50 +0000

Ummm...  this version omits all of the suggested changes that I sent to you and the working group on April 28th (even the spelling corrections).  These proposed changes were discussed at the interim working group meeting and there appeared to be agreement to incorporate at least some of them - especially the "Application and Protocol Requirements" section and the refactoring of the huge "Security Tokens and Authorization" section into more specific "Security Tokens", "OAuth", and "Federation" sections, plus citing Mozilla Persona, etc.

I've merged all my changes back into the attached version.  I'd appreciate it if you would promptly submit this as -02 after reviewing the changes, so that they aren't lost again.  After doing that, I agree that we'll be ready for WGLC.

The diffs are exactly the same as those posted on April 28th, other than updating some outdated references that were still out of date and/or incorrect in -01.

                                                            Thanks,
                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Barnes
Sent: Sunday, May 26, 2013 12:38 PM
To: [email-masked]
Subject: Re: [jose] I-D Action: draft-ietf-jose-use-cases-01.txt

This version just adds a use case provided by Jim.  I think this version is ready for WGLC.
--Richard

On Sun, May 26, 2013 at 3:30 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose