Subject: Re: [jose] Teleconference July 1 Agenda

From: Richard Barnes <[email-masked]>
Date: Mon, 1 Jul 2013 11:45:41 -0400

I agree that ISSUE-15 has been addressed in -11.

On a related note: As I recall, there was consensus at the interim to add
something in the "jku" section to the following effect:

NEW:
"""
If a "jku" URI refers to a JWK Set containing more than one key, then the
JWE MUST also contain a "kid" attribute identifying the key to be used for
this object.  In general, a JWE containing a "jku" URI SHOULD also contain
a "kid" for this purpose.
"""

I don't see anything like that in -11.

On Tue, Jun 25, 2013 at 8:31 PM, Mike Jones <[email-masked]>wrote:

>  Please add these issues to the agenda:  #5, #14, and #15.  Suggested
> agenda text follows.****
>
> ** **
>
> Issue #5 - Unclear instructions for key management****
>
>                 Discuss closing this issue as “fixed”, as text addressing
> it was added in the -09 drafts****
>
> ** **
>
> Issue #14 - Support longer wrapped keys than OAEP allows****
>
>                 Discuss closing this issue as “won’t fix”, as it will not
> occur in practice****
>
> ** **
>
> Issue #15 - At least one key indicator should be mandatory****
>
>                 Discuss closing this issue as “fixed”, as text addressing
> it was added in -11, as proposed by the WG in Denver****
>
> ** **
>
>                                                                 Thanks,***
> *
>
>                                                                 -- Mike***
> *
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Jim Schaad
> *Sent:* Tuesday, June 25, 2013 9:51 AM
> *To:* [email-masked]
> *Subject:* [jose] Teleconference July 1 Agenda****
>
> ** **
>
> Agenda has been posted
> http://www.ietf.org/proceedings/interim/2013/07/01/jose/agenda/agenda-interim-2013-jose-3
> ****
>
> ** **
>
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 12 Jul 2013 15:30:33 +0000

The content from these tables has been incorporated in JWA -12, in the tables in Sections 4.1 and 4.2.

                                                            -- Mike

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Richard Barnes
Sent: Sunday, June 30, 2013 3:41 PM
To: Jim Schaad
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [jose] Teleconference July 1 Agenda

For my open actions under ISSUE-6:

Create algorithm table reflecting meember requirement levels before 1 June:

alg/enc         Required fields
============================================
RSA1_5          encrypted_key
RSA-OAEP        encrypted_key
A128KW          encrypted_key
A256KW          encrypted_key
dir
ECDH-ES         epk, apu
ECDH-ES+A128KW  encrypted_key, epk, apu
ECDH-ES+A256KW  encrypted_key, epk, apu
--------------------------------------------
A128CBC-HS256   iv, tag
A256CBC-HS512   iv, tag
A128GCM         iv, tag
A256GCM         iv, tag

Add evaluation for protection to table of all fields:
-- There are no parameters where protection is REQUIRED for security purposes.
-- If one of the PSS algorithms is used ("PS256"/"PS512"), then the "alg" field MUST be protected, in order to protect the hash algorithm used.

On Tue, Jun 25, 2013 at 12:50 PM, Jim Schaad <[email-masked]<mailto:[email-masked]>> wrote:
Agenda has been posted http://www.ietf.org/proceedings/interim/2013/07/01/jose/agenda/agenda-interim-2013-jose-3

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose