Subject: [jose] x5c, x5u, x5t don't apply to all key types

From: Brian Campbell <[email-masked]>
Date: Wed, 17 Jul 2013 13:34:10 -0600

Section 3 of JWK [1] defines "members that are common to all key types" and
includes among those members x5c, x5u and x5t. However, the x5X parameters
are relevant only for half the key types defined in JWA - they don't really
make sense for "oct" [2] or "PBKDF2" [3].

Not sure the best way to address this but it seems kind of awkward as it
is. Maybe move them into the EC and RSA type definitions (or something
common to both) or somehow add some qualifying text saying that they can
only be used with key types utilizing public keys?

As I was looking up the URLs below I noticed that the section alignment in
section 5 of JWA is a little off. I think 5.3.3 and 5.3.4 should probably
be 5.4 and 5.5 respectively. Right now they line up as though they were
part of the RSA key type.

[1] http://tools.ietf.org/html/draft-ietf-jose-json-web-key-13#section-3
[2]
http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.3
[3]
http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.4

---

From: Mike Jones <[email-masked]>
Date: Wed, 17 Jul 2013 20:54:54 +0000

Thanks for noticing this.  How about "members that are common to all public key types"?

You're right about the section numbering.  I'll fix that.

                                                            Thanks again,
                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Wednesday, July 17, 2013 12:34 PM
To: [email-masked]
Subject: [jose] x5c, x5u, x5t don't apply to all key types

Section 3 of JWK [1] defines "members that are common to all key types" and includes among those members x5c, x5u and x5t. However, the x5X parameters are relevant only for half the key types defined in JWA - they don't really make sense for "oct" [2] or "PBKDF2" [3].
Not sure the best way to address this but it seems kind of awkward as it is. Maybe move them into the EC and RSA type definitions (or something common to both) or somehow add some qualifying text saying that they can only be used with key types utilizing public keys?
As I was looking up the URLs below I noticed that the section alignment in section 5 of JWA is a little off. I think 5.3.3 and 5.3.4 should probably be 5.4 and 5.5 respectively. Right now they line up as though they were part of the RSA key type.

[1] http://tools.ietf.org/html/draft-ietf-jose-json-web-key-13#section-3
[2] http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.3
[3] http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.4

---

From: Brian Campbell <[email-masked]>
Date: Wed, 17 Jul 2013 15:29:27 -0600

Works for me. As long as folks think "public key types" will be enough
understood. Seems like it would be.

On Wed, Jul 17, 2013 at 2:54 PM, Mike Jones <[email-masked]>wrote:

>  Thanks for noticing this.  How about “members that are common to all
> public key types”?****
>
> ** **
>
> You’re right about the section numbering.  I’ll fix that.****
>
> ** **
>
>                                                             Thanks again,*
> ***
>
>                                                             -- Mike****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Brian Campbell
> *Sent:* Wednesday, July 17, 2013 12:34 PM
> *To:* [email-masked]
> *Subject:* [jose] x5c, x5u, x5t don't apply to all key types****
>
> ** **
>
> Section 3 of JWK [1] defines "members that are common to all key types"
> and includes among those members x5c, x5u and x5t. However, the x5X
> parameters are relevant only for half the key types defined in JWA - they
> don't really make sense for "oct" [2] or "PBKDF2" [3]. ****
>
> only be used with key types utilizing public keys?****
>
> part of the RSA key type.****
>
> ** **
>
> ****