Subject: [jose] JOSE -13 drafts

From: Mike Jones <[email-masked]>
Date: Tue, 16 Jul 2013 01:30:00 +0000

The JOSE -13 drafts are now available, which incorporate issue resolutions agreed to on today's JOSE working group call.  The only breaking change was to the JWS JSON Serialization, by making all header parameters be per-signature (which is actually a simplification and makes it more parallel to the JWS Compact Serialization).  Algorithms were added to JWA for key encryption with AES GCM and for password-based encryption.  An optional "aad" (Additional Authenticated Data) member was added to the JWE JSON Serialization.

Thanks to Matt Miller for the password-based encryption write-up, which is based on draft-miller-jose-jwe-protected-jwk-02<http://tools.ietf.org/html/draft-miller-jose-jwe-protected-jwk-02>.

The drafts are available at:

*         http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-13

*         http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-13

*         http://tools.ietf.org/html/draft-ietf-jose-json-web-key-13

*         http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13

HTML formatted versions are also available at:

*         http://self-issued.info/docs/draft-ietf-jose-json-web-signature-13.html

*         http://self-issued.info/docs/draft-ietf-jose-json-web-encryption-13.html

*         http://self-issued.info/docs/draft-ietf-jose-json-web-key-13.html

*         http://self-issued.info/docs/draft-ietf-jose-json-web-algorithms-13.html

                                                                -- Mike

---

From: Vladimir Dzhuvinov / NimbusDS <[email-masked]>
Date: Tue, 16 Jul 2013 09:55:37 +0300

Yesterday I updated the Nimbus JOSE+JWT library to match the JOSE -12 /
JWT -10 drafts from last week. Since nothing that affects compact
serialisation has changed in -13, I'll leave it as it is.

I'm still unsure about how much demand there is for the JSON
serialisation, but if anyone is interested in contributing, just let me
know.

Thanks,

Vladimir

On Tue, 2013-07-16 at 01:30 +0000, Mike Jones wrote:
> The JOSE -13 drafts are now available, which incorporate issue
> resolutions agreed to on today’s JOSE working group call.  The only
> breaking change was to the JWS JSON Serialization, by making all
> header parameters be per-signature (which is actually a simplification
> and makes it more parallel to the JWS Compact Serialization).
> Algorithms were added to JWA for key encryption with AES GCM and for
> password-based encryption.  An optional “aad” (Additional
> Authenticated Data) member was added to the JWE JSON Serialization.
> 
>  
> 
> Thanks to Matt Miller for the password-based encryption write-up,
> which is based on draft-miller-jose-jwe-protected-jwk-02.
> 
>  
> 
> ·        http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-13
> 
> ·        http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-13
> 
> ·        http://tools.ietf.org/html/draft-ietf-jose-json-web-key-13
> 
> ·        http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13
> 
>  
> 
> ·        http://self-issued.info/docs/draft-ietf-jose-json-web-signature-13.html
> 
> ·        http://self-issued.info/docs/draft-ietf-jose-json-web-encryption-13.html
> 
> ·        http://self-issued.info/docs/draft-ietf-jose-json-web-key-13.html
> 
> ·        http://self-issued.info/docs/draft-ietf-jose-json-web-algorithms-13.html
> 
>  
> 
>                                                                 --
> Mike
> 
>  
> 
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose