Subject: Re: [jose] x5c, x5u, x5t don't apply to all key types

From: Mike Jones <[email-masked]>
Date: Tue, 30 Jul 2013 09:08:09 +0000

Draft -14 now says "members that are common to multiple key types".  And the incorrectly numbered sections are actually gone.

                                                            -- Mike

From: Mike Jones
Sent: Wednesday, July 17, 2013 1:55 PM
To: 'Brian Campbell'; [email-masked]<mailto:[email-masked]>
Subject: RE: [jose] x5c, x5u, x5t don't apply to all key types

Thanks for noticing this.  How about "members that are common to all public key types"?

You're right about the section numbering.  I'll fix that.

                                                            Thanks again,
                                                            -- Mike

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Wednesday, July 17, 2013 12:34 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] x5c, x5u, x5t don't apply to all key types

Section 3 of JWK [1] defines "members that are common to all key types" and includes among those members x5c, x5u and x5t. However, the x5X parameters are relevant only for half the key types defined in JWA - they don't really make sense for "oct" [2] or "PBKDF2" [3].
Not sure the best way to address this but it seems kind of awkward as it is. Maybe move them into the EC and RSA type definitions (or something common to both) or somehow add some qualifying text saying that they can only be used with key types utilizing public keys?
As I was looking up the URLs below I noticed that the section alignment in section 5 of JWA is a little off. I think 5.3.3 and 5.3.4 should probably be 5.4 and 5.5 respectively. Right now they line up as though they were part of the RSA key type.

[1] http://tools.ietf.org/html/draft-ietf-jose-json-web-key-13#section-3
[2] http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.3
[3] http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.4

---

From: Brian Campbell <[email-masked]>
Date: Tue, 30 Jul 2013 12:15:50 +0200

On Tue, Jul 30, 2013 at 11:08 AM, Mike Jones <[email-masked]>wrote:

>  Draft -14 now says “members that are common to multiple key types”.
>

WFM. Thanks.

> And the incorrectly numbered sections are actually gone.
>

Actually, 3.3.3 still looks problematic, "JWK Parameters for Symmetric
Keys" lines up as though it's part of RSA.

   5 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5>.
 Cryptographic Algorithms for JWK . . . . . . . . . . . . . . . 33
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>
     5.1 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.1>.
 "kty" (Key Type) Parameter Values for JWK  . . . . . . . . 33
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>
     5.2 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2>.
 JWK Parameters for Elliptic Curve Keys . . . . . . . . . . 33
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>
       5.2.1 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.1>.
 JWK Parameters for Elliptic Curve Public Keys  . . . . 33
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>
        [...]
       5.2.2 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.2>.
 JWK Parameters for Elliptic Curve Private Keys . . . . 34
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-34>
         5.2.2.1
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.2.1>.
 "d" (ECC Private Key) Parameter  . . . . . . . . . 34
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-34>
     5.3 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3>.
 JWK Parameters for RSA Keys  . . . . . . . . . . . . . . . 35
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>
       5.3.1 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.1>.
 JWK Parameters for RSA Public Keys . . . . . . . . . . 35
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>
        [...]
       5.3.2 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.2>.
 JWK Parameters for RSA Private Keys  . . . . . . . . . 35
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>
        [...]
       5.3.3 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.3>.
 JWK Parameters for Symmetric Keys  . . . . . . . . . . 37
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-37>
         5.3.3.1
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.3.1>.
 "k" (Key Value) Parameter  . . . . . . . . . . . . 37
<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-37>

  *From:* Mike Jones
> *Sent:* Wednesday, July 17, 2013 1:55 PM
> *To:* 'Brian Campbell'; [email-masked]
> *Subject:* RE: [jose] x5c, x5u, x5t don't apply to all key types****
>
> ** **
>
> Thanks for noticing this.  How about “members that are common to all
> public key types”?****
>
> ** **
>
> You’re right about the section numbering.  I’ll fix that.****
>
> ** **
>
>                                                             Thanks again,*
> ***
>
>                                                             -- Mike****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Brian Campbell
> *Sent:* Wednesday, July 17, 2013 12:34 PM
> *To:* [email-masked]
> *Subject:* [jose] x5c, x5u, x5t don't apply to all key types****
>
> ** **
>
> Section 3 of JWK [1] defines "members that are common to all key types"
> and includes among those members x5c, x5u and x5t. However, the x5X
> parameters are relevant only for half the key types defined in JWA - they
> don't really make sense for "oct" [2] or "PBKDF2" [3]. ****
>
> Not sure the best way to address this but it seems kind of awkward as it
> is. Maybe move them into the EC and RSA type definitions (or something
> common to both) or somehow add some qualifying text saying that they can
> only be used with key types utilizing public keys?****
>
> As I was looking up the URLs below I noticed that the section alignment in
> section 5 of JWA is a little off. I think 5.3.3 and 5.3.4 should probably
> be 5.4 and 5.5 respectively. Right now they line up as though they were
> part of the RSA key type.****
>
> ** **
>
> [2]
> http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.3
> [3]
> http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-13#section-5.3.4
> ****
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 30 Jul 2013 11:05:53 +0000

You're right - 5.3.3 should be 5.4.  This is now fixed in my editor's draft.  Thanks again for your diligence.

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Tuesday, July 30, 2013 3:16 AM
To: Mike Jones
Cc: [email-masked]
Subject: Re: [jose] x5c, x5u, x5t don't apply to all key types

On Tue, Jul 30, 2013 at 11:08 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
Draft -14 now says "members that are common to multiple key types".

WFM. Thanks.

Actually, 3.3.3 still looks problematic, "JWK Parameters for Symmetric Keys" lines up as though it's part of RSA.

   5<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5>.  Cryptographic Algorithms for JWK . . . . . . . . . . . . . . . 33<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>

     5.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.1>.  "kty" (Key Type) Parameter Values for JWK  . . . . . . . . 33<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>

     5.2<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2>.  JWK Parameters for Elliptic Curve Keys . . . . . . . . . . 33<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>

       5.2.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.1>.  JWK Parameters for Elliptic Curve Public Keys  . . . . 33<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-33>

        [...]

       5.2.2<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.2>.  JWK Parameters for Elliptic Curve Private Keys . . . . 34<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-34>

         5.2.2.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.2.2.1>.  "d" (ECC Private Key) Parameter  . . . . . . . . . 34<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-34>

     5.3<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3>.  JWK Parameters for RSA Keys  . . . . . . . . . . . . . . . 35<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>

       5.3.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.1>.  JWK Parameters for RSA Public Keys . . . . . . . . . . 35<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>

        [...]

       5.3.2<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.2>.  JWK Parameters for RSA Private Keys  . . . . . . . . . 35<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-35>

        [...]

       5.3.3<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.3>.  JWK Parameters for Symmetric Keys  . . . . . . . . . . 37<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-37>

         5.3.3.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#section-5.3.3.1>.  "k" (Key Value) Parameter  . . . . . . . . . . . . 37<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-14#page-37>

From: Mike Jones

                                                            Thanks again,
                                                            -- Mike