Subject: [jose] Registration change for IANA?

From: "Jim Schaad" <[email-masked]>
Date: Sat, 24 Jan 2015 20:01:59 -0800

I was looking at the registries that have been created by IANA for the JOSE
documents.  I want to ask for a change in the template from IANA on the
registry but need to run it past the working group before doing so.

In the post IESG documents, a new field was added to the registration
template for algorithms to provide pointers to documents that do analysis on
the security properties of the algorithm that the registration request is
for.  This field was added mainly for the benefit of the IANA designated
experts and is not really needed long term for people who look up the
algorithm in the table.  As such I think we can ask IANA to remove the
column from the registration table as the data contained will be good only
at the time of registration and will not be updated to reflect more recent
research on the algorithm.

Comments?

Jim

---

From: Kathleen Moriarty <[email-masked]>
Date: Sun, 25 Jan 2015 08:57:14 -0500

Hi Jim,

Sent from my iPhone

> On Jan 24, 2015, at 11:01 PM, "Jim Schaad" <[email-masked]> wrote:
> 
> I was looking at the registries that have been created by IANA for the JOSE documents.  I want to ask for a change in the template from IANA on the registry but need to run it past the working group before doing so.
>  
> In the post IESG documents, a new field was added to the registration template for algorithms to provide pointers to documents that do analysis on the security properties of the algorithm that the registration request is for.  This field was added mainly for the benefit of the IANA designated experts and is not really needed long term for people who look up the algorithm in the table.  As such I think we can ask IANA to remove the column from the registration table as the data contained will be good only at the time of registration and will not be updated to reflect more recent research on the algorithm.

I think that would be fine.  Since this is specification required, there would be a way to see that information later if needed.  Removing it from the registry would still meet the request from the IESG reviews IMO.

Thanks,
Kathleen
>  
> Comments?
>  
>  
> Jim
>  
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Mike Jones <[email-masked]>
Date: Sun, 25 Jan 2015 23:10:36 +0000

I’m OK with this suggestion.  I assume that we’d also want to add a sentence in the registration instructions for the field “Algorithm Analysis Documents(s):” saying something like this: “This field is provided for use by the designated experts but not included in the resulting registration”, which we’d add via an editor’s note at this point.  I would make it the next-to-last sentence in the last paragraph of 7.1.1<http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-40#section-7.1.1>.  Does that wording sound right to you, Jim and Kathleen?

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Sunday, January 25, 2015 5:57 AM
To: Jim Schaad
Cc: <[email-masked]>
Subject: Re: [jose] Registration change for IANA?

Hi Jim,

Sent from my iPhone

On Jan 24, 2015, at 11:01 PM, "Jim Schaad" <[email-masked]<mailto:[email-masked]>> wrote:
I was looking at the registries that have been created by IANA for the JOSE documents.  I want to ask for a change in the template from IANA on the registry but need to run it past the working group before doing so.

Thanks,
Kathleen

Comments?

Jim

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 25 Jan 2015 15:31:32 -0800

I don’t believe that there is any need for a textual change for this.  Just a request to IANA.  Consider that all of the fields that are not in the media types table.

Jim

From: Mike Jones [mailto:[email-masked]] 
Sent: Sunday, January 25, 2015 3:11 PM
To: Kathleen Moriarty; Jim Schaad
Cc: <[email-masked]>
Subject: RE: [jose] Registration change for IANA?

I’m OK with this suggestion.  I assume that we’d also want to add a sentence in the registration instructions for the field “Algorithm Analysis Documents(s):” saying something like this: “This field is provided for use by the designated experts but not included in the resulting registration”, which we’d add via an editor’s note at this point.  I would make it the next-to-last sentence in the last paragraph of 7.1.1 <http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-40#section-7.1.1> .  Does that wording sound right to you, Jim and Kathleen?

                                                            -- Mike

Hi Jim,

Sent from my iPhone

Thanks,

Kathleen

Comments?

Jim

---

From: Mike Jones <[email-masked]>
Date: Sun, 25 Jan 2015 23:45:51 +0000

Other than it being one more thing for us to do as an RFC Editor’s note, is there a reason not to include the sentence?  I’m concerned that if we don’t, people preparing registrations may become confused, using existing registrations as their guide for preparing new ones, and because the field won’t be present there, some will leave it out of their registration requests by mistake, thinking it’s not needed.  I think it will be more transparent and less confusing for all if we say explicitly that the field isn’t included in the registry.

                                                            -- Mike

From: Jim Schaad [mailto:[email-masked]]
Sent: Sunday, January 25, 2015 3:32 PM
To: Mike Jones; 'Kathleen Moriarty'
Cc: [email-masked]
Subject: RE: [jose] Registration change for IANA?

Jim

Cc: <[email-masked]<mailto:[email-masked]>>

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Sunday, January 25, 2015 5:57 AM
To: Jim Schaad
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [jose] Registration change for IANA?

Hi Jim,

Sent from my iPhone

Thanks,
Kathleen

Comments?

Jim