Subject: [jose] FYI: [Json] Signed JSON document / Json Content Metaheader / JSON Container

From: Nat Sakimura <[email-masked]>
Date: Thu, 29 Jan 2015 09:03:09 +0900

The discussion started this morning (for me) in the JSON Wg list.

See the thread started on
http://www.ietf.org/mail-archive/web/json/current/msg03606.html

Best,

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: Nat Sakimura <[email-masked]>
Date: Thu, 29 Jan 2015 11:51:54 +0900

We should probably track the conversation on the JSON list to try to avoid unnecessary duplication of effort. 

IMHO, if it is going to happen in JSON WG, then it should use the algorithms and probably header parameters specified by JWA, etc. It should limit the scope to payload processing and leave the rest to JOSE. 

Perhaps we could also consider rechartering JOSE WG to specifying signing of unencoded JSON payloads. 

Cheers, 

Nat

On Thu, 29 Jan 2015 09:03:09 +0900

-- 
Nat Sakimura ([email-masked])
Nomura Research Institute, Ltd. 

PLEASE READ:
The information contained in this e-mail is confidential and intended
for the named recipient(s) only. If you are not an intended recipient
of this e-mail, you are hereby notified that any review, dissemination,
distribution or duplication of this message is strictly prohibited. If
you have received this message in error, please notify the sender
immediately and delete your copy from your system.