Subject: Re: [jose] JOSE Hash-algorithm Identifiers?

From: Anders Rundgren <[email-masked]>
Date: Fri, 4 Mar 2016 16:27:49 +0100

No takers on this one?

On 2015-12-09 08:12, Anders Rundgren wrote:
> The following extract from a recent ACME posting indicates that I'm not the only one who see use-cases for such:
>
> It's not a bad idea to specify the agreement-integrity as a dictionary
> instead so in that future case, there's not problem of checksum
> negotiation:
> "agreement-integrity": {"sha512":
> "3Ys8QL9di54ggXIGBAS2RHr_W6cMurZPizhZihkQjwl3VG2dpXZYmsYZ0B7LG-tWlVE9-
> Hwp9hL3Mosvbr6lCA"}
>
> In my work I used the names S128, S256, and S512.
>
> Anders
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 4 Mar 2016 17:36:43 +0000

The PKCE RFC [RFC 7636] also uses "S256".

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Anders Rundgren
Sent: Friday, March 4, 2016 7:28 AM
To: [email-masked]
Subject: Re: [jose] JOSE Hash-algorithm Identifiers?

No takers on this one?

> In my work I used the names S128, S256, and S512.

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 4 Mar 2016 19:46:09 +0100

> The PKCE RFC [RFC 7636] also uses "S256".

Since this points to a rather specific application, I'm not sure if this speaks for or against using S256 for indicating SHA256...

Anders

---

From: Mike Jones <[email-masked]>
Date: Fri, 4 Mar 2016 19:14:06 +0000

For
________________________________
From: Anders Rundgren<mailto:[email-masked]>
Sent: ‎3/‎4/‎2016 10:46 AM
To: Mike Jones<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [jose] JOSE Hash-algorithm Identifiers?

Anders