Subject: [jose] I-D Action: draft-ietf-jose-cfrg-curves-04.txt

From: [email-masked]
Date: Thu, 07 Jul 2016 00:37:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Javascript Object Signing and Encryption of the IETF.

        Title           : CFRG ECDH and signatures in JOSE 
        Author          : Ilari Liusvaara
	Filename        : draft-ietf-jose-cfrg-curves-04.txt
	Pages           : 13
	Date            : 2016-07-07

Abstract:
   This document defines how to use the Diffie-Hellman algorithms
   "X25519" and "X448" as well as the signature algorithms "Ed25519" and
   "Ed448" from the IRTF CFRG elliptic curves work in JOSE.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-jose-cfrg-curves/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-jose-cfrg-curves-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-jose-cfrg-curves-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ilari Liusvaara <[email-masked]>
Date: Thu, 7 Jul 2016 10:45:02 +0300

> 	Filename        : draft-ietf-jose-cfrg-curves-04.txt

Some work on the references (as requested by comments on the draft).

-Ilari

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Thu, 7 Jul 2016 15:04:07 +0000

Thanks Ilari!

The changes look good to me and address all of my concerns.

--
- m&m

Matt Miller
Cisco Systems, Inc.

> On Jul 7, 2016, at 01:45, Ilari Liusvaara <[email-masked]> wrote:
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Mike Jones <[email-masked]>
Date: Fri, 8 Jul 2016 19:02:08 +0000

Hi Ilari,

I read all the diffs in -03 and -04 and things look good.  I've enclosed a slightly edited source that addresses a few strictly grammatical things that could be published as -05, should you decide to do so.

Thanks again for producing this specification!

				-- Mike

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Matt Miller (mamille2)
Sent: Thursday, July 7, 2016 8:04 AM
To: Ilari Liusvaara <[email-masked]>
Cc: [email-masked]
Subject: Re: [jose] I-D Action: draft-ietf-jose-cfrg-curves-04.txt

Thanks Ilari!

--
- m&m

Matt Miller
Cisco Systems, Inc.