Subject: Re: [Justfont] New draft, includes text for the three remaining issues.

From: Wendy Seltzer <[email-masked]>
Date: Fri, 1 Apr 2016 10:37:42 -0400

Hi Chris and WG,

We won't be meeting in B-A, but that shouldn't keep us from making
progress! Do we have group consensus on the issue resolutions Chris
proposes in the -01 draft?

Does anyone have further comments or issues with the -01 draft?

Thanks,
--Wendy

On 03/02/2016 12:19 PM, Chris Lilley wrote:
> Hello,
> 
> A new -01 draft was published,
> https://datatracker.ietf.org/doc/draft-ietf-justfont-toplevel/
> (link has text, pdf and html version)
> 
> with text incorporating discussions on the three remaining issues:
> 
> * Multiple outlines #2
> https://github.com/svgeesus/ietf-justfont/issues/2
> 
> The new draft includes the suggested wording from Vlad Levantovsky, a
> bit more open-ended than what I had suggested, to allow for future
> spec changes. It defers to the OFF spec on allowed combinations rather
> than listing those which are currently possible.
> 
> Either way, it clarifies that there is no magic number of fonts
> containing SVG outlines.
> 
> *  Media type for OpenType collections #6
> https://github.com/svgeesus/ietf-justfont/issues/6
> 
> The new draft defines the font/collection type. On advice from Ken
> Lunde and Rod Sheeter, just the one type is used for both TrueType
> Collections and (Opentype) Collections, and the suggested filename
> extension is .ttf for both, to conform to common practice.
> 
> *  Fragment syntax for collections #7
> https://github.com/svgeesus/ietf-justfont/issues/7
> 
> This uses the same fragment syntax as is used (in an illustrative
> example) in the CSS3 Fonts spec. It is used on font/collection and
> also on font/woff2 because unlike woff1, woff2 can encode collections.
> 
> The spec language also adresses the interpretation when the fragment
> is omitted (it is the first font in the collection), and for woff2,
> also what happens if a fragment is provided but the woff does not
> encode a collection (fragment ignored, no effect).
> 
> Does the new draft correctly capture the group consensus? If so, I can
> close off these issues.
> 
> 
> 

-- 
Wendy Seltzer -- [email-masked] +1.617.715.4883 (office)
Policy Counsel and Domain Lead, World Wide Web Consortium (W3C)
https://wendy.seltzer.org/        +1.617.863.0613 (mobile)

---

From: "Levantovsky, Vladimir" <[email-masked]>
Date: Fri, 1 Apr 2016 15:34:29 +0000

Hi Wendy, all,

Many thanks to Chris for updating the draft, I review the text and I agree that all of the issues that were raised in previous comments are now resolved.

I do have one new editorial comment though - the current text of the draft is using the last published WOFF 2.0 Working Draft as a reference; however, since then the WOFF 2.0 spec has been published as W3C Candidate Recommendation (on March 15) and we should probably update the references to reflect that.

Other than this editorial correction - there are no more changes that I can think of, the draft is good!

Thank you,
Vlad

-----Original Message-----
From: Justfont [mailto:[email-masked]] On Behalf Of Wendy Seltzer
Sent: Friday, April 01, 2016 10:38 AM
To: Chris Lilley; [email-masked]
Subject: Re: [Justfont] New draft, includes text for the three remaining issues.

Hi Chris and WG,

We won't be meeting in B-A, but that shouldn't keep us from making progress! Do we have group consensus on the issue resolutions Chris proposes in the -01 draft?

Thanks,
--Wendy

--
Wendy Seltzer -- [email-masked] +1.617.715.4883 (office) Policy Counsel and Domain Lead, World Wide Web Consortium (W3C)
https://wendy.seltzer.org/        +1.617.863.0613 (mobile)

_______________________________________________
Justfont mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/justfont

---

From: Chris Lilley <[email-masked]>
Date: Sat, 2 Apr 2016 02:31:54 +0200

> Many thanks to Chris for updating the draft, I review the text and I agree that all of the issues that were raised in previous comments are now resolved.

Great, thanks.
> I do have one new editorial comment though - the current text of the draft is using the last published WOFF 2.0 Working Draft as a reference; however, since then the WOFF 2.0 spec has been publishe…

Right, this is because 10 Feb 2016 < 15 March 2016 :)

Updated in current editor's draft
https://github.com/svgeesus/ietf-justfont/commit/253863119af4b5e0652a91030cb029299cf42cbf

> Other than this editorial correction - there are no more changes that I can think of, the draft is good!
Good to hear, thanks for reviewing it!

-- 
Chris Lilley
@svgeesus
Technical Director, W3C Interaction Domain

---

From: Sean Leonard <[email-masked]>
Date: Mon, 4 Apr 2016 15:28:58 -0300

> On Apr 1, 2016, at 9:31 PM, Chris Lilley <[email-masked]> wrote:
> 

I read the draft. It looks okay. Continue onward.

Sean