Subject: Re: [karp] Please take a look at draft-hartman-karp-ospf-analysis

From: "Michael Barnes" <[email-masked]>
Date: Fri, 18 Jun 2010 08:01:58 -0700

Hi Mark,

> I understand that we are using manual keying here, and the sequence
> number isnt mandatory, however, the same is the case with OSPFv2. If
> we can use the sequence numbers with OSPFv2, which has been manually
> keyed just like v3, then why cant we do it for OSPFv3?

OSPFv2 doesn't use IPsec, its packets have their own fields for security
including one for sequence numbers. OSPFv3 packets don't have any such fields
and it relies on IPsec encapsulation. That's why OSPFv2 doesn't have the same
limitation as OSPFv3 regarding replay protection.

Regards,
Michael

> Mark

---

From: Minto Jeyananth <[email-masked]>
Date: Mon, 21 Jun 2010 23:38:07 -0700

Mark, 

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of
|Michael Barnes
|Subject: Re: [karp] Please take a look at draft-hartman-karp-ospf-analysis
|
|Hi Mark,
|
|> I understand that we are using manual keying here, and the sequence
|> number isnt mandatory, however, the same is the case with OSPFv2. If
|> we can use the sequence numbers with OSPFv2, which has been manually
|> keyed just like v3, then why cant we do it for OSPFv3?
|
|OSPFv2 doesn't use IPsec, its packets have their own fields for security
|including one for sequence numbers. OSPFv3 packets don't have any such
|fields
|and it relies on IPsec encapsulation. That's why OSPFv2 doesn't have the
|same
|limitation as OSPFv3 regarding replay protection.

Some implementation support IPsec for OSPFv2. 
 
-minto  

|
|> Mark
|
|_______________________________________________
|karp mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/karp