Subject: Re: [karp] OSPFv3 Auth - Packet Prioritization

From: "Michael Barnes" <[email-masked]>
Date: Wed, 23 Jun 2010 19:21:59 -0700

------ Original Message ------
Received: Wed, 23 Jun 2010 05:55:02 PM PDT
From: Vishwas Manral <[email-masked]>
To: "Bhatia, Manav (Manav)" <[email-masked]>Cc:
"[email-masked]" <[email-masked]>
Subject: Re: [karp] OSPFv3 Auth - Packet Prioritization

> Low priority and high priority can have different DSCP value. :)) Just
> think over it.

I agree, and this is what our implementation is doing. (Although we currently
only prioritize Hellos and not Acks.)

Regards,
Michael

> Thanks,
> Vishwas

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 24 Jun 2010 08:23:21 +0530

Wow. So you give different DSCP values to Hellos and other packets? This is odd, because you have no control over what this would do to your other packets that are reaching the other node with a lower DSCP value? I think the idea is to always give the highest priority to the control packets so that they never compete with the data traffic, but then I guess this is also an implementation specific issue.

The way I understood it was that we always give the highest priority to control packets, and then somehow prioritize certain packets over the other within that forwarding class (FC). This to me meant that all OSPF packets regardless of what they are would always go out with the highest DSCP value so that there is no contention of resources with other data traffic. Then within OSPF, prioritize the Hellos and the Acks.

Cheers, Manav

> -----Original Message-----
> From: Michael Barnes [mailto:[email-masked]] 
> Sent: Thursday, June 24, 2010 7.52 AM
> To: Vishwas Manral; Bhatia, Manav (Manav)
> Cc: [email-masked]