Subject: [karp] FW: Russ Housley's Discuss on draft-ietf-karp-design-guide-05: (with DISCUSS and COMMENT)

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 11 Nov 2011 21:39:37 +0530

Fwding to the KARP mailing list ..

-----Original Message-----
From: Bhatia, Manav (Manav) 
Sent: Friday, November 11, 2011 6:19 PM
To: 'Joel M. Halpern'; 'Brian Weis'; 'Gregory Lebovitz'
Subject: RE: [karp] Russ Housley's Discuss on draft-ietf-karp-design-guide-05: (with DISCUSS and COMMENT)

Hi Joel,

I disagree that its very clear and reasonable.

Russ seems to be making a sweeping assumption that design guide ought to mention that a solution with manual keying needs to revolve around the crypto key table. I am not too sure of that. I agree that it's a WG doc, but we have not had any discussions on whether this is the FINAL approach that we are taking. I think its too premature to commit to this and the design guide should remain oblivious to a solution that has not even been debated in the WG.

If we really want to do as Russ suggests then we need to probably wait for some more time till we have good clarity on where we're going with the crypto key table document.

Cheers, Manav 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Joel M. Halpern
> Sent: Friday, November 11, 2011 6:11 PM
> To: [email-masked]
> Subject: Re: [karp] Russ Housley's Discuss on
> draft-ietf-karp-design-guide-05: (with DISCUSS and COMMENT)
> 
> This seems reasoanble, clear, and something that we can act on.
> Authors, can you do what is requested?
> 
> Yours,
> Joel
> 
> On 11/11/2011 3:46 AM, Russ Housley wrote:
> > Glen:
> >
> >>> So, this is the part where we disagree.  I do not think
> the current
> >>> document does a very good job at documenting common
> design elements.  
> >>> By doing so now, the I think the WG
> >>
> >> Mind elaborating what you mean by not documenting common
> design elements?
> >
> > Since we know that manual key management must be supported,
> the WG has decided to specify a crypto key table.  Manual key 
> management is populating the table, but this needs to be accomplished 
> using an interface that protects the keying material from disclosure 
> or alteration.
> >
> > In addition, we want to specify automated key management.  
> A protocol to automatically populate the crypto key table will be 
> used.  Several cases need to be considered:
> >
> > 1) pairwise keys -- IKEv2 and TLS already offer mechanisms
> that are directly applicable.
> >
> > 2) group keys --
> >
> > 2a) group keys distributed by a key center -- KeyProv
> offers mechanisms that are directly applicable, but additional 
> attributes may be needed.
> >
> > 2b) group keying protocols -- new protocol work is needed
> for this approach to be employed.
> >
> > A design guide ought to say what work needs to be done and
> when each of these cases ought to be employed.
> >
> > Russ
> > _______________________________________________
> > karp mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/karp
> >
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp
>

---

From: Acee Lindem <[email-masked]>
Date: Fri, 11 Nov 2011 20:05:31 -0800

I agree with Manav. 

Thanks,
Acee

---

From: Venkatesh Sriram <[email-masked]>
Date: Sun, 13 Nov 2011 05:48:07 +0530

+1

Sriram

---

From: Sean Turner <[email-masked]>
Date: Sun, 13 Nov 2011 13:07:54 +0800

-1

spt

On 11/13/11 8:18 AM, Venkatesh Sriram wrote:
> +1
>
> Sriram
>
> On Sat, Nov 12, 2011 at 9:35 AM, Acee Lindem<[email-masked]>  wrote:
>> I agree with Manav.
>>
>> Thanks,
>> Acee
>>
>>
>> On Nov 11, 2011, at 8:09 AM, "Bhatia, Manav (Manav)"<[email-masked]>  wrote:
>>