Subject: Re: [karp] Proposed text for design guide

From: RJ Atkinson <[email-masked]>
Date: Thu, 17 Nov 2011 10:15:01 -0500

Earlier, Joel Halpern wrote:
> However, since the proposed reference to keytables in the 
> design-guidelines is to the concept, not a normative reference
> to the specific document, I am not sure I understand why those
> detail issues are an objection to the conceptual reference
> in the design guidelines document.
>  
> Can you clarify?

Manav responded here:
	<http://www.ietf.org/mail-archive/web/karp/current/msg00821.html>
but with a narrow engineering issue about the bit length
of a particular field, rather than with any objection to the concept 
-- and Joel was clearly and precisely asking about the concept alone.

Then Acee responded here:
	<http://www.ietf.org/mail-archive/web/karp/current/msg00823.html>
but asked whether there would be a normative reference
to the Key Tables I-D -- which Joel *already* answered
above with "not a normative reference to the specific document".

So I don't see either of those notes to the KARP list 
as actually responsive to Joel's precise question.

The practical reality is that any implementation of routing
protocol authentication using cryptography has to have some 
internal form of a key table.  The engineering details of
how a particular implementation might code that capability
are both beyond the contents of the current Key Table I-D
and also well beyond the scope of the Design Guide -- as
it should be.

However, having an internal key table of some sort is simply
*unavoidable* for any implementation supporting cryptographic 
routing authentication.  Its existence is mandated by numerous 
RFCs, for example RFC-2328 Section D.3 (which I wrote long ago).

For the record, I do support a reference to the concept
of a key table and I agree with Joel that a normative
reference to the specific Key Tables I-D is not needed 
for the Design Guide.

Yours,

Ran

---

From: Acee Lindem <[email-masked]>
Date: Thu, 17 Nov 2011 17:27:41 -0500

Hi Ran,

> reference to the specific Key Tables I-D is not needed 

I'd agree with that as well. 

Thanks,
Acee 

> 
> Yours,
> 
> Ran
> 
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 18 Nov 2011 10:45:39 +0530

> but with a narrow engineering issue about the bit length of a 
> particular field, rather than with any objection to the concept

Aha. I wasn't responding to Joel's question. I was merely trying to point out that there is work left to be done in the crypto-key-table document. I sent my note because Sean has a DISCUSS saying that certain fields used in draft-ietf-ospf-auth-trailer-ospfv3 must align with the crypto-key-table document.

I concede that my point would have been clearer if I had chosen to respond to the right thread.

Cheers, Manav