Subject: [KEYPROV] [issue21] Consider to add object diagram in DSKPP for relationships among IDs

From: Mingliang Pei <[email-masked]>
Date: Wed, 20 Jun 2007 14:28:17 +0000

New submission from Mingliang Pei <[email-masked]>:

Following up for issue 3 to clarify relationship of various IDs, Shuh suggested 
using an object diagram in the doc. Here is Shuh's initial drawing:

OATH Basic Object Model
=======================

                   (Token/TokenID or Device/DeviceID)
-----------        ------------
|User     |        |Token     |
|---------|  owns  |----------|
|  UserID |------->|  TokenID |
|  ...    |        |...       |
-----------        ------------
                         |
                         | contains
                         V
                   ------------
                   |Key       |
                   |----------|
                   |  KeyID   |
                   |  KeyType |
                   |...       |
                   ------------

Note: Choose the term either Token or Device, and then stick to it throughout 
the OATH documentation.

----------
assignedto: andrea
messages: 36
nosy: andrea, keyprov, mpei
priority: feature
status: chatting
superseder: Consistent definition about IDs between Keyprov and PSKC: TokenID, DeviceID, and KeyID
title: Consider to add object diagram in DSKPP for relationships among IDs

_________________________________________________________
KEYPROV Roundup Issue Tracker <[email-masked]>
<http://www.tschofenig.priv.at:8080/keyprov/issue21>
_________________________________________________________

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "CHANG Shuh" <[email-masked]>
Date: Wed, 27 Jun 2007 19:29:53 +0200

Based on today's KeyProv discussions, we'd:

1. Use Device/DeviceID instead of Token/TokenID.
2. Use the term Key rather than Secret.

Also there should be one consistent diagram for KeyProv (including PSKC,
DSKPP, CT-KIP). We'll provide one such diagram once all the common data
types currently exist in the various merging specs are consolidated.

Regards,
Shuh

> -----Original Message-----
> From: Mingliang Pei [mailto:[email-masked]] 
> Sent: Wednesday, June 20, 2007 9:28 AM
> To: [email-masked]; [email-masked]
> Subject: [KEYPROV] [issue21] Consider to add object diagram 
> in DSKPP forrelationships among IDs
> 
> 
> Following up for issue 3 to clarify relationship of various 
> IDs, Shuh suggested using an object diagram in the doc. Here 
> is Shuh's initial drawing:
> 
> OATH Basic Object Model
> =======================
> 
> 
> Note: Choose the term either Token or Device, and then stick 
> to it throughout the OATH documentation.
> 
> ----------
> assignedto: andrea
> messages: 36