Subject: [KEYPROV] [issue4] Should TokenID and KeyID be string instead of binary?

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 14 Jun 2007 15:13:22 +0000

Hannes Tschofenig <[email-masked]> added the comment:

I suggest to look at 
http://www.w3.org/TR/xmlschema-2/#base64Binary
http://www.w3.org/TR/xmlschema-2/#string
in order to figure out whether there is a problem with the data we want to 
encode.

----------
nosy: +keyprov

_________________________________________________________
KEYPROV Roundup Issue Tracker <[email-masked]>
<http://www.tschofenig.priv.at:8080/keyprov/issue4>
_________________________________________________________

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "CHANG Shuh" <[email-masked]>
Date: Thu, 14 Jun 2007 17:51:33 +0200

I tend to agree with Ming's view on using "string" rather than
"base64binary" for the TokenID or KeyID.

One practical reason to support the idea of using "string" is when
searching TokenID or KeyID in a data store, especially an LDAP server, a
"string" is a lot flexible than "base64binary." For base64binary,
different implementation of LDAP servers provides slightly different
searching mechanism for that type, which could cause problem to
consistently search for TokenID or KeyID.

Regards,
Shuh

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Thursday, June 14, 2007 10:13 AM
> To: [email-masked]; [email-masked]
> Subject: [KEYPROV] [issue4] Should TokenID and KeyID be 
> string instead ofbinary?
> 
> 
> in order to figure out whether there is a problem with the 
> data we want to encode.
> 
> ----------
> nosy: +keyprov
>

---

From: "Pei, Mingliang" <[email-masked]>
Date: Wed, 27 Jun 2007 11:00:02 -0700

Hannes,

When people respond to an issue from issuer tracker sent email, the
responses are not visible from issue tracker. It would be nice to be
able to see all the comments from the issue tracker when we do review.
Is this a possible feature by the issuer tracker site? Thanks,

- Ming 

> Sent: Thursday, June 14, 2007 8:13 AM
> To: [email-masked]; Pei, Mingliang
> Subject: [issue4] Should TokenID and KeyID be string instead 
> of binary?
> 
>