Subject: [KEYPROV] [issue10] Do we need to provide SOAP binding and where if so?

From: Andrea Doherty <[email-masked]>
Date: Tue, 07 Aug 2007 17:14:39 +0000

Andrea Doherty <[email-masked]> added the comment:

Based on discussions in Chicago and Prague, a SOAP binding is desirable. 
Whether a separate document will be resubmitted for the SOAP binding or whether 
the DSKPP should expressed using WSDL 2.0 (which allows for SOAP and HTTP 
bindings) is TBD after the co-chairs consult with the Applications Area 
Director.

----------
nosy: +keyprov

_________________________________________________________
KEYPROV Roundup Issue Tracker <[email-masked]>
<http://www.tschofenig.priv.at:8080/keyprov/issue10>
_________________________________________________________

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 7 Aug 2007 11:59:39 -0700

One reason for doing this is what occurred in the PKIX working group with SCVP.

SCVP was originally defined as being layered on HTTP. But the spec was incomplete with respect to the binding. The applications area director noticed this at last call. Since the group was otherwise meant to close they have now gone to a protocol over raw TCP just for the sake of getting it out the door.

Layering via WSDL means that we have the benefit of the W3C binding work, and one hopes that they understand HTTP.

A developer can ignore the WSDL if they choose, they are not obligated to make use of it. But if they are using a WSDL based toolkit to construct the SOAP binding they can throw out the HTTP binding without any more effort. 

> -----Original Message-----
> From: Andrea Doherty [mailto:[email-masked]] 
> Sent: Tuesday, August 07, 2007 1:15 PM
> To: [email-masked]; Pei, Mingliang
> Subject: [KEYPROV] [issue10] Do we need to provide SOAP 
> binding and where ifso?
> 
> 
> Whether a separate document will be resubmitted for the SOAP 
> binding or whether the DSKPP should expressed using WSDL 2.0 
> (which allows for SOAP and HTTP
> bindings) is TBD after the co-chairs consult with the 
> Applications Area Director.
> 
> ----------
> nosy: +keyprov
> 
> <http://www.tschofenig.com:8080/keyprov/issue10>