Subject: [KEYPROV] Using XML in Internet Protocols

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 10 Jan 2008 10:03:50 +0200

In case you have seen this tutorial at the last IETF meeting, please 
take a look at:
http://edu.ietf.org/download/72/xmltut-0.pdf

The slides point also to RFC 3470 about “Guidelines for the Use of 
Extensible Markup Language (XML)”

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 10 Jan 2008 11:04:25 +0200

Hi Anders,

yep. I also noticed the dislike of XML schemas and the preference for 
Relax NG.
I wrote XML schemas and Relax NG schemas for IETF protocols and I have 
to admit that Relax NG is much, much nicer to write and to read. But: 
There was, however, always the argument that Relax NG lacks tool support.

For the work in the group nobody so far proposed the usage of Relax NG 
and we have other issues to deal with first but it would not hurt to 
take a look at RFC 3470.

Ciao
Hannes

Rundgren, Anders wrote:
> Interesting document although I had to look on URL
> http://www3.ietf.org/proceedings/07dec/slides/xmltut-0.pdf
> to find it.
>
> The author seems to dislike XML Schemas:
>
> W3C XML Schemas (XSD)
> - Hard to understand, hard to implement, hard to
>   interoperate.
> - No underlying formalism.
> - Limited in the set of markup idioms they can define.
> - Includes (in "Part 2") a usable set of primitive
>   Data types: Integers, floats, dates, URIs, and so on.
> - One of the reasons why the SOA/WS-* project is
>   sinking.
>
>
> I definitely agree that XSD is not easy but there is nothing stopping
> you from creating very simple XSDs in case you feel challenged by some
> constructs.
>
> That WS-* is in jeopardy due to XSD is though something I don't
> particularly buy into.  The main problem with WS-* is really the
> diversion and constant "progress" (eh...) that makes it fairly
> impossible to ship interoperable solutions without requiring every
> system implementing multiple flavors of the same thing.  ebXML messaging
> 2.0 had for example 21 different ways to arrange security.  For some
> people this sounds like "flexibility", but in my opinion it is rather a
> failure understanding the realities of system development which is that
> you try a couple of variants that *you* think are OK and that's about
> it.
>
> Regards
> Anders Rundgren
>
>
> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Thursday, January 10, 2008 09:04
> To: [email-masked]
> Subject: [KEYPROV] Using XML in Internet Protocols
>
> The slides point also to RFC 3470 about "Guidelines for the Use of 
> Extensible Markup Language (XML)"
>
>
>

---

From: "Rundgren, Anders" <[email-masked]>
Date: Thu, 10 Jan 2008 08:42:10 -0000

W3C XML Schemas (XSD)

Regards
Anders Rundgren