Subject: Re: [KEYPROV] Keyprov Conference Call Meeting Minutes, 28th April 2009

From: "Pei, Mingliang" <[email-masked]>
Date: Wed, 6 May 2009 19:00:01 -0700

Updated PSKC schema file attached:

1. DerivedKeyType is commented out, and we are going to point PBE key
type to W3C version in the doc.
2. AlgorithmParameters is renamed to AlgorithmAttributes per early
discussion
3. xml:id is pulled back for IDs of the type "xs:ID". It was suggested
earlier and added in one version but didn't get in the file.

The version is based on the last version pskc_04052009.xsd. Please
review, and let me know if there are questions. Thanks,

- Ming 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Tschofenig, 
> Hannes (NSN - FI/Espoo)
> Sent: Tuesday, April 28, 2009 11:36 PM
> To: KEYPROV
> Subject: [KEYPROV] Keyprov Conference Call Meeting Minutes, 
> 28th April 2009
> 
> Participants:
> 
>  - Ming Pei
>  - Andrea Doherty
>  - Salah Machani
>  - Hannes Tschofenig
>  - Phillip Hallam-Baker
>  
> Discussion
> 
>  Terminology changes to the PSKC being incorporated by Hannes. 
>  Pasi provided further feedback for the terminology changes 
> distributed by Philip. 
>  
>  Tentatively we will go for the following wording proposal: 
>  
>    s/KeyAlgorithm/KeyType
>    s/KeyType/KeyObject
>    
>  PSKC open issues so far:
>  
>    * Figure 1 needs to be updated based on the drawing from 
> the IETF meeting.
>    * Some examples require update, namely those with 
> cryptographically computed values. 
>    * Review comments sent to the mailing list need to get reflected.
>    * Ming to provide info about MAC key definition and schema in PSKC
>    * Ming to provide info about encryption key in PSKC 
>    * Ming believe that cryptographic module needs an id. 
> Andrea believes that we don't need one as agreed during the meeting.
>      Ming wants to provide some text. 
>    * Ming to provide text about derived key using the 
> recently published
> document by Magnus. 	 
>    
>  DSKPP
>  
>   Ming summarized his recent comment about DSKPP sent to the 
> mailing list. Andrea was not too happy about re-opening old 
> issues. Phillip said that we should introduce a feature 
> freeze in 2 weeks. Andrea suggested that new features should 
> be deferred to a new DSKPP version or to an extension.  
>    
>   Andrea will respond to Ming on the list to postpone the 
> stateless / stateful issue. 
>   Andrea will look at the other raised issues and will 
> provide a response.  
>   
> _______________________________________________
> KEYPROV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/keyprov
>

---

From: "Philip Hoyer" <[email-masked]>
Date: Wed, 13 May 2009 15:55:04 +0200

Ladies and Gentlemen,
Not to put a spanner in the works but just having looked at PKCS#11 it
uses the term Mechanism (Algorithm) Parameters and not attributes.

I personally prefer AlgorithmParameters instead of AlgorithmAttributes

Not adamant just wanted to have an opinion from you.

Also coming back to the old chestnut of Ids

We currently have 3 identifiers in the schema:

KeyContainer.Id of type xsID
Key.Id of type xs:string
CryptomoduleInf.Id of type xs:string.

I remember earlier discussion of wanting to distinguish between Ids as
refeences to XML documents (KkeyContainer.Id) and Ids that have meaning
outside of the document (Key.Id and CryptoModuleInfo.Id).

Should we keep them all as 'Id'? or should we change KeyContainer.Id to
KeyContaner.ID?

Xmlenc uses 'Id' even if of type xs:ID...

Philip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Pei, Mingliang
Sent: Thursday, May 07, 2009 3:00 AM
To: Tschofenig, Hannes (NSN - FI/Espoo); KEYPROV
Subject: Re: [KEYPROV] Keyprov Conference Call Meeting Minutes,28th
April 2009

- Ming