Subject: [KEYPROV] MAC cipher value mismatch (RE: New version of PSKC)

From: "Pei, Mingliang" <[email-masked]>
Date: Thu, 17 Dec 2009 18:55:38 -0800

Hi Philip,
 
Dan pointed out the error in the example of spec v04, and I tried to figure out where it was missed. I did provide the correct value as seen in this email from 9/1. It looks that the last version didn't pick up this change as needed. I assume that there will be another update before the final RFC publish. Let us include this change in the final version.
 
Thanks,
 
- Ming

________________________________

	From: Pei, Mingliang 
	Sent: Tuesday, September 01, 2009 10:44 PM
	To: Philip Hoyer; [email-masked]; Phillip Hallam-Baker; Salah Machani; Sean Turner
	Cc: Doherty, Andrea; Magnus Nyström; KEYPROV
	Subject: RE: New version of PSKC

	Hi Philip,
	 
	Please see the forwarded email that includes the examples from my implementation that I sent earlier. The latest draft doesn't seem to have the CipherValue for the MAC key right. Please update it to
	 
	2GTTnLwM3I4e5IO5FkufoOEiOhNj91fhKRQBtBJYluUDsPOLTfUvoU2dStyOwYZx
	 
	Thanks,
	 
	- Ming

________________________________

		From: Philip Hoyer [mailto:[email-masked]] 
		Sent: Friday, August 28, 2009 9:56 AM
		To: [email-masked]; Phillip Hallam-Baker; Pei, Mingliang; Salah Machani; Sean Turner
		Cc: Doherty, Andrea; Magnus Nyström; KEYPROV
		Subject: New version of PSKC

		Ladies and Gentlemen,

		Please find attached the new version of PSKC.

		Changes:

		*	incorporated all of the feedback from Andrea and Sean. 
		*	reference name change to the new DerivedKey element (moved to XMLEnc11) 
		*	Corrected AES example to include (prepend) IV inline with XMLENC spec and mentions IV handling. 

		I have one big problem:

		The samples that Ming sent out for PBE and RSA do not match the ones in the spec.

		Especially the PBE is different form the one Ming already says was corrected.

		Based on the new XML Enc 1.1 spec for PBE and DerivedKeys. Are we sure we are aligned here?

		This is the only thing that needs to be clarified.

		Otherwise,

		What do I need to do now.

		Do I just submit or send to Russ and Pasi directly?

		Philip

		________________________________

		Philip Hoyer 

		Senior Architect - Office of CTO

		ActivIdentity (UK)

		117 Waterloo Road

		London SE1 8UL

		Telephone: +44 (0) 20 7960 0220

		Fax: +44 (0) 20 7902 1985

		Private and confidential: This message and any attachments may contain

		privileged / confidential information. If you are not an intended recipient,

		you must not copy, distribute, discuss or take any action in reliance on it.

		If you have received this communication in error, please notify the sender

		and delete this message immediately.

---

From: "Philip Hoyer" <[email-masked]>
Date: Fri, 18 Dec 2009 14:58:52 +0100

Ming,

There is no other planned version, Hannes should be taking this to RFC as we speak.

Hannes since there are 2 mistakes I the examples should we correct them? And resubmit? Or what is the process at the moment.

Philip

From: Pei, Mingliang [mailto:[email-masked]] 
Sent: Friday, December 18, 2009 2:56 AM
To: Philip Hoyer; [email-masked]; Phillip Hallam-Baker; Salah Machani; Sean Turner
Cc: Doherty, Andrea; Magnus Nyström; KEYPROV; Dan Smith
Subject: MAC cipher value mismatch (RE: New version of PSKC)

Hi Philip,

Thanks,

- Ming

	From: Pei, Mingliang 

	Hi Philip,

	Thanks,

	- Ming

		Ladies and Gentlemen,

		Changes:

		I have one big problem:

		Otherwise,

		Philip

		Philip Hoyer 

		ActivIdentity (UK)

		117 Waterloo Road

		London SE1 8UL