Subject: Re: [KEYPROV] PROTO WRITEUP for draft-ietf-keyprov-symmetrickeyformat-07

From: Anders Rundgren <[email-masked]>
Date: Wed, 03 Mar 2010 09:43:04 +0100

The document is great from a technical point of view.

The utility is questionable since PSKC does the same
thing and also interopes with DSKPP.  The rationale
(which has been mentioned but not been put on paper)
"cards cannot process XML" is true but provisioning
generally relies on middleware doing the unpacking
and then through some API inserting keys and attributes
in the card.

Creating tokens that would decipher CMS is technically
doable but there is absolutely no point with that

In case you want to know how you can deal with XML,
secure transfer of secrets, and still keep the token
device unaware of sophisticated data structures and
public key verification you may take a peek in the
following document:

"setPiggybackedSymmetricKey"

http://webpki.org/papers/keygen2/sks-api-arch.pdf

Anders

---

From: Sean Turner <[email-masked]>
Date: Wed, 03 Mar 2010 09:00:06 -0500

Anders,

PSKC is the mandatory to implement key package and nobody, that I am 
aware of, is trying to change that.  The container defined in 
draft-ietf-keyprov-symmetrickeyformat-07 is optional to implement.

spt

Anders Rundgren wrote:
> _______________________________________________
> KEYPROV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/keyprov
>

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 03 Mar 2010 15:54:36 +0100

> draft-ietf-keyprov-symmetrickeyformat-07 is optional to implement.

I just said that it felt like a redundant solution.

/anders