Subject: Re: [KEYPROV] PROTO WRITEUPfor draft-ietf-keyprov-symmetrickeyformat-07

From: "Philip Hoyer" <[email-masked]>
Date: Wed, 3 Mar 2010 16:29:30 +0100

Redundant to what exactly?

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Sean Turner <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Wed Mar 03 15:54:36 2010
Subject: Re: [KEYPROV] PROTO WRITEUPfor	draft-ietf-keyprov-symmetrickeyformat-07

Sean Turner wrote:
> Anders,
> 
> PSKC is the mandatory to implement key package and nobody, that I am 
> aware of, is trying to change that.  The container defined in 
> draft-ietf-keyprov-symmetrickeyformat-07 is optional to implement.

I just said that it felt like a redundant solution.

/anders

> 
> spt
> 
> Anders Rundgren wrote:
>> The document is great from a technical point of view.
>>
>> The utility is questionable since PSKC does the same
>> thing and also interopes with DSKPP.  The rationale
>> (which has been mentioned but not been put on paper)
>> "cards cannot process XML" is true but provisioning
>> generally relies on middleware doing the unpacking
>> and then through some API inserting keys and attributes
>> in the card.
>>
>> Creating tokens that would decipher CMS is technically
>> doable but there is absolutely no point with that
>>
>> In case you want to know how you can deal with XML,
>> secure transfer of secrets, and still keep the token
>> device unaware of sophisticated data structures and
>> public key verification you may take a peek in the
>> following document:
>>
>> "setPiggybackedSymmetricKey"
>>
>> http://webpki.org/papers/keygen2/sks-api-arch.pdf
>>
>> Anders
>> _______________________________________________
>> KEYPROV mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/keyprov
>>
> 

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 03 Mar 2010 17:10:46 +0100

> Redundant to what exactly?

I believe I elaborated that in my initial posting.

RSA have had seeds distributed in XML format for ages and they work
on multiple platforms including mobile phones.

Anders