Subject: Comments on draft-ietf-kitten-gssapi-prf-00

From: Sam Hartman <[email-masked]>
Date: Fri, 10 Dec 2004 05:54:50 -0500

1) The spec must require that gss_pseudo_random with the same input
   will produce the same output within one context.  I.E. if I call
   the function multiple times with the same input I get the same result.

2) The spec must require that the probability that I get the same
   output given the same input with different contexts is exponentially small

3) The requirement that the function be called at most once per
   context needs to be dropped.

4) A reference to a definition of PRFs needs to be added.

5) The section titled "normative" should either become a subsection of a section titled "References" or should be retitled "Normative References"

--Sam

_______________________________________________
Kitten mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/kitten

---

From: Nicolas Williams <[email-masked]>
Date: Mon, 13 Dec 2004 12:06:44 -0600

>    the function multiple times with the same input I get the same result.

I.e., there should be a "MUST" in the text, correct?  Will do.

>    output given the same input with different contexts is exponentially small

Or as best the mechanism designers can get to that.  Will do.

Out of curiosity, where does this leave the krb5 des-cbc-crc enctype? :)

>    context needs to be dropped.

It was a recommendation, not requirement.  In that light, should it
still be dropped?

> 4) A reference to a definition of PRFs needs to be added.

Recommendations?

> 5) The section titled "normative" should either become a subsection of a section titled "References" or should be retitled "Normative References"

Will do.