Subject: Last word on MechListMIC encoding

From: Wyllys Ingersoll <[email-masked]>
Date: Thu, 02 Dec 2004 09:50:19 -0500

The latest draft  submitted (-02) specifically states how the
MechListMIC is to be encoded:
Section 5, item 'a' says:
        [...] only the DER encoding of the type MechTypeList is included.

I interpret this to mean the following in the case where the
MechList contains the Kerberos OID (as an example):
       30 nn 06 09 2A 86 48 86 F7 12 01 02 02 ...

This is acceptable to me (even though it breaks our current
implementation, which I seriously doubt that anyone is
interoperating with anyway since its not yet released).

Is everyone else in agreement about the definition of how
to encode the MIC  and with the text as it is written?

-Wyllys Ingersoll

_______________________________________________
Kitten mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/kitten

---

From: Luke Howard <[email-masked]>
Date: Fri, 3 Dec 2004 09:45:30 +1100

>       30 nn 06 09 2A 86 48 86 F7 12 01 02 02 ...

I agree (eg. 

30 0b 06 09 2a 86 48 86 f7 12 01 02 02

for just the Kerberos mech)

>interoperating with anyway since its not yet released).

What does your implementation do?

-- Luke

--