Subject: Re: [kitten] Minting URIs for a draft?

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 17 Sep 2012 09:56:52 -0600

On 9/17/12 9:38 AM, Cantor, Scott wrote:
> On 9/17/12 11:36 AM, "Cantor, Scott" <[email-masked]> wrote:
> 
>> On 9/17/12 11:25 AM, "Peter Saint-Andre" <[email-masked]>
>> wrote:
>>> 
>>> I'd recommend IETF URNs. See registration examples here:
>>> 
>>> http://tools.ietf.org/html/rfc6120#section-14
>> 
>> Thanks for the pointer. The XML REG RFC doesn't actually mention
>> the use case I have, which is for a URI constant, not an XML
>> namespace or any of the other types of identifiers mentioned. Is
>> that a problem?
> 
> Answering my own question, it would seem so, since they're trying
> to carve out consistent subtrees for the various kinds of
> identifiers, and mine don't qualify as any of them.
> 
> (Informationally, they're key derivation algorithm URIs for use
> with XML Encryption syntax.)

Could you provide a few examples? They might be similar to some
identifiers that led me to think we might want a urn:iana: tree.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Cantor, Scott" <[email-masked]>
Date: Mon, 17 Sep 2012 16:02:50 +0000

>identifiers that led me to think we might want a urn:iana: tree.

Well, the existing algorithms are limited to:

http://www.w3.org/2009/xmlenc11#ConcatKDF
http://www.w3.org/2009/xmlenc11#pbkdf2

I'm using the syntax to handle communicating the derivation mechanisms I'm
putting into my mechanism for the more common case of bearer tokens, one
of which is using the TLS-Exporter mechanism and the other is just a dummy
mechanism for the insecure case of generating a client nonce to use as a
key. I need that for apps that require GSS session keys even if it's not
really secure.

Were I using W3C identifiers, they'd be something like

http://www.w3.org/2009/xmlenc11#client-generated
http://www.w3.org/2009/xmlenc11#tls-exporter

-- Scott