Subject: [kitten] OT: ktutil and x-realm keys (Re: Comments on draft-ietf-kitten-aes-cts-hmac-sha2-00)

From: Nico Williams <[email-masked]>
Date: Mon, 20 May 2013 19:04:15 -0500

On Mon, May 20, 2013 at 6:46 PM, Henry B. Hotz <[email-masked]> wrote:
> On May 16, 2013, at 9:36 AM, Greg Hudson <[email-masked]> wrote:
>> * Cross-realm TGTs are currently managed by entering the same password
>> at two KDCs to get the same keys.  If each KDC uses a random salt, they
>> won't have the same keys.
>
> Obviously off-topic, but I've advocated for a "keytab import" administrative function as a way to avoid retyping passwords in this case.  Yeah, yeah, "write it yourself, it's open-source", I know.

I don't think that's the best way to implement this.  As long as we
must have password-based x-realm keys the way it should work is that
one admin creates an x-realm princ on on realm, then the other realm's
admin does an AS exchange to fetch the salt (and other s2kparams) and
validate the password they've been told on the phone/whatever, then
the key gets added to that realm.  This is, also, how password-based
keys should be added to keytabs (to fetch the salt and other
s2kparams).

But this is off-topic, and also off-topic: we really need
password-authenticated DH-exchanged x-realm keys and PKI-authenticated
DH-exchanged x-realm keys.  I.e., PKCROSS.

Nico
--

---

From: "Henry B. Hotz" <[email-masked]>
Date: Tue, 21 May 2013 11:59:29 -0700

On May 20, 2013, at 5:04 PM, Nico Williams <[email-masked]> wrote:

> must have password-based x-realm keys

But that's the point.  They shouldn't be password-based at all.  The string-to-key function isn't needed to make the tgs exchanges work.  All implementations can already generate random keys.  All implementations can already *export* keytab files independent of the password.  Just add the inverse operation.

See slide 16 of my 2007 AFS BP workshop presentation for how it works for Heimdal<->Heimdal cross-realm.  (I neglected to say you start with an "add -r" or two.)

> the way it should work is that

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]