Subject: Re: [kitten] BrowserID mutual auth

From: Luke Howard <[email-masked]>
Date: Sun, 6 Oct 2013 20:56:20 +1100

To follow up on an old post. I've updated the draft to use RFC 4985 SRVNames instead of URIs in the SAN.

Service principal names encoded in context tokens are now prefixed with urn:ietf:params:gss:spn
 instead of urn:x-gss.

Link here:

http://www.ietf.org/id/draft-howard-gss-browserid-05.txt

-- Luke

---

From: Luke Howard <[email-masked]>
Date: Mon, 7 Oct 2013 16:30:01 +1100

I published -06 which incorporates the change mentioned in my last mail (as JWT specifies the audience claim as a StringOrURI, we will encode the raw service principal name without a URN prefix). A few other nits fixed (and introduced).

The reference implementation (gss_browserid) has been updated to -06.

On 06/10/2013, at 8:56 PM, Luke Howard <[email-masked]> wrote:

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

--
Luke Howard / [email-masked]
www.padl.com / www.lukehoward.com