Subject: [kitten] [RFC Errata System] [Technical Errata Reported] RFC6112 (3743)

From: Sam Hartman <[email-masked]>
Date: Tue, 08 Oct 2013 15:08:50 -0400

Folks, when working on the MIT implementation of RFC 6112 I got the
capitalization of one of the cryptographic inputs wrong.
Love found this while interop testing against MIT.

As we (myself, MIT and Love) understand, MIT is the only shipping
implementation.

We propose to change the spec rather than the implementations.

This would presumably involve:

1) accepting this erata 

2) Fairly quickly reissuing RFC 6112 and moving the existing spec to
historic.

Thoughts/comments?

Subject: [Technical Errata Reported] RFC6112 (3743)
From: RFC Errata System <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
Cc: [email-masked], [email-masked], [email-masked]
Date: Tue, 8 Oct 2013 11:06:46 -0700 (PDT)

The following errata report has been submitted for RFC6112,
"Anonymity Support for Kerberos".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6112&eid=3743

--------------------------------------
Type: Technical
Reported by: Love Hörnquist Åstrand <[email-masked]>

Section: 7

Original Text
-------------
 "is ASCII string "KeyExchange"

Corrected Text
--------------
"is ASCII string "KEYEXCHANGE"

Notes
-----
MIT Kerberos is the only public implementation of this draft and when I created the second implementation I noticed that the MIT folks had used the wrong constant in their code.

After talking to them it makes more sense to change the specification then break backward compatibility with old clients since there no other implementations that we know about.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6112 (draft-ietf-krb-wg-anon-12)
--------------------------------------
Title               : Anonymity Support for Kerberos
Publication Date    : April 2011
Author(s)           : L. Zhu, P. Leach, S. Hartman
Category            : PROPOSED STANDARD
Source              : Kerberos WG
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Greg Hudson <[email-masked]>
Date: Tue, 08 Oct 2013 15:14:13 -0400

> 2) Fairly quickly reissuing RFC 6112 and moving the existing spec to

I support this plan.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 08 Oct 2013 21:28:45 +0100

Hiya,

>> 2) Fairly quickly reissuing RFC 6112 and moving the existing spec to

That does sound like the right outcome.

However...

The IESG often sees suggestions for "improvements" to RFCs posted as
errata and we reject those on the basis that the errata process is
intended to handle cases where a WG/authors/whoever made a mistake and
that process is just *not* intended to change what the WG wanted to
see in the RFC.

Can you make a case that this really is an erratum and does not
really represent a change of mind?

Thanks,
Stephen.

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 9 Oct 2013 09:21:44 -0400 (EDT)

> That does sound like the right outcome.

It sounds good to me, too.

> really represent a change of mind?

My perspective (as someone who only started participating in the WG after 
this document was published) is that there was an arbitrary choice that 
had to be made in the creation of the document, and the implementors used 
(for whatever reason) an equally valid selection of that arbitrary choice. 
It's not really that there's a change of mind so much as there's no reason 
to care one way or the other until there is something to interoperate 
with.

I'm not sure whether that would help with the IESG or not, though.

-Ben

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 09 Oct 2013 14:50:40 +0100

> I'm not sure whether that would help with the IESG or not, though.

I'm checking if anyone will yell if we approve this. While I
guess they won't mind about the kerberos change, its possible
that someone will strongly dislike the precedent. But we'll
see.

S.

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Wed, 9 Oct 2013 15:55:53 +0200

> that someone will strongly dislike the precedent. But we'll

I this either way is fine wrt approving the errata.

Now the kerberos community will know that there is an issue in RFC6112.

IESG can approve a new version of RFC6112 which a a one word change once there is a new draft published.

Love

---

From: Sam Hartman <[email-masked]>
Date: Wed, 09 Oct 2013 13:34:59 -0400

Sure.
It's really a rules lawyer question about the erata.
the interesting and important thing is to go issue a new spec.
I won't be able to put together a draft before Vancouver but I will work
promptly on this.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 15 Oct 2013 11:53:39 +0100

> that someone will strongly dislike the precedent. But we'll

I asked and was asked back: how widely is this one
implementation deployed?

I also got a non-IESG comment that this wasn't the
first time we've ended up changing things due to
coding glitches so maybe we need to think about
that as well.

S.

> 
> S.
> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
> 
>

---

From: Greg Hudson <[email-masked]>
Date: Tue, 15 Oct 2013 10:01:37 -0400

> I asked and was asked back: how widely is this one

RFC 6112 was first implemented in MIT krb5 version 1.8, which was
released in March 2010.  We never have any solid idea how widely krb5
features are being used since we don't have a close relationship with
most of our users.  I have seen at least one question about anonymous
PKINIT on [email-masked], so it's being used at least somewhat.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 15 Oct 2013 15:04:51 +0100

> PKINIT on [email-masked], so it's being used at least somewhat.

Would asking about the erratum on that list therefore be
useful?

Ta,
S.

---

From: Greg Hudson <[email-masked]>
Date: Tue, 15 Oct 2013 10:30:36 -0400

> Would asking about the erratum on that list therefore be

I assume you mean, would it be useful to ask on [email-masked] whether
people are using anonymous PKINIT?  The list is not by any means a
reliably way of canvassing users, so I don't think it would be.

I'm also not sure where we would go with such a question.  I think
implementors have decided that we are going to use "KEYEXCHANGE" instead
of "KeyExchange" as the pepper going forward.  There is no obvious way
to change the existing implementation to use "KeyExchange" without
creating interoperability issues, and there is no merit to one string
over another aside from its likelihood of interoperating.

---

From: Russ Allbery <[email-masked]>
Date: Wed, 16 Oct 2013 08:50:35 -0700

>> I asked and was asked back: how widely is this one implementation
>> deployed?

> PKINIT on [email-masked], so it's being used at least somewhat.

Anonymous PKINIT is supported by my Kerberos PAM module for obtaining FAST
armor.  I don't know how many people actually use it, though.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>