Subject: [kitten] I-D Action: draft-ietf-kitten-aes-cts-hmac-sha2-03.txt

From: [email-masked]
Date: Wed, 02 Jul 2014 08:43:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Common Authentication Technology Next Generation Working Group of the IETF.

        Title           : AES Encryption with HMAC-SHA2 for Kerberos 5
        Authors         : Michael J. Jenkins
                          Michael A. Peck
                          Kelley W. Burgin
	Filename        : draft-ietf-kitten-aes-cts-hmac-sha2-03.txt
	Pages           : 15
	Date            : 2014-07-02

Abstract:
   This document specifies two encryption types and two corresponding
   checksum types for Kerberos 5.  The new types use AES in CTS mode
   (CBC mode with ciphertext stealing) for confidentiality and HMAC with
   a SHA-2 hash for integrity.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-kitten-aes-cts-hmac-sha2/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-kitten-aes-cts-hmac-sha2-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 5 Jul 2014 21:40:38 -0400 (EDT)

> http://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-03

The text changes look good to me; thanks.

I would still like to have pseudo-random test vectors (though I do not 
think I will insist on it).  I may try to find time to generate some.

-Ben

---

From: "Peck, Michael A" <[email-masked]>
Date: Mon, 7 Jul 2014 14:03:57 +0000

Ben,

Thanks for reviewing the changes.

I put together test vectors this morning for deriving Kp from the base-key
and for the pseudo-random function invocations.
I can add the following text to Appendix A (Test Vectors) once
Internet-Draft submission reopens.
If you'd like to verify these I certainly wouldn't mind.

Sample results for key derivation:
   ----------------------------------

   enctype aes128-cts-hmac-sha256-128:
   128-bit base-key:
      37 05 D9 60 80 C1 77 28 A0 E8 00 EA B6 E0 D2 3C
   Kc value for key usage 2 (constant = 0x0000000299):
      B3 1A 01 8A 48 F5 47 76 F4 03 E9 A3 96 32 5D C3
   Ke value for key usage 2 (constant = 0x00000002AA):
      9B 19 7D D1 E8 C5 60 9D 6E 67 C3 E3 7C 62 C7 2E
   Ki value for key usage 2 (constant = 0x0000000255):
      9F DA 0E 56 AB 2D 85 E1 56 9A 68 86 96 C2 6A 6C
   Kp value (constant = 0x707266):
      9C 66 77 98 08 4F 16 82 1E 77 15 DD 5A A6 EB 71

   enctype aes256-cts-hmac-sha384-192:
   256-bit base-key:
      6D 40 4D 37 FA F7 9F 9D F0 D3 35 68 D3 20 66 98
      00 EB 48 36 47 2E A8 A0 26 D1 6B 71 82 46 0C 52
   Kc value for key usage 2 (constant = 0x0000000299):
      EF 57 18 BE 86 CC 84 96 3D 8B BB 50 31 E9 F5 C4
      BA 41 F2 8F AF 69 E7 3D
   Ke value for key usage 2 (constant = 0x00000002AA):
      56 AB 22 BE E6 3D 82 D7 BC 52 27 F6 77 3F 8E A7
      A5 EB 1C 82 51 60 C3 83 12 98 0C 44 2E 5C 7E 49
   Ki value for key usage 2 (constant = 0x0000000255):
      69 B1 65 14 E3 CD 8E 56 B8 20 10 D5 C7 30 12 B6
      22 C4 D0 0F FC 23 ED 1F
   Kp value (constant = 0x707266):
      5D 63 0D B7 EF DE 37 DE 9C 92 03 C5 2B D9 6C 77
      31 BE 1C 5B DD 50 DC 75 44 D9 60 AF F3 CC 23 04

Sample pseudo-random function (PRF) invocations:
   -----------------------------------------

   PRF input octet-string: "test" (0x74657374)

   enctype aes128-cts-hmac-sha256-128:
   Kp value:
      9C 66 77 98 08 4F 16 82 1E 77 15 DD 5A A6 EB 71
   PRF output:
3A CA 18 6C C1 26 56 76 5C FE B1 D2 2D 1C B1 36

   enctype aes256-cts-hmac-sha384-192:
   Kp value:
      5D 63 0D B7 EF DE 37 DE 9C 92 03 C5 2B D9 6C 77
      31 BE 1C 5B DD 50 DC 75 44 D9 60 AF F3 CC 23 04
   PRF output:
      01 72 03 F2 90 CD 16 6C D6 B2 BB 4F 18 7D 16 23
      6B 9A 4E D7 66 19 D8 11 6C 64 06 A3 37 E7 F9 08

On 7/5/14, 9:40 PM, "Benjamin Kaduk" <[email-masked]> wrote:

>_______________________________________________
>Kitten mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/kitten