Subject: Re: [kitten] WGLC on draft-ietf-kitten-aes-cts-hmac-sha2-06

From: Jeffrey Altman <[email-masked]>
Date: Fri, 27 Nov 2015 10:49:02 -0500

On 4/17/2015 5:23 PM, Benjamin Kaduk wrote:
> 
> That seems to leave us with the following action items:
> 
> For the document editor:
> * remove truncation from the PRF output and use the natural hash output
> length
> * remove the use of random-to-key() and discussion of constant values from
> section 3
> * add an output length argument to KDF-HMAC-SHA2() and adjust text
> accordingly
> * update test vectors to include base keys and key usage values for all
> test cases
> * reword the text discussing aes256 with 192-bit keys

Michael and Michael,

How is draft-ietf-kitten-aes-cts-hmac-sha2-07 coming along?

As promised, Luke Howard is implementing aes-cts-hmac-sha2 for Heimdal.
 Luke currently has -06 implemented and I would prefer to see a verified
implementation of -07 with the above changes.

Thank you.

Jeffrey Altman

---

From: Michael Jenkins <[email-masked]>
Date: Fri, 27 Nov 2015 15:27:35 -0500

We are working on the changes and will post a new draft as soon as possible!

-- 
Mike Jenkins
[email-masked] - if you want me to read it only at my desk
[email-masked] - to read everywhere
443-634-3951

---

From: Jeffrey Altman <[email-masked]>
Date: Fri, 27 Nov 2015 19:34:19 -0500

> We are working on the changes and will post a new draft as soon as possible!

Luke Howard's implementation for Heimdal can be found at

  https://github.com/heimdal/heimdal/commits/lukeh/aes-cts-hmac-sha2

Jeffrey Altman