Subject: [kitten] I-D Action: draft-ietf-kitten-aes-cts-hmac-sha2-10.txt

From: [email-masked]
Date: Tue, 05 Jul 2016 11:00:40 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Authentication Technology Next Generation of the IETF.

        Title           : AES Encryption with HMAC-SHA2 for Kerberos 5
        Authors         : Michael J. Jenkins
                          Michael A. Peck
                          Kelley W. Burgin
	Filename        : draft-ietf-kitten-aes-cts-hmac-sha2-10.txt
	Pages           : 17
	Date            : 2016-07-05

Abstract:
   This document specifies two encryption types and two corresponding
   checksum types for Kerberos 5.  The new types use AES in CTS mode
   (CBC mode with ciphertext stealing) for confidentiality and HMAC with
   a SHA-2 hash for integrity.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-kitten-aes-cts-hmac-sha2/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-kitten-aes-cts-hmac-sha2-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Jenkins <[email-masked]>
Date: Tue, 5 Jul 2016 15:55:00 -0400

The new draft-ietf-kitten-aes-cts-hmac-sha2 includes changes for all of
Ben's comments. As for the KDF, we looked at both simply inserting a 0x00
between the "prf" and the octet string (leaving the extra 0x00 before the
length bits intact), and fixing the KDF so that the prf was computed the
same way as any other KDF. So in the end we decided that the cleanest and
least likely to confuse option was to fix the KDF definition in Section 3
by adding an optional context field.

Mike J

On Tue, Jul 5, 2016 at 2:00 PM, <[email-masked]> wrote:

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
>

-- 
Mike Jenkins
[email-masked] - if you want me to read it only at my desk
[email-masked] - to read everywhere
443-634-3951

---

From: Luke Howard <[email-masked]>
Date: Wed, 6 Jul 2016 09:55:50 +1000

Updated aes-cts-hmac-sha2 branch of Heimdal.

> On 6 Jul 2016, at 5:55 AM, Michael Jenkins <[email-masked]> wrote:
> 
> The new draft-ietf-kitten-aes-cts-hmac-sha2 includes changes for all of Ben's comments. As for the KDF, we looked at both simply inserting a 0x00 between the "prf" and the octet string (leaving the extra 0x00 before the length bits intact), and fixing the KDF so that the prf was computed the same way as any other KDF. So in the end we decided that the cleanest and least likely to confuse option was to fix the KDF definition in Section 3 by adding an optional context field.
> 
> Mike J
> 
> On Tue, Jul 5, 2016 at 2:00 PM, <[email-masked] <mailto:[email-masked]>> wrote:
> 
> https://datatracker.ietf.org/doc/draft-ietf-kitten-aes-cts-hmac-sha2/ <https://datatracker.ietf.org/doc/draft-ietf-kitten-aes-cts-hmac-sha2/>
> 
> https://tools.ietf.org/html/draft-ietf-kitten-aes-cts-hmac-sha2-10 <https://tools.ietf.org/html/draft-ietf-kitten-aes-cts-hmac-sha2-10>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-10 <https://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-10>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/kitten <https://www.ietf.org/mailman/listinfo/kitten>
> 
> 
> 
> -- 
> Mike Jenkins
> [email-masked] <mailto:[email-masked]> - if you want me to read it only at my desk
> [email-masked] <mailto:[email-masked]> - to read everywhere
> 443-634-3951 <tel:443-634-3951>_______________________________________________
> Kitten mailing list
> [email-masked]

--
www.lukehoward.com
soundcloud.com/lukehoward

---

From: Greg Hudson <[email-masked]>
Date: Wed, 6 Jul 2016 02:29:08 -0400

> Updated aes-cts-hmac-sha2 branch of Heimdal.

I also updated my Python and MIT krb5 implementations, and verified the
new PRF test vectors.

https://github.com/greghudson/pyk5/tree/aes-sha2
https://github.com/greghudson/krb5/tree/aes-sha2

(As before, there is no guarantee of commit stability for either of
these branches, and they may disappear entirely after being merged into
the relevant master branches.)

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 6 Jul 2016 16:45:25 -0400 (EDT)

The changes look good, thanks for putting them together so quickly.

Also thanks to Luke and Greg for updating implementations and re-verifying
test vectors.

-Ben