Subject: Re: [kitten] Proposal for tracking document reviews and skipping WGLC

From: Nico Williams <[email-masked]>
Date: Wed, 6 Jul 2016 19:54:55 -0500

On Mon, Jun 20, 2016 at 11:58:08PM -0400, Benjamin Kaduk wrote:
> Does this proposal seem reasonable?

Yes.

> If this proposal moves forward, there is a question of where to host the
> wiki page: two choices that came up so far are a github wiki or an
> IETF-hosted trac wiki, but we are not tied to those two options.  My

I'm not a fan of the IETF trac.  I'm not a fan of the github issue
tracker either, but,

a) github is very convenient,
b) its wiki is nice,
c) this can all be blended (optionally) with using git[hub] for version
   control of each I-D,
d) we can have an organization for the WG to be the umbrella for [a
   subset of] the WG's documents that every participant who asks can be
   made a member of.

> understanding is that either one would require an account tied to that
> provider in order to edit (to avoid wiki spam), so there would be some
> barrier to entry in either case.  However, perhaps more people already
> have github accounts than IETF trac accounts, which lends some preference

It's also becoming common to use github for IETF work.  E.g., TLS 1.3.

I'd consider other VCS services built around git too.

> to github; indeed, other WGs are using github for document editing and
> issue tracking already.  Regardless of where the wiki is hosted, a wiki
> account would not be needed in order to participate in document review;
> comments can always be sent to the mailing list and the chairs are able to
> edit the wiki page on behalf of others.

Indeed, the mailing list must remain the ultimate consensus confirmation
medium for now and the forseeable future.

Nico
--

---

From: "Henry B (Hank) Hotz, CISSP" <[email-masked]>
Date: Wed, 6 Jul 2016 18:16:02 -0700

Given the necessary multitude of different username/password combinations I need to avoid duplicating passwords already, I don’t consider the need for yet another for an IETF wiki to be a serious impediment.

Agreed that *some* mailing list traffic is still necessary so the otherwise-uninvolved have a chance to weigh in.

> On Jul 6, 2016, at 5:54 PM, Nico Williams <[email-masked]> wrote:
> 
> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

Personal: [email-masked]
https://www.linkedin.com/in/hbhotz/

---

From: Nico Williams <[email-masked]>
Date: Wed, 6 Jul 2016 20:44:20 -0500

On Wed, Jul 06, 2016 at 06:16:02PM -0700, Henry B (Hank) Hotz, CISSP wrote:
> Given the necessary multitude of different username/password
> combinations I need to avoid duplicating passwords already, I don’t
> consider the need for yet another for an IETF wiki to be a serious
> impediment.

That's not what bothers me about thr tracker.