Subject: [L2CP] L2CP; New Working Group Name

From: "Haag, T" <[email-masked]>
Date: Mon, 27 Mar 2006 12:37:09 +0200

All,

L2CP as working group name is already in use by other organisations. 
Therefore it was agreed during previous IETF meeting that the working group name should be changed. 
Potential acronyms like DL2C (DSL Layer 2 Control), L2CC (Layer2 Configuration & Control), ALCC (Access Link Configuration & Control) are already in use.

As far as I investigated the abbreviation "DLLC" is not in use:

Proposal 1: DLLC - DSL Loop & Link Control
Proposal 2: DLLC - DSL Logical Link Control
Proposal 3: DLLC - Digital Loop & Link Control
Proposal 4: DLLC - Dynamic Loop & Link Control

I'm in favour of proposal 1.
Any other opinion / proposal?

Regards
Thomas Haag

_______________________________________________
L2cp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2cp

---

From: "Haag, T" <[email-masked]>
Date: Mon, 27 Mar 2006 14:03:14 +0200

I would prefer "Link", because we are looking to the physical and logical link in the access. 

"Line" is very close to the U-interface boundary. Use cases like OAM and Multicast have a wider scope.

Thomas

-----Ursprüngliche Nachricht-----
Von: Peter Arberg [mailto:[email-masked]] 
Gesendet: Montag, 27. März 2006 13:56
An: Haag, Thomas; [email-masked]
Cc: Schott, Roland; Busser, Michael; [email-masked]; Langhammer, Michael; Witschurke, Birgit; Freudenberger, Markus; Meyer, Klaus; Weis, Werner; Hamacher, Peter
Betreff: RE: [L2CP] AW: L2CP; New Working Group Name

Correct if you do a search ALCP will show "Area Local Control Panel"
but it also shows "American Language and Culture Program".

So as long as it is not used in same context as we are looking to
use it, I do not think having 2 abbrivations with same letters is a 
big deal.

I prefer the ALCP = Access Line Control Protocol.
(could also use the Link as suggested by Matthew, I just think Line 
is easier ;)

cheers,
Peter 

> -----Original Message-----
> From: Haag, T [mailto:[email-masked]] 
> Sent: 27. marts 2006 13:14
> To: [email-masked]
> Cc: Schott, Roland; Busser, M; [email-masked]; Langhammer, 
> Michael; Witschurke, Birgit; Freudenberger, Markus; Meyer04, 
> Klaus; Weis, W; Hamacher, Peter
> Subject: [L2CP] AW: L2CP; New Working Group Name
> 
> Matthew,
> 
> ALCP is already in use for "Area Local Control Panel".
> 
> What's about BALCP? BACLP - Broadband Access Link Control Protocol
> 
> Regards
> Thomas
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Gesendet: Montag, 27. März 2006 12:53
> An: Haag, Thomas
> Cc: Witschurke, Birgit; Meyer, Klaus; [email-masked]; 
> Freudenberger, Markus; Busser, Michael; Langhammer, Michael; 
> Hamacher, Peter; Schott, Roland; [email-masked]; 
> [email-masked]; [email-masked]; Weis, Werner
> Betreff: Re: L2CP; New Working Group Name
> 
> Thomas,
> 
> I think that we discussed not precluding other access 
> technologies, so I
> think we should not use DSL in the WG name.
> 
> How about Access Link Control Protocol (ALCP) ?
> 
> Matthew
> 
> 
> 
> |---------+--------------------------->
> |         |           "Haag, T"       |
> |         |           <Thomas.Haag@t-s|
> |         |           ystems.com>     |
> |         |                           |
> |         |           27/03/2006 11:37|
> |---------+--------------------------->
>   
> >-------------------------------------------------------------
> ------------------------------------------------------------------|
>   |                                                           
>                                                                     |
>   |        To:      [email-masked]                             
>                                                                     |
>   |        cc:      "Meyer04, Klaus" <[email-masked]>, 
> "Langhammer, Michael" <[email-masked]>,            |
>   |        "Freudenberger, Markus" 
> <[email-masked]>, "Busser, M" 
> <[email-masked]>, "Witschurke, |
>   |        Birgit" <[email-masked]>, 
> "Hamacher, Peter" <[email-masked]>, "Weis, W" 
> <[email-masked]>, |
>   |        "Schott, Roland" <[email-masked]>, 
> Matthew BOCCI/GB/ALCATEL@ALCATEL, [email-masked], 
> [email-masked],      |
>   |        [email-masked]                                
>                                                                     |
>   |        Subject: L2CP; New Working Group Name              
>                                                                     |
>   
> >-------------------------------------------------------------
> ------------------------------------------------------------------|
> 
> 
> 
> 
> All,
> 
> 
> Therefore it was agreed during previous IETF meeting that the 
> working group
> name should be changed.
> 
> 
> Potential acronyms like DL2C (DSL Layer 2 Control), L2CC (Layer2
> Configuration & Control), ALCC (Access Link Configuration & 
> Control) are
> already in use.
> 
>

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Mon, 27 Mar 2006 08:19:09 -0500

Folks
  I would rather we don't restrict it to link or line (i.e. why rule out node level dynamic config). I would like to suggest "BACP" : Broadband Access Control Protocol. 

-Sanjay

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Mon, 27 Mar 2006 08:16:36 -0500

Folks

-Sanjay

>Sent: Monday, March 27, 2006 6:14 AM
>Cc: Witschurke, Birgit; Meyer04, Klaus; [email-masked]; Freudenberger,
>Markus; Busser, M; Langhammer, Michael; Hamacher, Peter; 
>Schott, Roland;
>Sanjay Wadhwa; [email-masked]; [email-masked]; Weis, W
>Subject: AW: L2CP; New Working Group Name
>
>
>Matthew,
>
>>--------------------------------------------------------------
>-----------------------------------------------------------------|
>  |                                                            
>                                                                   |
>  |        To:      [email-masked]                              
>                                                                   |
>  |        "Schott, Roland" <[email-masked]>, Matthew 
>BOCCI/GB/ALCATEL@ALCATEL, [email-masked], [email-masked],      |
>  |        [email-masked]                                 
>                                                                   |
>>--------------------------------------------------------------
>-----------------------------------------------------------------|
>
>
>
>
>All,
>
>

---

From: "Wojciech Dec \(wdec\)" <[email-masked]>
Date: Mon, 27 Mar 2006 15:44:49 +0200

Well, BACP is already used for bandwidth control in PPP, so we can't use
it. Think that BALCP is close to this too.

The candidates so far, with names that are reasonably easy to pronounce,
are:

Access Link Control Protocol (ALCP)

Subscriber Line Configuration and Control (SLICC). 
(However this one is open to the "who/what's a subscriber?" rathole
discussion, and dropping the S would leave it with a not a less than
appealing name... )

Still awaiting anyone to comment on these two: 

Access Node Control Protocol (ANCP)
Access Control Protocol (AXCP or ACP) 

Regards,
Woj.

-----Original Message-----
From: Sanjay Wadhwa [mailto:[email-masked]] 
Sent: 27 March 2006 15:19
To: [email-masked]; [email-masked]; Wojciech Dec
(wdec)
Cc: [email-masked]
Subject: RE: L2CP; New Working Group Name

Folks
  I would rather we don't restrict it to link or line (i.e. why rule out
node level dynamic config). I would like to suggest "BACP" : Broadband
Access Control Protocol. 

-Sanjay

---

From: "Nurit Sprecher" <[email-masked]>
Date: Mon, 27 Mar 2006 16:00:11 +0200

I am in favor of the first two options: BALCP or ALCP. It may be that
the BALCP is already a little bit cumbersome.

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]] 
Sent: Monday, March 27, 2006 15:45
To: Sanjay Wadhwa; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: [L2CP] RE: L2CP; New Working Group Name

Regards,
Woj.

-----Original Message-----
From: Sanjay Wadhwa [mailto:[email-masked]] 
Sent: 27 March 2006 15:19
To: [email-masked]; [email-masked]; Wojciech Dec
(wdec)
Cc: [email-masked]

Folks

-Sanjay

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Mon, 27 Mar 2006 09:03:55 -0500

I would prefer ANCP to ALCP. Another option is BAMP (Broadband access
management protocol).

-Sanjay

>Sent: Monday, March 27, 2006 8:45 AM

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 27 Mar 2006 09:21:03 -0500

I would prefer BBACP.
It would be easy to pronounce - Bee Backup...
And it is closer to what it stands for.

/himanshu

> Sent: Monday, March 27, 2006 9:04 AM
> To: Wojciech Dec (wdec); [email-masked];

---

From: "Sandy Ng \(swkeng\)" <[email-masked]>
Date: Mon, 27 Mar 2006 13:29:18 -0800

To not restrict the protocol to the strictly Access technology space, can we consider MLCP : Multi-Layer Control Protocol), noting the overlapping with Morningstar Large Cap Index (:^/).

Thanks,
Sandy

> Sent: Monday, March 27, 2006 5:17 AM
> To: Haag, T; [email-masked]
> Cc: Schott, Roland; Busser,M; [email-masked]; 
> Langhammer,Michael; Witschurke,Birgit; Freudenberger,Markus; 
> Meyer04,Klaus; Weis, W; Hamacher, Peter
>   I would rather we don't restrict it to link or line (i.e. 
> why rule out node level dynamic config). I would like to 
> suggest "BACP" : Broadband Access Control Protocol. 
> 
> -Sanjay
> 
> >Markus; Busser, M; Langhammer, Michael; Hamacher, Peter; Schott, 
> >Roland; Sanjay Wadhwa; [email-masked]; [email-masked]; Weis, W
> >Cc: Witschurke, Birgit; Meyer, Klaus; [email-masked]; Freudenberger, 
> >Markus; Busser, Michael; Langhammer, Michael; Hamacher, 
> Peter; Schott, 
> >Roland; [email-masked]; [email-masked]; 
> [email-masked]; Weis, 
> >Werner
> technologies, so 
> >I think we should not use DSL in the WG name.
> >
> >Therefore it was agreed during previous IETF meeting that 
> the working 
> >group name should be changed.
> >
> >

---

From: "Derek Harkness" <[email-masked]>
Date: Tue, 28 Mar 2006 15:08:29 +0100

Apologies to Sanjay & Thomas but unfortunately BACP is another IETF protocol ( RFC 2125: The PPP Bandwidth Allocation Protocol (BAP) / The PPP Bandwidth Allocation Control Protocol (BACP) ) which may also be used / desired / discussed in a similar context,even tho' it's more applicable in a narrow band / ISDN type scenario.

Given the constraints my amusing acronym generator has been unable to come up with anything else.....

	Apologies,

		Derek.

+=============================+
Derek Harkness
Systems Engineer
Juniper Networks 
Nymphenburger Strasse 13-15
80335 Munich
Germany
Tel: +49 89 5529 4916
Mobile: +49 172 843 6621
Email: [email-masked]
+=============================+ 

-----Original Message-----
From: Haag, T [mailto:[email-masked]] 
Sent: 28 March 2006 15:45
To: [email-masked]
Cc: [email-masked]
Subject: AW: [L2CP] Re: L2CP; New Working Group Name

Summarizing all incomming proposals my view is as follows:

DLLC, BACP, BBACP, BACLP, ALCP, ANCP, AxCP, SLCP, SLiCC, MLCP

Taking two key arguments into account...

- Protocol should not restrict to link or line

- With respect to the charter it should not be limited to access nodes

...only the following options remain: BACP, BBACP, MLCP

BACP or MLCP sounds best. Now it's a matter of choice!

I think BACP fits best to the charter.

Thomas

-----Ursprüngliche Nachricht-----
Von: Mark Townsley [mailto:[email-masked]] 
Gesendet: Dienstag, 28. März 2006 01:14
An: Haag, Thomas
Cc: Busser, Michael; [email-masked]; Langhammer, Michael; Witschurke, Birgit; Freudenberger, Markus; Meyer, Klaus; Weis, Werner; Hamacher, Peter
Betreff: [L2CP] Re: L2CP; New Working Group Name

It's really the access node we are controlling, not the link per se. So, how 
about something along the lines of...

Access Node Control Protocol ANCP ?

- Mark

Haag, T wrote:
> Configuration & Control), ALCC (Access Link Configuration & Control) are 
> already in use.
> 
> ***Regards*
> *Thomas Haag*

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 28 Mar 2006 09:10:45 -0500

I agree. only reason suggesting BBACP was that
BACP is already used to mean b/w allocation control protocol
(rfc 2125) as per an earlier email.

> Sent: Tuesday, March 28, 2006 8:45 AM
> To: [email-masked]
> Cc: [email-masked]
> Cc: Busser, Michael; [email-masked]; Langhammer, Michael; 
> Witschurke, Birgit; Freudenberger, Markus; Meyer, Klaus; 
> Weis, Werner; Hamacher, Peter

---

From: "Jerome Moisand" <[email-masked]>
Date: Tue, 28 Mar 2006 11:04:11 -0500

Agreed with Mark. Also I believe we all would like to rely on an existing protocol (GSMP or else), possibly with extensions, instead of reinventing the wheel.

This is why we tried to remove the "L2CP" acronym from DSL-Forum literature.

Personally, I like the "L2CC" proposal (Layer2 Configuration & Control). It stays close to the terminology we used so far, it doesn't ring like a new protocol to be created, and it maps well to the use cases we have identified while staying general purpose.

I do agree that the DSL scope is too limitative. There are multiple examples of access technologies that could benefit from similar concepts. 

Cheers,
Jerome

-----Original Message-----
From: Mark Townsley [mailto:[email-masked]] 
Sent: Tuesday, March 28, 2006 10:51 AM
To: Haag, T
Cc: [email-masked]
Subject: Re: AW: [L2CP] Re: L2CP; New Working Group Name

> BACP or MLCP sounds best. Now it's a matter of choice!

BACP is a PPP Control Protocol (Bandwidth Allocation Control Protocol), MLCP is 
sometimes used for the PPP Multi-link Control Protocol.

The problem with anything ending in CP is a lot of potential overlap with the 
PPP space.

- Mark

---

From: "Sandy Ng \(swkeng\)" <[email-masked]>
Date: Tue, 28 Mar 2006 09:50:15 -0800

> 
> How about MTCP (Multi-Transport Control Protocol) or ATCP 
> (Any Transport Control Protocol)?
> 

Scratch ATCP as it is AppleTalk's.

One more :

Universal Node Control Protocol (UNCP)

Thanks,
Sandy

> From: Sandy Ng (swkeng) 
> Sent: Tuesday, March 28, 2006 9:31 AM
> To: Mark Townsley (townsley); Haag, T
> Cc: [email-masked]
> Subject: RE: AW: [L2CP] Re: L2CP; New Working Group Name
> 
>  
> 
> > From: Mark Townsley (townsley)
> > Sent: Tuesday, March 28, 2006 7:51 AM
> > To: Haag, T
> > Cc: [email-masked]
> > BACP is a PPP Control Protocol (Bandwidth Allocation Control 
> > Protocol), MLCP is sometimes used for the PPP Multi-link Control 
> > Protocol.
> > 
> > The problem with anything ending in CP is a lot of 
> potential overlap 
> > with the PPP space.
> 
> How about MTCP (Multi-Transport Control Protocol) or ATCP 
> (Any Transport Control Protocol)?
> 
> -Sandy
> 
> 
> 
> > 
> > - Mark
> > 
> > > 
> > Witschurke,
> > > Birgit; Freudenberger, Markus; Meyer, Klaus; Weis, Werner;
> > Hamacher,
> > > Peter
> > > It's really the access node we are controlling, not the
> > link per se. 
> > > So, how about something along the lines of...
> > > 
> > Control)
> > >>are already in use.

---

From: "Sandy Ng \(swkeng\)" <[email-masked]>
Date: Wed, 29 Mar 2006 08:15:58 -0800

> Sent: Wednesday, March 29, 2006 2:18 AM
> To: Sandy Ng (swkeng)
> Cc: Haag, T; [email-masked]
> Sandy Ng (swkeng) wrote:
> >>>- With respect to the charter it should not be limited to
> >>
> >>access nodes
> >>
> Sorry to continue being the harbinger of bad news, but I 

That's alright. Too many toes to step on. :-)

Looks like we are bound to be narrow here.

-Sandy

> would avoid the word "Transport" unless you mean something 
> from the Transport Area in the IETF.
> 
> MTCP in this sense would look very much like some sort of 
> "Multi-TCP" - which this very much is not.
> 
> In fact, the WG which maintains TCP may not be MTCP, but does 
> happen to be TCPM ;-)
> 
> - Mark
> 
> > -Sandy
> > 
> > 
> > 
> > 
> >>- Mark
> >>
> >>

---

From: "Jerome Moisand" <[email-masked]>
Date: Wed, 29 Mar 2006 12:20:45 -0500

Good point, Matthew. 

In the mobile world (3G/etc), they would actually call it a
(network-level) signaling protocol, but then it gets confusing with
application-level signaling. 

I believe control protocol conveys much better what we're trying to do
than "management" or "signaling". Although, as I said, we'd better avoid
inferring that we're defining a brand new protocol. I continue to like
L2CC...  ;-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2006 12:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: AW: [L2CP] Re: L2CP; New Working Group Name

Are people happy with the term "management" in the WG name, as opposed
to"
configuration" or "control"?

Management may have different connotations, in terms of what we are
doing
with the access node.

Regards,

Matthew

|         |           Michel.Platnic@e|
|         |           citele.com      |
|         |           29/03/2006 15:32|
 
>-----------------------------------------------------------------------
--------------------------------------------------------|
  |
|
  |        To:      [email-masked]
|
  |        cc:
|
  |        Subject: RE: AW: [L2CP] Re: L2CP; New Working Group Name
|
 
>-----------------------------------------------------------------------
--------------------------------------------------------|

'BAMP: Broadband Access Management Protocol'        ---    sounds good
to
me as well,
 'GAMP: General Access Management Protocol'           --- I do not like
this name so much, as 'general' is not specific enough :-)

What about APMP  pronounced A.P.M.P  standing for Access Port Management
Protocol? Might be easier to pronounce
(also used for 'Acid Precipitation Mitigation Program' ... sounds nice).

Michel.

             "Andrew G. Malis"
             <andymalis@comcas
             t.net>
To
                                       "Serbest, Yetik"
             29/03/2006 12:29          <[email-masked]>
 
cc
                                       [email-masked]
 
Subject
                                       RE: AW: [L2CP] Re: L2CP; New
                                       Working Group Name

BAMP sounds reasonable to me.

Andy

At 3/28/2006 13:30 -0600, Serbest, Yetik wrote:
>I like both:
>
>- GAMP: General Access Management Protocol
>- BAMP: Broadband Access Management Protocol
>
>Thanks,
>yetik

---

From: "Schott, Roland" <[email-masked]>
Date: Wed, 29 Mar 2006 19:46:15 +0200

Dear all,

many opinions about the naming, but one could also use

Port Configuration & Control Protocol (PCCP) 

other meaning is

Potential Conflict to Co-operation Potential (PCCP)

Triple "C" or CCCP sounds also good in my opinion but 
Connection might be not useful.

Regards 

Roland

-----Ursprüngliche Nachricht-----
Von: Jerome Moisand [mailto:[email-masked]] 
Gesendet: Mittwoch, 29. März 2006 19:21
An: [email-masked]
Betreff: RE: AW: [L2CP] Re: L2CP; New Working Group Name

Good point, Matthew. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2006 12:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: AW: [L2CP] Re: L2CP; New Working Group Name

Regards,

Matthew

 

Michel.

             "Andrew G. Malis"
             <andymalis@comcas
             t.net>
To
                                       "Serbest, Yetik"
 
cc
                                       [email-masked]
 
Subject

Andy

---

From: "Sandy Ng \(swkeng\)" <[email-masked]>
Date: Wed, 29 Mar 2006 10:00:24 -0800

I second that "control" is more suitable.

-Sandy

> Sent: Wednesday, March 29, 2006 9:07 AM
> Are people happy with the term "management" in the WG name, 
> as opposed to"
> Management may have different connotations, in terms of what 
> we are doing with the access node.
> 
> Regards,
> 
> Matthew
> 
> 
> 
> 'BAMP: Broadband Access Management Protocol'        ---    
> sounds good to
> me as well,
> What about APMP  pronounced A.P.M.P  standing for Access Port 
> Management Protocol? Might be easier to pronounce (also used 
> for 'Acid Precipitation Mitigation Program' ... sounds nice).
> 
> Michel.
> 
> 
> 
> 
> 
>              "Andrew G. Malis"
>              <andymalis@comcas
>              t.net>                                           
>           To
>                                        "Serbest, Yetik"

---

From: "Haag, T" <[email-masked]>
Date: Thu, 30 Mar 2006 22:10:27 +0200

Matthew,

I share your view. I'm not happy with the term "management" because it implies we would replace existing SNMP based implementation. But that's not the case for L2CP or whatever we call it is an extensive development to already existing configuration management. 

So keeping "control" would be my preference.

Regards

Thomas

-----Ursprüngliche Nachricht-----
Von: Sandy Ng (swkeng) [mailto:[email-masked]] 
Gesendet: Mittwoch, 29. März 2006 20:00
An: [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: RE: AW: [L2CP] Re: L2CP; New Working Group Name

-Sandy

---

From: Knud Gjørup (AH/LMD) <[email-masked]>
Date: Fri, 31 Mar 2006 16:47:36 +0200

Thomas et al

It seems like most of us agree about:  "A" for Access and "P" for Protocol.
In other words: we have an Action Point (AP)

My personal opinion about "control" versus "management" is that I don't care very much. Those two words have been used and misused for some decades now, and they are mixed up with some other connotations of the same words in our native languages. But I agree that the new-L2CP should not replace existing SNMP based management.

Perhaps we could also agree about not being too specific about the kind of access the new-L2CP will be dealing with. Implying: no Broadband-, no DSL-, no L2-words. This leaves us with the adjectives (to characterize Access): no-adj, common, general, ordinary, normal, universal, shared, joint, customary, simple, humble, modest etc.
This really many possibilities: CACP, CAMP, GACP, GAMP, OACP, OAMP, .... , SACP, SAMP, HACP, HAMP, MACP, MAMP, and many more.

Will someone please propose a procedure for selection of the new-L2CP acronym?

Best regards
Knud
Post scriptum: one of the reasons why I'm in favour of choosing General Access Management Protocol is that gamp alludes to umbrella, and if the new-L2CP becomes a success in the future one of the reasons will be the umbrella aspect of the protocol standard.

> Sent: 30. marts 2006 22:10
> Subject: AW: AW: [L2CP] Re: L2CP; New Working Group Name
> 
> Matthew,
> 
> I share your view. I'm not happy with the term "management" 
> because it implies we would replace existing SNMP based 
> implementation. But that's not the case for L2CP or whatever 
> we call it is an extensive development to already existing 
> configuration management. 
> 
> as opposed 
> > doing with the access node.
> > 
> > Regards,
> > 
> > Matthew
> > 
> > 
> > 
> > Management Protocol? Might be easier to pronounce (also 
> used for 'Acid 
> > Precipitation Mitigation Program' ... sounds nice).
> > 
> > Michel.
> > 
> > 
> > 
> > 
> > 
> >              "Andrew G. Malis"
> >              <andymalis@comcas
> >              t.net>                                           
> >           To
> >                                        "Serbest, Yetik"