Subject: RE: [L2CP] L2C Encapsulation using GSMP RFC3293 Framework

From: "Sandy Ng \(swkeng\)" <[email-masked]>
Date: Wed, 1 Mar 2006 01:00:21 -0800

Thomas,

The need of a separate encapsulation definition can be gauged by today's
existing interop networks. With the exception of a deployment model that
exclusively runs only ATM, IP has lent itself a very workable layer
living on top of most layer 2 networks; the former case is usually not a
constraint in most telecom space today, maintaining protocol
transparency from lower layer adaptation is always the preference.

Thanks,
Sandy

> -----Original Message-----
> From: Haag, T [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 8:20 AM
> To: [email-masked]
> Cc: Busser, M; Meyer04,Klaus
> Subject: [L2CP] L2C Encapsulation using GSMP RFC3293 Framework 
> 
> All,
> 
> Running Layer 2 Control in ATM and Ethernet based networks 
> should base on common requirements like RFC3293.
> 
> The document talks about three different types of 
> encapsulation which have different draw backs.
> 
>  - GSMP Packet Encapsulation for ATM (section 2)
> 
>    VPI=0/VCI=15; preferred value would be VPI=254; VCI=32...
>    No MAC address needed
> 
> - GSMP Packet Encapsulation for Ethernet (section 3)
>   MAC Address needed
> 
> - GSMP Packet Encapsulation for TCP (section 4)
>   No MAC Address needed; But additional IPsec for security 
> 
> 
> To be consistent by operating parallel ATM and Ethernet in 
> networks the encapsulation should be done similar for all Types.
> 
> I think it should be investigated to run GSMP packets over 
> bridged encapsulation via ATM according RFC2684 using MAC 
> addresses for detection of Layer 2 Control sender instance, 
> and receiver instance. This would enable to run GSMP Ethernet 
> Packet Encapsulation on Top of ATM using the same sender and 
> receiver assignment.
> 
> 
> Regards
> 
> Thomas Haag
> 
> 

_______________________________________________
L2cp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2cp

---

From: [email-masked]
Date: Wed, 1 Mar 2006 11:42:31 +0100

Sandy,
I fully agree with you there:  right, we may transport GSMP on anything we 
want, but I fail to see why we 
should *not* use IP underneath in practice...

Kind regards,
Robert

"Sandy Ng \(swkeng\)" <[email-masked]>
03/01/2006 10:00 AM
 
        To:     "Haag, T" <[email-masked]>, <[email-masked]>
        cc:     "Busser, M" <[email-masked]>, "Meyer04, 
Klaus" <[email-masked]>
        Subject:        RE: [L2CP] L2C Encapsulation using GSMP RFC3293 
Framework

Thomas,

Thanks,
Sandy