Subject: [L2CP] On Partitioning

From: "Sandy Ng" <[email-masked]>
Date: Wed, 1 Mar 2006 12:46:34 -0800

Hi all,

I recall some discussions on partitions earlier on but do not recall any
solidifications.

Here are some questions/topics/thoughts we should ponder as we go forward:

1) How do we see partitions being deployed? 
   With respect to DSL tech type, how are the switch partitions segmented, by
range of ports/VCs? By subnets?

   Consider:
   - 1 partition : 1 controller
   - 1 partition : multiple controllers (redundant controller case, or others)
   
   In a protocol operation sense, we may want to consider the full matrix, as we
need to adapt L2CP in other Tech Types in an extensible way.

2) As partition ID is an 8-bit field open for definition, as mentioned in 3292,
do we want to add subdivisions within the field to add flexible definitions? 
   Do we see the need for 255 partitions?

3) I see the crux of partition descriptions in section 13.3 and 13.5, 3292. I
would still have questions on : 

a) What additional housekeeping we would need to interact between switch
partitions and controllers?
b) Do we need to maintain knowledge of other controllers who are neighbors with
the same partition?

We can start our conversation on this.

Thanks,
Sandy

_______________________________________________
L2cp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2cp

---

From: [email-masked]
Date: Fri, 03 Mar 2006 14:55:38 +0100

Hi Sandy,

>    - 1 partition : multiple controllers (redundant controller case, or others)

IMHO, one of the basic questions that need to be answered
is whether we want to limit the architecture to a single
edge or not.  If we also target to apply layer 2 control
in a multiple-edge architecture where the two edges even
may belong to different service providers, the whole
concept may become far more complicated.

Despite these facts, I personally believe that a single
edge architecture introduces a heavy limitation on the
concept and that the multi-edge alternative is worth
investigation.

A multi-edge architecture could be realized by allowing
two VC's/VLAN's on the same DSL line to belong to two
different partitions or by allowing a single partition
to be controlled by multiple BNGs.

 From the drafts that are available so far, I conclude
that there is an implicit consensus that a multi-edge
architecture is out of the scope of the upcoming
working group.  So, is this indeed the clear, overall
consensus or is this point still open for debate?

By the way, even if we agree on the basic paradigms of
a single edge, a one-partition-one-controller and a
one-DSL-port-one-partition approach, active-standby
redundancy could still be guaranteed e.g. if the two
BNG's run VRRP or something similar, right?

Any opinions?

> We can start our conversation on this.

Patrick.

---

From: [email-masked]
Date: Fri, 3 Mar 2006 16:08:47 +0100

Patrick MENSCH wrote

> to be controlled by multiple BNGs.

I have two questions here:

1) If (?) we assume that one partition is associated with one GSMP 
session, how could a single partition be controlled by multiple
BNGs ?

2) I don't see how a DSL line could be associated to several BNGs when 
dealing with L2CP: if the physical rate of a DSL line would be reported 
to several BNGs (for topology discovery) how would each BNG use this 
line rate value to control its own shaper to the DSLAM ?

Or am I missing smthg ?

Thanks
Robert