Subject: [L2sm] draft-ietf-l2sm-l2vpn-service-model

From: Ashish Mittal <[email-masked]>
Date: Mon, 8 Jan 2018 07:31:31 +0000

Hello,

The way contains are organized in this service model will cause problems for software implementation.

To identify Sites associated with a service, implementation shall iterate all the sites list. Also VPLS kind of services when orchestrator is sending service creation request to SDN Controller Application, then when shall application assume that all Sites have been received.

A slightly modified organization shall help getting rid of above problems. Please suggest.

Current Organization of Yang:

container l2vpn-svc {
container vpn-profiles {
uses vpn-profile-cfg;
}
container vpn-services {
list vpn-svc {
key "vpn-id";
leaf vpn-id {
type svc-id;
description
"Defining a service id.";
}
leaf vpn-svc-type {
type identityref {
base service-type;
}
description
"Service type";
}
leaf customer-name {
type string;
description
"Customer name";
}
leaf svc-topo {
type identityref {
base vpn-topology;
}
....
}
}

container sites {
list site {
key "site-id site-type";
leaf site-id {
type string;
description
"Site id";
}
...
}
}
}

Proposed Organization of Yang:

container l2vpn-svcs
{
               list l2vpn-svc
               {
key "vpn-id";
leaf vpn-id {
type svc-id;
description
"Defining a service id.";
}
               container vpn-services {
               leaf vpn-svc-type {
type identityref {
base service-type;
}
description
"Service type";
}
leaf customer-name {
type string;
description
"Customer name";
}
leaf svc-topo {
type identityref {
base vpn-topology;
}
....
               }
               container sites
               {
list site {
key "site-id site-type";
leaf site-id {
type string;
description
"Site id";
}
...
}
               }
}

Regards

Ashish Mittal

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 11 Jan 2018 16:26:37 +0000

Hi Ashish,
(I'm resending my answer in order to involve in the discussion the whole L2SM WG)
Thanks for your comments!
I understand your point and I will consider it. We are working on a new revision.
Regarding sites and services identification, our intent is to model L2SM in the same way as L3SM, in order to have a common structure for L2SM/L3SM.

Best Regards,

Giuseppe

Da: L2sm [mailto:[email-masked]] Per conto di Ashish Mittal
Inviato: lunedì 8 gennaio 2018 08:32
A: [email-masked]
Oggetto: [L2sm] draft-ietf-l2sm-l2vpn-service-model

Hello,

container l2vpn-svc {
container vpn-profiles {
uses vpn-profile-cfg;
}
container vpn-services {
list vpn-svc {
key "vpn-id";
leaf vpn-id {
type svc-id;
description

container sites {
list site {
key "site-id site-type";
leaf site-id {
type string;
description
"Site id";
}
...
}
}
}

container l2vpn-svcs
{
               list l2vpn-svc
               {
key "vpn-id";
leaf vpn-id {
type svc-id;
description

Regards

Ashish Mittal

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.