Subject: PPPoE Framing Type

From: "Luigi Campora" <[email-masked]>
Date: Mon, 12 Jun 2000 17:48:12 +0200

Dear subscribers,
I have a doubt concerning PPP Framing when PPPoE sessions
have to be multiplexed over a L2TP tunnel.

Suppose my LAC is also a PPPoE server: then it receives PPP
packets having the PPPoE framing, i.e., no address/control field
is inserted by the PPPoE client.
Bearer type AVP is not mandatory, thus there is no way of
informing the LNS about this framing
(Framing Type AVP can't help, because PPPoE framing is
neither synchronous nor asynchronous in my opinion...).

Do I have to insert address and control before sending PPP
packets through the L2TP tunnel?
In other words, do I have to provide some PPP bridging
functionality at the LAC?

Regards.

Luigi

----------------------------------------------------------
Luigi Campora

     Phone:      +39 10 600 2511
     Facsimile:  +39 10 600 3849
     E-mail:     [email-masked]

     MARCONI COMMUNICATIONS
     Access Networks Division
     Via A. Negrone 1A -  16153 Genova (Italy)

---

From: James Carlson <[email-masked]>
Date: Tue, 13 Jun 2000 07:30:15 -0400 (EDT)

> is inserted by the PPPoE client.

Right.

> neither synchronous nor asynchronous in my opinion...).

Yes, unless you invent a new Framing Type just for "real PPP without
the HDLC headers."  (In my opinion, that's how L2TP should have been
done in the first place.  Then it would have been compatible with the
other encapsulations, like RFC 1598 and RFC 1973.  Oh well.)

> functionality at the LAC?

Yes.  The HDLC headers are (rather unexpectedly) necessary for PPP
data on L2TP.

-- 
James Carlson, Internet Engineering       <[email-masked]>
SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp