Subject: ZLB Ack question

From: Vipin Jain <[email-masked]>
Date: Mon, 23 Oct 2000 15:40:47 -0700

LAC  ---- seq #1 --> *LOST*       LNS
LAC  ----- seq #2 --------------> LNS
LAC  ------ seq #3 -------------> LNS
LAC  ------ seq #4 -------------> LNS
LAC  <------ seq #33 ------------- LNS

Should LAC ZLB Ack LNS seq#33?
If so what should be Ns in ZLB Ack?
Or should LAC retransmit seq #1 to LNS acking seq#33?

**** LAC Actually times out on seq #1 here ***

Thanks for any insights.
-- vipin

---

From: Motonori Shindo <[email-masked]>
Date: Tue, 24 Oct 2000 12:43:03 +0900 (JST)

Vipin,

From: Vipin Jain <[email-masked]>
Subject: ZLB Ack question
Date: Mon, 23 Oct 2000 15:40:47 -0700

> Should LAC ZLB Ack LNS seq#33?

Yes, it should Ack it. However, it doesn't have to be ZLB. It could
also be any control message, assuming there is still an open window
for this control channel.

> If so what should be Ns in ZLB Ack?

Ns should be 5. 

> Or should LAC retransmit seq #1 to LNS acking seq#33?

LAC may retransmit seq #1 if the timer expires associated with
it. This retransmission could also act as an Ack for seq #33 message.
Please be aware that Ns of retransmitted packet must remains the same
but Nr must be updated, reflecting the most up-to-date Nr value.

Whether the acknowledge for seq#33 (by sending a message with Nr=34)
is done by sending a ZLB or a retransmission of seq#1 is up to the
implementation and often a timing issue.

Regards,

> **** LAC Actually times out on seq #1 here ***

=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
 +----+----+     
 |.. .|    |     Motonori Shindo
 |_~__|    |     
 | .. |~~_~|     Sr. Systems Engineer
 | .  |    |     CoSine Communications Inc.
 +----+----+     
 C o S i n e     e-mail:  [email-masked] 
Communications
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=