Subject: RE: SLI from LNS to LAC ...

From: "Umesh Sirsiwal" <[email-masked]>
Date: Wed, 16 May 2001 12:45:16 -0400

David,

We already have draft in L2TP working group which allows
LAC/LNS DSCP negotiation. We also have draft for header
compression. I am not proposing any new AVP. I am proposing
capability to change already negotiated AVP if conditions
change on ends. I do agree that there is no new attributes
needed for IPSec.

With respect to redundant router protocol, as you said 
redundant routing protocol has its own issues and there
is a merit in transferring L2TP tunnels to another
router in a controlled basis. 

I am not proposing any NEW violation of layering principles
just capability to modify existing AVP even after tunnel is
established...

-Umesh

-----Original Message-----
From: Chen, David [mailto:[email-masked]]
Sent: Wednesday, May 16, 2001 12:30 PM
To: Umesh Sirsiwal; [email-masked]
Subject: RE: SLI from LNS to LAC ...

With the spirit of modifying L2tp attributes,
the IPSec's SA does not present in the "l2tp attributes",
So is "QoS".

Each of the topic (Sec, QoS) is another set of IP service protocols.
What the degree you suggest to let L2tp involved.

Also, the reliable connection can be solved in several level
from physical layer to IP layer or above.

If you implement Redudant Routing Protocol (which still having issues)
to keep the same IP among several different LNS...

--- David

-----Original Message-----
From: Umesh Sirsiwal [mailto:[email-masked]]
Sent: Wednesday, May 16, 2001 12:02 PM
To: [email-masked]
Subject: FW: SLI from LNS to LAC ...

Chen, Elwin, Mark, et.al.
I do agree that we must "try to" preserve common
networking stack. draft-ietf-l2tpext-ds-03.txt,
and draft-ietf-l2tpext-security-02.txt adress 
some of the functionality needed for IPSec and DiffServ.

However, I agree with Elwin in spirit. We need
a way of modifying tunnel attributes without 
tearing down tunnel. For example draft-ietf-l2tpext-ds-03.txt
addresses issues with respect to DSCP used.
However, the DSCP usage may change because of
administrative policies on LNS end and it must
inform LAC about it. Similar arguments can be
made regarding draft-ietf-l2tpext-l2tphc-03.txt.
This can also be used for controlled de-commissioning
of LNS, in case LNS is capable of sharing state 
information with another LNS.

Current form of L2TP addresses issues with respect
to tunnel establishment and teardown. However,
it does not really adress issues with respect to
change in attributes of an existing tunnel.

-Umesh

-----Original Message-----
From: Chen, David [mailto:[email-masked]]
Sent: Wednesday, May 16, 2001 9:53 AM
To: 'Elwin Eliazer'; W. Mark Townsley
Cc: [email-masked]
Subject: RE: SLI from LNS to LAC ...

Elwin,

The layered network structure has been used for long time.
It will be very difficult for "networking" if
the comm stack collapsed.

I don't think L2tp knows DH key exchange (may not be a bad idea)
or PPP's ACCM or RSVP, RTP signaling ... who knows what's the payload in
IP... :-)

--- David

-----Original Message-----
From: Elwin Eliazer [mailto:[email-masked]]
Sent: Tuesday, May 15, 2001 11:42 PM
To: W. Mark Townsley
Cc: [email-masked]
Subject: Re: SLI from LNS to LAC ...

Mark,

The cases when LNS needs to inform LAC after
authentication phase some characteristics that
are based on user, will need additional messages.
One such requirement is the conveying the user
based IP service information to LAC, so that LAC
can take appropriate actions, like QOS and IPSec. 

Another requirement is: MLPPP can be turned on
or off by LNS based on authentication information;
which cannot be sent to LAC as of now.

Acknowledgments to these may be needed for some
cases from LAC to LNS.

regards,
Elwin.

--- "W. Mark Townsley" <[email-masked]> wrote:
> 
> WEN is currently the only "after session
> establishment" message defined
> for receipt by an LNS. New messages are not
> difficult to create though.
> What type of information would you like to signal?
> 
> - Mark
> 
> Elwin Eliazer wrote:
> > 
> > Hi,
> > 
> > Are there any standard way of changing the
> > characteristics of a L2TP tunnel/session
> > after the tunnel/session setup is complete?
> > 
> > SetLinkInfo (SLI) PDU defined in RFC 2661,
> > section 6.4 can only be used by LNS to
> > inform LAC. Are there any methods like that
> > from LAC to LNS?
> > 
> > Your response would be appreciated.
> > 
> > regards,
> > Elwin.
> > 
> > =====
> > -------
> > Elwin Stelzer Eliazer
> > Corona Networks
> > San Jose, CA
> > 408-519-3832
> > -------
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Yahoo! Auctions - buy the things you want at great
> prices
> > http://auctions.yahoo.com/

=====
-------
Elwin Stelzer Eliazer
Corona Networks
San Jose, CA
408-519-3832
-------

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 16 May 2001 13:17:20 -0400

There is nothing wrong with sending a message after tunnel/session
setup, just define the message type in a draft. There is certainly
precedence for sending a message after tunnel/session establishment. SLI
and WEN both work in this manner.

- Mark