Subject: RE: I-D ACTION:draft-elwin-l2tpext-ppvpn-00.txt

From: "Reinaldo Penno" <[email-masked]>
Date: Tue, 20 Nov 2001 18:02:16 -0800

This draft won't be standardize through this WG, so what we can say is
"okay, you didn't turned L2TP around, so please move to the PPVPN WG now".

And the use of L2TP for the purpose stated in the draft clearly belongs to
PPVPN. There are also GRE, IPSec and MPLS used as tunneling mechanims. All
their pros and cons are discussed on the PPVPN WG.

regards,

-RP 

> -----Original Message-----
> From: Ignacio Goyret [mailto:[email-masked]]
> Sent: Tuesday, November 20, 2001 2:12 PM
> To: Penno, Reinaldo [SC9:T327:EXCH]
> Cc: [email-masked]'
> Subject: RE: I-D ACTION:draft-elwin-l2tpext-ppvpn-00.txt
> 
> 
> The use of L2TP and the discussion of any use/abuse 
> definitely belongs on this WG.
> The discussion on the applicability of the draft to PPVPN 
> belongs on that other WG.
> 
> 
> At 01:26 PM 11/20/01 -0800, Reinaldo Penno wrote: 
> >>>>
> 
> Hello, 
> 
> before any comments, I wonder if this draft belongs here. I 
> would say it belongs in the PPVPN WG. What you are proposing 
> is a new membership, topology discovery and tunnel protocol for VPNs. 
> 
> There are already several out there, and they all go through 
> the PPVPN WG. We have the "de facto" standard of BGP 
> membership and discovery 
> (<http://www.ietf.org/internet-drafts/draft-ietf-ppvpn-bgpvpn-
> auto-00.txt>http://www.ietf.org/internet-drafts/draft-ietf-ppv
> pn-bgpvpn-auto-00.txt) and the new one based on directory 
> services like LDAP and/or DNS. 
> 
> The BGP discovery does not go through the IDR WG, and the 
> directory discovery does not go through the LDAP WG, all go 
> through the PPVPN WG.
> 
> regards, 
> 
> Reinaldo 
> 
> > -----Original Message----- 
> > From: [email-masked] 
> [<mailto:[email-masked]>mailto:[email-masked]] 
> > Sent: Tuesday, November 20, 2001 4:13 AM 
> > To: IETF-Announce 
> > Cc: [email-masked] 
> > Subject: I-D ACTION:draft-elwin-l2tpext-ppvpn-00.txt 
> >  
> >  
> > A New Internet-Draft is available from the on-line  
> > Internet-Drafts directories. 
> >  
> >  
> >       Title           : L2TP Extensions for PPVPN 
> >       Author(s)       : E. Stelzer, N. Gowda 
> >       Filename        : draft-elwin-l2tpext-ppvpn-00.txt 
> >       Pages           : 8 
> >       Date            : 19-Nov-01 
> >        
> > Provider Provisioned  VPNs (PPVPNs)  need  a  tunneling   
> > mechanism and a 
> > means to automatically discover VPN membership and signal  
> > these tunnels. 
> > This draft  elaborates the use of  L2TP as the  tunneling  
> > mechanism, and 
> > defines  extensions  to  L2TP  to  handle  VPN  membership   
> > discovery to 
> > leverage  PPVPNs.  Additional AVPs  are defined, and their  
> > behaviour are 
> > explained.  The solution presented here  is applicable  for  
> > both L3 VPNs 
> > and L2 VPNs. 
> >  
> > A URL for this Internet-Draft is: 
> > 
> <http://www.ietf.org/internet-drafts/draft-elwin-l2tpext-ppvpn
> -00.txt>http://www.ietf.org/internet-drafts/draft-elwin-l2tpex
> t-ppvpn-00.txt 
> >  
> > To remove yourself from the IETF Announcement list, send a 
> message to  
> > ietf-announce-request with the word unsubscribe in the body  
> > of the message. 
> >  
> > Internet-Drafts are also available by anonymous FTP. Login  
> > with the username 
> > "anonymous" and a password of your e-mail address. After 
> logging in, 
> > type "cd internet-drafts" and then 
> >       "get draft-elwin-l2tpext-ppvpn-00.txt". 
> >  
> > A list of Internet-Drafts directories can be found in 
> > <http://www.ietf.org/shadow.html>http://www.ietf.org/shadow.html  
> > or 
> <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>ftp://ftp.ietf.org/
ietf/1shadow-sites.txt 
>  
>  
> Internet-Drafts can also be obtained by e-mail. 
>  
> Send a message to: 
>       [email-masked]. 
> In the body type: 
>       "FILE /internet-drafts/draft-elwin-l2tpext-ppvpn-00.txt". 
>        
> NOTE: The mail server at ietf.org can return the document in 
>       MIME-encoded form by using the "mpack" utility.  To use this 
>       feature, insert the command "ENCODING mime" before the "FILE" 
>       command.  To decode the response(s), you will need "munpack" or 
>       a MIME-compliant mail reader.  Different MIME-compliant  
> mail readers 
>       exhibit different behavior, especially when dealing with 
>       "multipart" MIME messages (i.e. documents which have been split 
>       up into multiple messages), so check your local documentation on 
>       how to manipulate these messages. 
>                
>                
> Below is the data which will enable a MIME compliant mail reader 
> implementation to automatically retrieve the ASCII version of the 
> Internet-Draft. 
>  

<<<<

---

From: Elwin Eliazer <[email-masked]>
Date: Tue, 20 Nov 2001 19:33:58 -0800 (PST)

Hey Reinaldo!

Did you ever read the L2TPext WG charter?
Or the PPVPN WG charter?

The charter as it stands today in both the WGs are as
follows:

PPVPN WG:
   "....Note that it is not a goal of this WG to
develop new protocols or extend existing ones. ..."

L2TPext WG:
   "This group is responsible for extensions to the
Layer 2 Tunneling Protocol. Examples of L2TP
"extensions" include any changes to the L2TP
encapsulation, control messages, or new AVPs sent in
IETF standard control messages. "

This draft provides a solution for PPVPN, at the same
time extends L2TP, by adding AVPs. Thus there appears
some overlap on where it goes -- whether the L2TPext
WG or PPVPN WG. However i think it is the L2TPext WGs
decision and not that of one person to resolve and
conclude, even if there is any conflict here.

I would like to hear feedback from the WG members on
this.

regards,
Elwin.

--- Reinaldo Penno <[email-masked]>
> >       "FILE
> /internet-drafts/draft-elwin-l2tpext-ppvpn-00.txt". 
> >        

=====
-------
Elwin Stelzer Eliazer
Corona Networks
-------

__________________________________________________
Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1