Subject: RE: I-D ACTION:draft-elwin-l2tpext-ppvpn-00.txt

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 21 Nov 2001 11:42:58 -0800

> -----Original Message-----
> From: Elwin Eliazer [mailto:[email-masked]]
> Sent: Tuesday, November 20, 2001 7:34 PM
> To: Penno, Reinaldo [SC9:T327:EXCH]; 'Ignacio Goyret'
> Cc: [email-masked]'
> Subject: RE: I-D ACTION:draft-elwin-l2tpext-ppvpn-00.txt
> 
> 
> Hey Reinaldo!
> 
> Did you ever read the L2TPext WG charter?
> Or the PPVPN WG charter?
> 
> The charter as it stands today in both the WGs are as
> follows:
> 
> PPVPN WG:
>    "....Note that it is not a goal of this WG to
> develop new protocols or extend existing ones. ..."
> 
> L2TPext WG:
>    "This group is responsible for extensions to the
> Layer 2 Tunneling Protocol. Examples of L2TP
> "extensions" include any changes to the L2TP
> encapsulation, control messages, or new AVPs sent in
> IETF standard control messages. "
> 
> This draft provides a solution for PPVPN, at the same
> time extends L2TP, by adding AVPs. Thus there appears
> some overlap on where it goes -- whether the L2TPext
> WG or PPVPN WG. However i think it is the L2TPext WGs
> decision and not that of one person to resolve and
> conclude, even if there is any conflict here.

Sure it is not my say so. But since unfortunately you managed to bundle in
your draft a extension to L2TP and also a PPVPN scenario you do belong in
either group. My suggestion to you is do what was done for BGP-4. Write a
separate draft just with the L2TP extension and another one with it's
applicability for PPVPN.

The first one would be discussed here and the other one in the PPVPN WG.

regards,

-RP

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 21 Nov 2001 14:55:19 -0500

> Reinaldo Penno wrote:

That sounds like a reasonable approach. For the moment, it is still an
individual submission so is a bit of a moot point. However, certainly if either
WG accepts this doc, we should work out where what work should be done. The
PPVPN chairs should be part of that decision as well. Typically, I am inclined
to have any L2TP extension portion of a document done here, unless the
extensions are absolutely trival.

Thanks,

- Mark