Subject: RE: [L2tpext] Comments on draft-vipin-l2tpext-failover-01.txt

From: "Reinaldo Penno"<[email-masked]>
Date: Thu, 28 Feb 2002 08:26:22 -0800

>> >> hum...I might be wrong but I tought we discussed this many
>> >moons ago...I
>> >> thought that including the same AVPs wasn't mandatory. If
>> >when you try to
>> >> recover you (do not) include some AVPs it's a admin
>> >decision. Maybe you
>> >> changed some configuration in the meantime.
>> >
>> >I don't remember the outcome of our discussion many moons ago.
>> >
>> >But, as far as what I am thinking today, my only fear in
>> >allowing this is that
>> >there might be some session specific state that is defined at
>> >the tunnel
>> >initiation level that might not get updated when the new
>> >tunnel comes up and
>> >takes over all of the sessions from the old tunnel. It just
>> >seemed simpler to
>> >say that the new tunnel has to be the same as the old tunnel.
>> 
>> I agree, I wasn't just pointing out it shouldn't be a MUST 
>on draft, but a
>> SHOULD with a comment saying that if the AVPs change the 
>tunnel might not be
>> recovered.
>
>The latter is almost a MUST, in which case I lean more to 
>making it a MUST.
>MUSTs are good for interoperability, SHOULDs and MAYs are not. 
>If its just a
>SHOULD, then it could work with some vendors, and not with 
>others. That's never
>fun.

It think there will be no interoperability problems Mark. 

-All vendors MUST be able to recover tunnels if the AVPs are the same,
period. This is the baseline request.

- If we have different AVPs the tunnel might or not be recovered. This is a
SHOULD.

waht do you think?

-Reinaldo

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 28 Feb 2002 18:15:03 +0100

> Reinaldo Penno wrote:
> -All vendors MUST be able to recover tunnels if the AVPs are the same, period.
> This is the baseline request.
> 

I think the best choice for interoperability is to state that the same AVPs MUST
be present the new tunnel as the old when sending SCCxx messages.

When receiving new messages, they SHOULD have the same AVPs as the old tunnel in
order to continue with tunnel setup.

This is this the basic premise of being strict in what one sends, and liberal in
what is accepted.

If you make both SHOULDs you could end up in a non-interoperable situation where
it is not clear which side of the exchange is at fault with regards to the RFC. 

> -Reinaldo

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext