Subject: RE: [L2tpext] draft-galtzur-l2tpext-tdm-00.txt as a WG document?

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 14 Sep 2004 19:02:52 +0200

Stewart and all,
Please see a brief comment inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Tuesday, September 14, 2004 10:25 AM
> To: Sasha Vainshtein
> Cc: W. Mark Townsley; [email-masked]; Sharon Galtzur; Alik 
> Shimelmits
> Subject: Re: [L2tpext] draft-galtzur-l2tpext-tdm-00.txt as a 
> WG document?
> 
> 
> 
> 
> Sasha Vainshtein wrote:
> 
> >Stewart,
> >The data plane is described in the appropriate PWE3 drafts
> >(draft-ietf-pwe3-satop-01.txt and draft-ietf-pwe3-cesopsn-01.txt).
> >
> >  
> >
> I did not see text that specified whether of not to use L2TP
> sequence numbers
[Sasha] <quote from draft-galtzur (two last para in Section 2)>
   TDM pseudowires use their own control word.  Therefore the L2-
   Specific Sublayer AVP MUST either be omitted or  set to zero. 
    
   TDM pseudowires use their own sequencing.  Therefore the Data 
   Sequencing AVP MUST either be omitted or  set to zero. 
<end quote>.

Is this not sufficient?

> or express a view on whether to run in IP or UDP mode.
>
[Sasha] This depends on your L2TPv3 implementation. IMHO, draft-galtzur is
invariant to that. And, to the best of my knowledge, this is exactly how the
rest of PW-related L2TPEXT drafts are specified. Do I miss something?
> - Stewart

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 14 Sep 2004 13:14:26 -0400

>    Specific Sublayer AVP MUST either be omitted or  set to zero. 

Perhaps you should go ahead and mandate that the Sublayer not be present (which 
is signaled via the standard method in l2tpv3).

> rest of PW-related L2TPEXT drafts are specified. Do I miss something?

Yes, in general, L2TPv3 over IP is a MUST implement, and UDP is a SHOULD. The 
primary rationale for UDP mode is to be NAT friendly (as opposed to TDM over 
UDP/IP which uses UDP in a very NAT unfriendly manner).

- Mark

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 14 Sep 2004 19:58:55 +0100

>   Sequencing AVP MUST either be omitted or  set to zero. 
Yes, I missed that.

>rest of PW-related L2TPEXT drafts are specified. Do I miss something?

No, the text looks sufficient.

- Stewart