Subject: RE: [L2tpext] Re: Local CE IP Address AVP

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 4 May 2005 12:19:45 +0200

Carlos and all,
Please see a brief comment inline.
CC'ing also the PWE3 WG
I have snipped the parts that are not relevant to this comment.

Regards,
			Sasha Vainshtein
e-mail:		[email-masked]
phone:		+972-3-7659993 (office)
mobile:		+972-52-8674833

> -----Original Message-----
> From: Carlos Pignataro [mailto:[email-masked]]
> Sent: Saturday, April 30, 2005 9:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [L2tpext] Re: Local CE IP Address AVP
> 
... snipped ...
> > 
> > 
> >>For example, a PW Type for IP-L2
> >>Transport is not yet defined (in any draft and thus not
> > 
> > allocated),
> > 
> > I thought that IP L2 transport had been allocated the PW type
> > 0x000B, hadn't it??
> > 
> 
> No. The link below Section 2. (or 2.1. in version -09) references the
> LDP (FEC128/129) "Pseudowire Type", which is a 15-bit quantity (1 bit
> used in the FEC Element for Control-word).
>    IANA needs to set up a registry of "Pseudowire Type".  
> These are 15-
>    bit values.
> 
> In contrast, "L2TPv3 Pseudowire Types" uses a different 
> number space or
> registry created as part of RFC3931 (see Section 10.6) for 
> these 16-bit
> quantities:
>    The Pseudowire Type (PW Type, see Section 5.4) is a 2-octet value
>    used in the Pseudowire Type AVP and Pseudowire 
> Capabilities List AVP
> 
> See also the registry "L2TPv3 Pseudowire Types" in
> http://www.iana.org/assignments/l2tp-parameters
> 
> Regards,
> 
> --Carlos.
[Sasha] What are the reasons for keeping two different 
name spaces for the same set of objects (PW Types)? 
Just the different description of the format (2 octets
vs. 15-bit)? IMO it just adds unnecessary complexity.

E.g., consider the case of multi-segment PWs where
L2TPv3 segments must be stitched to MPLS segments with
the appropriate interworking of both data path and the control plane... 

The fact that no L2TP PW values have been allocated yet (I've checked
the registry before writing this email!) speaks for itself.

... snipped to the end ...

... snipped to the end ...

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: Carlos Pignataro <[email-masked]>
Date: Wed, 04 May 2005 09:38:04 -0400

Sasha,

Please see a couple of comments inline.

> vs. 15-bit)? IMO it just adds unnecessary complexity.

They are arguably two different sets of objects. RFC3931 defines the
"L2TPv3 Pseudowire Type" (Section 10.6) as "a 2-octet value used in the
Pseudowire Type AVP and Pseudowire Capabilities List AVP"; OTOH,
although the reference [1] is missing in
draft-ietf-pwe3-iana-allocation-09, it defines "Pseudowire Type" values
to be used with draft-ietf-pwe3-control-protocol.
The two spaces have different allocation policy as well.
Why is it this way? I suppose the reasons are mostly historical, and
while it may add complexity, it also keeps separation and adds flexibility.

> the appropriate interworking of both data path and the control plane... 

In this case, the IWF should also contemplate the "L2TPv3 Pseudowire
Type" <-> "Pseudowire Type" mapping, as another object to interwork.

> the registry before writing this email!) speaks for itself.

RFC3931 defines the number space but not the values. From RFC3931:
      Defined PW types that may appear in this list are managed by IANA
      and will appear in associated pseudowire-specific documents for
      each PW type.
...
   There are no specific pseudowire types
   assigned within this document.  Each pseudowire-specific document
   must allocate its own PW types from IANA as necessary.

And values are suggested in the respective companion documents:
draft-ietf-l2tpext-pwe3-fr-05.txt
draft-ietf-l2tpext-pwe3-hdlc-05.txt
draft-ietf-l2tpext-pwe3-ethernet-03.txt
draft-ietf-l2tpext-pwe3-atm-03.txt
draft-ieft-l2tpext-tdm-00.txt

The allocation of suggested values for "L2TPv3 Pseudowire Type"
(included in those documents) was requested from IANA months ago. The
fact the values do not appear in the registry may be just saying that
there is a slow response from IANA.

Best Regards,

--Carlos.

> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

-- 
--Carlos.
Escalation RTP - cisco Systems