Subject: [L2tpext] FW: New Version Notification for draft-ietf-l2tpext-keyed-v6-tunnel-yang-02.txt

From: <[email-masked]>
Date: Fri, 28 Oct 2016 08:40:22 +0000

Hi,

We’ve just submitted a new version of this draft. This is a small update which cleans up some outstanding items:

• Updated the YANG model to YANG 1.1 (the model content and structure was already compliant, so this only required addition of the ‘yang-version 1.1’ statement
• Small language cleanup
• Completion of the IANA Considerations section

The model has been checked against yangvalidator.com and reports ‘No warning or errors’.

The authors believe that this draft is now ready and would like to request WGLC.

Thanks,
Ian

On 28/10/16 10:32, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-ietf-l2tpext-keyed-v6-tunnel-yang-02.txt
    has been successfully submitted by Ian Farrer and posted to the
    IETF repository.
    
    Name:		draft-ietf-l2tpext-keyed-v6-tunnel-yang
    Revision:	02
    Title:		A YANG Data Model for Keyed IPv6 Tunnels
    Document date:	2016-10-28
    Group:		l2tpext
    Pages:		14
    URL:            https://www.ietf.org/internet-drafts/draft-ietf-l2tpext-keyed-v6-tunnel-yang-02.txt
    Status:         https://datatracker.ietf.org/doc/draft-ietf-l2tpext-keyed-v6-tunnel-yang/
    Htmlized:       https://tools.ietf.org/html/draft-ietf-l2tpext-keyed-v6-tunnel-yang-02
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-l2tpext-keyed-v6-tunnel-yang-02
    
    Abstract:
       This document defines a YANG data model for the configuration and
       management of Keyed IPv6 tunnels.  The data model includes both
       configuration and state data.  Due to the stateless nature of keyed
       IPv6 tunnels, a model for NETCONF notifications is not necessary.

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 28 Oct 2016 13:36:17 +0000

Thank you, Ian, for this update.

Looking at the L2tpext list, there has not been significant discussion of this document — before a last-call, it may seem we need a first-call :-)

WG,

I would encourage you to read this document and comment on the list.

Authors,

I was just wondering — wouldn’t we need an L2tp YANG model, before a Keyed-v6-tunnel one?

Thanks!

— Carlos.

> On Oct 28, 2016, at 4:40 AM, [email-masked] wrote:
> 
> Hi,
> 
> _______________________________________________
> L2tpext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l2tpext

---

From: Giles Heron <[email-masked]>
Date: Fri, 28 Oct 2016 17:10:26 +0100

Hi Carlos,

not sure if we need a “generic” L2TP YANG model.   Existing L2TP deployments happened without YANG models - I’m not sure how much the MIBs were used?

For keyed IP tunnel the YANG model is critical (as there’s no L2TP signalling so both ends of each tunnel need to be configured with the same IPv6 addresses, session IDs and cookies), so I’m not sure I’d want to slow the YANG models down by seeking commonality with a generic L2TP model that might not get used.

Giles

> On 28 Oct 2016, at 14:36, Carlos Pignataro (cpignata) <[email-masked]> wrote:
>