Subject: RE: Questions regarding the VPLS

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Fri, 8 Aug 2003 18:20:40 -0400

Eric Rosen wrote:
> 
> Dunstan> Does this not bring back n^2 issue for addition of 
> another PE. 
> 
> You do end up with n^2  pseudowires, but since the 
> intermediate nodes do not
> have to hold any per-pseudowire state, there is no n^2 issue. 
> 

That is true for the non-distributed model. In a decoupled VPLS solution, the intermediate nodes (i.e. the N-PEs) do hold per-pseudowire state.

A few observations:

1) Strictly speaking, there is no n^2 issue. A single VPLS instance needs a full mesh of Pseudo Wires, but the total number of PWs in a network scales linearly with the number of VPLS instances.

2) That said, the total number of PWs could become large. Based on experience with other L2 services, the average number of attachment circuits per VPN is around 20. The number of PWs per VPLS is probably in the low hundreds. 

3) The primary solution for dealing with a large number of PWs is tunneling. However, in a non-distributed model that becomes unwieldy. Strictly speaking, it is still not an n^2 problem, since you don't need a full mesh of transport LSPs between all PEs. You only need LSPs between those PEs that support at least one common VPLS instance. But still, the number of transport LSPs becomes large.

4) The next step is a distributed (decoupled) model. Through the use of intermediate aggregation points, the number of transport LSPs decreases significantly, but the price you pay is that the intermediate nodes must hold per-PW state. I agree with Neil Harrison that this is a fundamental truth of connection-oriented services: one way or another you have to deal with a large number of point-to-point connections.

5) Personally, I think that through smart usage of tunneling and decoupling (i.e. intermediate PW switching), it is possible to build infrastructures that can support very large numbers of VPLSs. However, I think that that requires more flexibility than it offered by the current GVPLS proposal which assumes that on any path there will be at most two intermediate aggregation points.

Peter

---

From: Eric Rosen <[email-masked]>
Date: Mon, 11 Aug 2003 13:23:27 -0400

Peter> 1) Strictly  speaking, there is no n^2 issue.  A single VPLS instance
Peter>    needs a full mesh of Pseudo  Wires, but the total number of PWs in
Peter>    a network scales linearly with the number of VPLS instances.  

I think in  this context n would be  the number of PEs, and it  is then true
that the number  of PWs needed in a particular VPLS  instance is O(n^2).  If
we ignore the  distributed VPLS for a moment, the point  is that there isn't
any node whose  resources need to scale up at O(n^2).   Resources at the PEs
scale as O(n), and resources as  the intermediate nodes are unaffected by an
increase in the number of PEs.

It is  true that if some node  is mediating the signaling  between two other
sets of nodes  (as in distributed VPLS), the node doing  the mediating has a
scaling problem on the order of the product of the sizes of the two sets.

Peter>  That said, the total number of PWs could become large. 

Yes, and that is why L2 scales  poorly when compared to L3.  If you want the
number of PEs to be able to increase in a scalable manner, try L3VPN!

If one  used spanning tree instead of  full mesh with split  horizon, a PE's
pw-related resources  would not need to  scale up even at  O(n).  Of course,
there  are other  scaling  limitations that  would  then arise,  due to  the
sub-optimal routing, the need to explicitly manage the overlay, etc. 

Peter> the number of transport LSPs becomes large. 

No  problem, use mp2p  "transport LSPs"  and the  state at  the intermediate
nodes is marginal.