Subject: RE: On VPLS and Routing Protocols

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 8 Aug 2003 14:35:59 -0400

Not true.

In my example PE A would block emulated LAN port to
VPLS instance x. PE Z or for that matter any PE in VPLS
instance x would know that PE A has blocked emulated LAN
port.

Using  your example, if PW data plane fails, PE Z would block
emulated LAN port for VPLS instance x only.. No other PEs
participating in VPLS instance x would know that PE Z has
blocked his emulated LAN port for VPLS instance x.  And
neither would PE Z block emulated LAN port for VPLS
instance other than x.  

Isn't this somewhat similar to what bridges do today?
Blocking of a Bridge port is not notified to anybody. It is local
decision based on information received from the BPDU.

/himanshu

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Friday, August 08, 2003 1:13 PM
> To: Shah, Himanshu
> Cc: 'Alex Zinin'; [email-masked]
> Subject: Re: On VPLS and Routing Protocols 
> 
> 
> 
> Himanshu> If a PW from PE A to PE Z fails for VPLS instance x,
> Himanshu> PE A simply blocks bridge port to VPLS instance x. 
> 
> So if the pseudowire data plane fails  entirely at PE Z, this 
> means that all
> other PEs block  their Emulated LAN ports for VPLS  instance 
> x.  I.e., every
> VPLS instance supported by PE Z is 100% down. 
> 
> 
>

---

From: Eric Rosen <[email-masked]>
Date: Fri, 08 Aug 2003 17:00:22 -0400

Eric> So if  the pseudowire data  plane fails entirely  at PE Z,  this means
Eric> that all other PEs block their Emulated LAN ports for VPLS instance x.
Eric> I.e., every VPLS instance supported by PE Z is 100% down.

Himanshu> Using  your example,  if PW  data plane  fails, PE  Z  would block
Himanshu> emulated  LAN  port  for  VPLS  instance x  only.  No  other  PEs
Himanshu> participating in VPLS instance x would know that PE Z has blocked
Himanshu> his emulated LAN port for VPLS instance x. 

What you  say is true,  but it  does not contradict  what I said.   Every PE
supporting VPLS instance x has a PW to  PE Z, so if PE Z fails, every one of
those PWs will fail, and every  PE supporting VPLS instance x will block its
Emulated LAN interface  for VPLS instance x. Of course,  one PE doesn't know
that another PE has done this, nevertheless they all do it.