Subject: RE: Questions regarding the VPLS

From: [email-masked]
Date: Fri, 8 Aug 2003 19:30:57 +0100

Christopher, Dunstan wrote 08 August 2003 19:04

> Any-to-any service requires fully meshed VCs due to the 
> "split horizon rule" of learning and forwarding across the 
> VPLS leg points. 
> a) What is the reason for Tunnel LSPs to be meshed across the 
> PE-PE ? Does this not bring back n^2 issue for addition of 
> another PE.
NH=> This issue is so important I can't let it pass without comment.  In a
co-ps mode only p2p and p2mp topology constructs are architecturally valid.
(I will avoid getting into the discussion of the architecturally wrong mp2p
merging case here, except to note that the only way to demerge is to run p2p
trails above these *if* their client layer is not cnls).  This means that if
A wants to talk to B then A has to have (trail) connectivity in the
data-plane with B....that is just a fact that cannot be avoided.  So you
cannot avoid this *ever* with a co-ps mode (or indeed a co-cs mode).  You
can stack trails (ie put in hierarchy) to improve scaling (something we have
been doing in Telecoms since forever it seems). The only way to avoid the
so-called N^/2 connectivity problem is not to have any data-plane
connections at all, ie use a true cnls mode.

All 3 modes (ie cnls, co-ps and co-cs) have different behaviours (which is a
good thing) and we need them all.  What we don't want is to have them
corrupted by inappropriate treatment......not sure everyone has grokked the
importance of this yet however.

regards, Neil
<snipped>

---

From: "Christopher, Dunstan" <[email-masked]>
Date: Fri, 8 Aug 2003 14:30:06 -0600

Does the PE-PE tunnels have to be meshed for L2VPNs ?
Can we get away with segmenting the tunnel from PE-P, P-P and P-PE? 
Would P help in L2VPN to alleviate meshed tunnel LSPs ?

regards,

Dunstan Christopher

-----Original Message-----
From: Vach Kompella [mailto:[email-masked]]
Sent: August 8, 2003 3:49 PM
To: Christopher, Dunstan; [email-masked]
Subject: RE: Questions regarding the VPLS

However, the n^2 issue isn't the same as the n^2 issue of ATM VCs.  Here, the
tunnels carry multiple services.

-Vach

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Christopher, Dunstan
> Sent: Friday, August 08, 2003 11:04 AM
> To: [email-masked]
> Subject: Questions regarding the VPLS
>
>
>
> Any-to-any service requires fully meshed VCs due to the "split
> horizon rule" of learning and forwarding across the VPLS leg points.
> a) What is the reason for Tunnel LSPs to be meshed across the PE-PE ?
> Does this not bring back n^2 issue for addition of another PE.
> b) What are the other technical alternatives to provide VPLS service
> based on  non PE-PE meshed tunnels when P is introduced?
>
>
> regards,
>
> Dunstan Christopher
>
>
>

---

From: "Christopher, Dunstan" <[email-masked]>
Date: Fri, 8 Aug 2003 13:58:36 -0600

Vach Kompella,
Does the PE-PE tunnel E-LSP have to be meshed for L2VPN ?
Can we get away with creating the segmenting the tunnel from PE-P, P-P and P-PE? 
Would P help in L2VPN to alleviate meshed tunnel LSPs ?

regards,

Dunstan Christopher

-----Original Message-----
From: Vach Kompella [mailto:[email-masked]]
Sent: August 8, 2003 3:49 PM
To: Christopher, Dunstan; [email-masked]
Subject: RE: Questions regarding the VPLS

-Vach

---

From: [email-masked]
Date: Fri, 8 Aug 2003 22:28:25 +0100

> Dunstan> Does this not bring back n^2 issue for addition of 
> another PE. 
> 
> Eric> You do end up with n^2  pseudowires, but since the 
> intermediate nodes do not
> have to hold any per-pseudowire state, there is no n^2 issue. 

NH=> Agreed Eric....but this is hierarchy at work.....the basic n^2 'truth'
still holds.

regards, Neil

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 12 Aug 2003 16:51:30 -0400

Vach,

> tunnels carry multiple services.

True. In addition to that the n^2 PE-PE tunnels is a bit
different from the n^2 layer-2 services running across
these tunnels. The complexity of the former depends on the 
number of PEs and the engineering of
the provider network and impacts only the provider network
while the complexity of the latter depends on 
the number of l2vpns and the number of sites for each VPN
that requires connectivity to all the other sites, and
the impact can be on both provider and customer networks
(if we assume that routing needs to be configured on top 
of these VCs).

Hamid.