Subject: RE: VPN Identifiers

From: [email-masked]
Date: Wed, 13 Aug 2003 07:22:23 +0100

Hamid,

I understand that your GID draft is not intended to solve the problem of
defining a unique VPN-ID format and I agree that RFC2685 meets the
requirements for a VPN-ID. If there is consensus that this is the best VPN
ID to use then I would like to see all the drafts support its use.

Richard

> -----Original Message-----
> From: Hamid Ould-Brahim [mailto:[email-masked]]
> Sent: 12 August 2003 19:16
> To: Spencer,R,Richard,XGH5 R; [email-masked]
> Cc: [email-masked]
> Subject: RE: VPN Identifiers 
> 
> 
> Richard,
> 
> [clipped...]
> 
> > 
> > The point is that currently different mechanisms use 
> different VPN ID
> > formats. 
> 
> I would say instead "different mechanisms use different global unique
> identifiers some of them are intended to uniquely identify a VPN."
> 
> >If it is decided that 
> > draft-ouldbrahim-ppvpn-gid-03.txt is the best
> > VPN ID format to use then that's fine, but for inter-dependency and
> > interoperability reasons it should be used across all VPN 
> mechanisms.
> > Looking at draft-ouldbrahim-ppvpn-gid-03.txt, do we really 
> > need 4+ different
> > naming methods for a VPN? I think two options for global 
> > identifiers at the
> > most should be sufficient, i.e. AS#, or OUI, although 
> > obviously one global
> > ID would be preferable.
> 
> draft-ouldbrahim-ppvpn-gid-03.txt tries to define formats for 
> supporting global unique identifiers mainly intended for VPN 
> solutions and mostly targeting control planes, and among these 
> formats it supports the route target and RFC2685 formats within
> an 8 octets length field. These ids are required to be unique 
> only within a given solution and they do not necessarily identify 
> a VPN. A particular solution may decide to assign a gid to uniquely 
> identify a VPN if it wants to, and may want to use gids for other
> purposes as well. 
> 
> The draft does not solve the problem of defining a unique VPN-ID 
> format intended to be used everywhere across all solutions including 
> management. In my view if one wants to solve this problem and enforce 
> that id on all solutions and on all the components of a given solution
> then there is already rfc2685 standard which pretty 
> much meets the definition you mentioned below. Whether solutions 
> within l2vpns will be using it everywhere is obviously 
> another thing. 
> 
> Hamid.
> 
> > 
> > Richard
> > 
> > > -----Original Message-----
> > > From: Eric Rosen [mailto:[email-masked]]
> > > Sent: 11 August 2003 18:26
> > > To: Spencer,R,Richard,XGH5 R
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: VPN Identifiers 
> > > 
> > > 
> > > 
> > > We already  have an  8-byte VPN-Id format  which can  be 
> > > based either  on AS
> > > numbers or on OUIs, and is  extensible to other possibilities 
> > > as well.  Have
> > > you looked at draft-ouldbrahim-ppvpn-gid-03.txt? 
> > > 
> > 
> > 
>

---

From: Giles Heron <[email-masked]>
Date: 13 Aug 2003 12:35:39 +0000

Not sure I'd go with that consensus.

OUIs aren't exactly cheap, are they?

Giles

-- 
=================================================================
Giles Heron    Principal Network Architect    PacketExchange Ltd.
ph: +44 7880 506185              "if you build it they will yawn"
=================================================================

---

From: Eric Rosen <[email-masked]>
Date: Wed, 13 Aug 2003 10:00:16 -0400

Richard> If there is  consensus that this is  the best VPN ID to  use then I
Richard> would like to see all the drafts support its use. 

Not much chance of that. 

No one has presented a requirement for a single kind of VPN id.