Subject: RE: On VPLS and Routing Protocols

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 8 Aug 2003 13:02:02 -0400

What I mean by VPLS port blocking is this.

If a PW from PE A to PE Z fails for VPLS instance x,
PE A simply blocks bridge port to VPLS instance x.
It does not send PW status to Z or to any other PEs.
No traffic for VPLS instance x would be forwarded 
to/from any PW by PE A. Thus, isolating all the CEs behind
PE A of VPLS instance x from the rest.

I don't believe this has domino effect because no PE
finds out about bridge port blocking on PE A.

/himanshu

Alex Zinin wrote:
---- stuff deleted ---
> 
> Cheng-Yin:
> 
> > Mick Seaman proposed a solution on IEEE 802.1
> > (or PPVPN?) mailing list prior to this. My understanding of 
> the proposal
> > is - the VPLS entity shall disable the MAC port presented 
> to the 802.1ad
> > bridge if a PW fails. I think Himanshu has described a 
> similar approach
> > ("blocking" VPLS port) in this thread.
> 
> Doesn't this suffer from the same problem Eric pointed out--the whole
> VPLS falling apart when a single node goes down and brings PWs with
> all other PEs down too?
> 
> Alex
> 
> 
>

---

From: Eric Rosen <[email-masked]>
Date: Fri, 08 Aug 2003 13:12:36 -0400

Himanshu> If a PW from PE A to PE Z fails for VPLS instance x,
Himanshu> PE A simply blocks bridge port to VPLS instance x. 

So if the pseudowire data plane fails  entirely at PE Z, this means that all
other PEs block  their Emulated LAN ports for VPLS  instance x.  I.e., every
VPLS instance supported by PE Z is 100% down.