Subject: Questions regarding the VPLS

From: "Christopher, Dunstan" <[email-masked]>
Date: Fri, 8 Aug 2003 12:04:17 -0600

Any-to-any service requires fully meshed VCs due to the "split horizon rule" of learning and forwarding across the VPLS leg points. 
a) What is the reason for Tunnel LSPs to be meshed across the PE-PE ? Does this not bring back n^2 issue for addition of another PE. 
b) What are the other technical alternatives to provide VPLS service based on  non PE-PE meshed tunnels when P is introduced?

regards,

Dunstan Christopher

---

From: "Vach Kompella" <[email-masked]>
Date: Fri, 8 Aug 2003 12:48:40 -0700

However, the n^2 issue isn't the same as the n^2 issue of ATM VCs.  Here, the
tunnels carry multiple services.

-Vach

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Christopher, Dunstan
> Sent: Friday, August 08, 2003 11:04 AM
> To: [email-masked]
> Subject: Questions regarding the VPLS
>
>
>
> Any-to-any service requires fully meshed VCs due to the "split
> horizon rule" of learning and forwarding across the VPLS leg points.
> a) What is the reason for Tunnel LSPs to be meshed across the PE-PE ?
> Does this not bring back n^2 issue for addition of another PE.
> b) What are the other technical alternatives to provide VPLS service
> based on  non PE-PE meshed tunnels when P is introduced?
>
>
> regards,
>
> Dunstan Christopher
>
>
>

---

From: Eric Rosen <[email-masked]>
Date: Fri, 08 Aug 2003 17:06:05 -0400

Dunstan> Does this not bring back n^2 issue for addition of another PE. 

You do end up with n^2  pseudowires, but since the intermediate nodes do not
have to hold any per-pseudowire state, there is no n^2 issue.