Subject: RE: A question regarding section 5.1.1.2 of draft-ietf-l2vpn-sign alin g-00.txt

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 10 Sep 2003 16:35:01 +0200

Eric,
Sorry - missed this point. 
However, I think that referring to a name that must
be unique in some global (AGI) context as "local" 
is misleading (at least, it mis-led me:-).

On the practical side: How can the operator configuring AIIs in a PE 
guarantee their uniqueness in the context that is not local to the
specific PE? A simple way to do that would be to include the
PE IP address (or host name) as part of the AII, i.e. the AIIs would 
look like john@pe1, fred@pe2, fred@pe3 etc., but this would
make moving the attachment circuit from one PE to another 
without reconfiguration of the remote endpoint (the primary 
benefit of the single-sided model) somewhat problematic.
A manual check vs the list of all AIIs in the given AGI does not
seem to be a nice solution either.

In addition, the auto-discovery protocol should be probably capable of 
discovering duplicated AIIs within a given AGI with the appropriate 
consequent actions (at least prevention of establishing PWs + report
of a detected misconfiguration).
But this is probably out of scope of the signaling protocol spec.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Wednesday, September 10, 2003 3:10 PM
> To: Sasha Vainshtein
> Cc: L2VPN (E-mail)
> Subject: Re: A question regarding section 5.1.1.2 of 
> draft-ietf-l2vpn-signalin g-00.txt 
> 
> 
> 
> Sasha> - both  PE-2 and PE-3 have attachment  circuits 
> locally identified as
> Sasha>   <V,  fred>   (looks  perfectly  legal  since  "fred" 
>   is  a  LOCAL
> Sasha>   identification) and configured to  expect <V, john> 
> as their remote
> Sasha>   peers. 
> 
> From the first paragraph of section 5.1.1.2: 
> 
>    The  local  name consists  of  a  VPN-id (signaled  as  
> the  AGI) and  an
>    Attachment Individual Identifier which is unique relative 
> to the AGI. 
> 
> So the situation in which you have two <V, fred>'s is not allowed. 
>

---

From: Eric Rosen <[email-masked]>
Date: Wed, 10 Sep 2003 11:50:14 -0400

Sasha> On the practical side: How can  the operator configuring AIIs in a PE
Sasha> guarantee their  uniqueness in the context  that is not  local to the
Sasha> specific PE? 

Any  VPWS auto-discovery  scheme requires  the  assignment of  ids that  are
unique per  VPN.  One  would need a  provisioning process that  could assign
these,  so  probably  these ids  would  be  integers  beginning with  1  and
incrementing for each new system added to the VPN. 

Whether  the  benefit  of  the  auto-discovery  exceeds  the  cost  of  this
provisioning process is a debatable issue.