Subject: RE: A question regarding section 5.1.1.2 of draft-ietf-l2vpn-sign alin g-00.txt

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 10 Sep 2003 18:55:48 +0200

Eric,
Thank you for a prompt response.
Please see inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Wednesday, September 10, 2003 5:50 PM
> To: Sasha Vainshtein
> Subject: Re: A question regarding section 5.1.1.2 of 
> draft-ietf-l2vpn-sign alin g-00.txt 
> 
> 
> 
> Sasha> On the practical side: How can  the operator 
> configuring AIIs in a PE
> Sasha> guarantee their  uniqueness in the context  that is 
> not  local to the
> Sasha> specific PE? 
> 
> Any  VPWS auto-discovery  scheme requires  the  assignment of 
>  ids that  are
> unique per  VPN.  One  would need a  provisioning process 
> that  could assign
> these,  so  probably  these ids  would  be  integers  
> beginning with  1  and
> incrementing for each new system added to the VPN. 
>
The problem with the VPWS is that it is not enough to generate unique
attachment circuit IDs. The provisioning process must also assign a peer
endpoint ID to any attachment circuit, and assignments of the two peers
must match. If this operation is done manually, it is not any better than
assignment of PW IDs. Automated matching schemes are, IMO, somewhat
problematic.
All such schemes I am aware of make some assumptions on the VPWS topology
(full mesh, hub-and-spokes etc.) and become increasingly complicated
as these assumptions change. So I fully agree with your conclusion below:
>
> Whether  the  benefit  of  the  auto-discovery  exceeds  the  
> cost  of  this provisioning process is a debatable issue. 
> 
> 
> 
>

---

From: Wei Luo <[email-masked]>
Date: Thu, 11 Sep 2003 11:25:41 -0700

Sasha,

Do you think the idea proposed in the Section 4 of the following draft would
enable you to assign locally significant values to attachment circuits while
keep them globally unique in signaling exchanges?

http://www.ietf.org/internet-drafts/draft-luo-l2tpext-l2vpn-signaling-02.txt

Please note it is protocol independent.

---Wei